Using 5.1 Surround Disables Adrenaline 2020 Recording (Temp Fix)

Discussion in 'Videocards - AMD Radeon Drivers Section' started by Eastcoasthandle, Jun 4, 2020.

?

Did the Temp Fix Enable Recording for you?

  1. Yes

    2 vote(s)
    66.7%
  2. No

    0 vote(s)
    0.0%
  3. Other: I will post it

    1 vote(s)
    33.3%
  1. Eastcoasthandle

    Eastcoasthandle Ancient Guru

    Messages:
    2,691
    Likes Received:
    407
    GPU:
    Nitro 5700 XT
    Good to know it's not limited to Sound Blaster.
     
  2. Montville

    Montville Master Guru

    Messages:
    250
    Likes Received:
    26
    GPU:
    Aorus RX 570 4GB
    After some more testing I can say the recording stutter problem relies on the game map's activity - many active enemies much stutter. Hence the driver is either:

    1) just slow code

    or

    2) too many concurrent (monitoring) activities inside the driver overload it
     
  3. Eastcoasthandle

    Eastcoasthandle Ancient Guru

    Messages:
    2,691
    Likes Received:
    407
    GPU:
    Nitro 5700 XT
    I recall FC4 having an issue with the config file:

    1.Navigate to: c:\Users\Your username\Documents\My Games\Far Cry 4\
    2.Open GamerProfile.xml file with Notepad.
    3.Find DisableLoadingMip0 = "0" and change it to DisableLoadingMip0 = "1"
    4.Find GPUMaxBufferedFrames="0" and change to GPUMaxBufferedFrames="1"
    5. Save and start the game.

    See if that helps the stutters while recording.
     
  4. Montville

    Montville Master Guru

    Messages:
    250
    Likes Received:
    26
    GPU:
    Aorus RX 570 4GB
    Hi, I did that but no joy - same problem!
    I returned to the old driver (Display - 26.20.12028.2) and all is fine again.

    lemme know when this problem is fixed

    cya
     

  5. Eastcoasthandle

    Eastcoasthandle Ancient Guru

    Messages:
    2,691
    Likes Received:
    407
    GPU:
    Nitro 5700 XT
    After all this time this still isn’t fixed.
    This was reported a long time ago.
     
  6. Montville

    Montville Master Guru

    Messages:
    250
    Likes Received:
    26
    GPU:
    Aorus RX 570 4GB
    You seriously believe they fix anything like that?
    BTW, recording is still disabled until you set Stereo mode (General/Audio-Channels) - this is an old problem too
     
  7. itpro

    itpro Master Guru

    Messages:
    583
    Likes Received:
    312
    GPU:
    Radeon Technologies
    If you need multichannel audio do not record. First world problems right there. Stay stereo and play your videos happy people.
     
  8. Eastcoasthandle

    Eastcoasthandle Ancient Guru

    Messages:
    2,691
    Likes Received:
    407
    GPU:
    Nitro 5700 XT
    Ok, this might actually be a windows problem. Remember me saying this all seem to crop up when I was alternating between 2.0 and 5.1?
    Well, I decided to see if win10 could fix it on it's own. I right clicked on the horn icon in the lower right corner.
    Selected: Trouble Shoot Sound Problem > Speakers - Sound Blaster "name of the card you have" (Current Default Device) The connector for this device is located...
    Next
    Followed the prompts (YES to any suggestions).
    Yes, Open Audio Enhancements
    Disabled Enhancements
    Closed out and the report came back it was "fixed"

    Now when I click on "Configure" for Speakers it's now in Stereo mode instead of 5.1.
    For some odd reason doing this manually without the Trouble Shoot Sound Problem didn't cause the change. It took me using Trouble Shoot Sound Problem 1st.

    So now I can adjust:
    Separate Microphone Track: Disable
    Audio Channels: Automatic
    Reboot PC and now recording still works.

    But it's odd that Relive (or whatever they call it now) won't work if you have it set to 5.1.
     
  9. Montville

    Montville Master Guru

    Messages:
    250
    Likes Received:
    26
    GPU:
    Aorus RX 570 4GB
    First World problem? ... more like incompetent driver department at the job unwilling to improve at all

    Radeon is a windows application hence who/whatever is responsible...
     
  10. Eastcoasthandle

    Eastcoasthandle Ancient Guru

    Messages:
    2,691
    Likes Received:
    407
    GPU:
    Nitro 5700 XT
    Relive and 5.1 should still be able to record. There is no excuse for that. But its also equally baffling why win10 was defaulting to 5.1 when switching between stereo and 5.1.

    In any case I will continue testing to make sure this is actually fixed.
     

  11. Eastcoasthandle

    Eastcoasthandle Ancient Guru

    Messages:
    2,691
    Likes Received:
    407
    GPU:
    Nitro 5700 XT
    Ok, good news and bad news.
    Good news is that doing the troubleshoot method works.
    Bad news is that I have to do that every boot up.
     
  12. Montville

    Montville Master Guru

    Messages:
    250
    Likes Received:
    26
    GPU:
    Aorus RX 570 4GB
    Save your time as it will never be fixed - even on Automatic setting it fails to enable Recording hence Automatic fails its task right away. You have to explicitly set to Stereo or no recording at all (I see Why). AMD's Kmart attitude will drive people away from their constant quality issues..
     
  13. Eastcoasthandle

    Eastcoasthandle Ancient Guru

    Messages:
    2,691
    Likes Received:
    407
    GPU:
    Nitro 5700 XT
    You know what I think you are right. It's something to do with the automatic option. I've seen it work on automatic one time. And it seems to happen after a fresh driver install which is what I was doing. But when I try again it doesn't work after that. That's when I have to use stereo or the mic option.
     
  14. 1EvilMan

    1EvilMan New Member

    Messages:
    1
    Likes Received:
    1
    GPU:
    Msi R7870 Hawk 2gb
    I enabled separate mic track and have no issues with recording, except now I have to learn how to include the separate mic track in a finished video if I want to.
    Thanks for helping me keep my sanity
     
    Eastcoasthandle likes this.
  15. Eastcoasthandle

    Eastcoasthandle Ancient Guru

    Messages:
    2,691
    Likes Received:
    407
    GPU:
    Nitro 5700 XT
    Ok, with 20.9.1 The issue appears to be fix!!!!
    I don't have to enabled separate mic to get recording to work.
    To whomever addressed this, thanks!!
     

  16. Krteq

    Krteq Master Guru

    Messages:
    667
    Likes Received:
    207
    GPU:
    RX Vega 56 +64 BIOS
    Yep, I can confirm that on Vega :)
     
  17. Eastcoasthandle

    Eastcoasthandle Ancient Guru

    Messages:
    2,691
    Likes Received:
    407
    GPU:
    Nitro 5700 XT
    I'm glad it fix it for you. Progress right?
    As for me, as I noted in the other thread for some reason my default audio was changed to Aorus and not Sound Blaster. When I changed it back to SB the issue returned.
     

Share This Page