Using 5.1 Surround Disables Adrenaline 2020 Recording (Temp Fix(

Discussion in 'Videocards - AMD Radeon Drivers Section' started by Eastcoasthandle, Jun 4, 2020.

?

Did the Temp Fix Enable Recording for you?

  1. Yes

    2 vote(s)
    66.7%
  2. No

    0 vote(s)
    0.0%
  3. Other: I will post it

    1 vote(s)
    33.3%
  1. Eastcoasthandle

    Eastcoasthandle Ancient Guru

    Messages:
    2,667
    Likes Received:
    383
    GPU:
    Nitro 5700 XT
    Ok, after spending a day researching this I've found that using 5.1 Surround (as pictured below) disables "Record A Video" from Adrenaline 2020.

    [​IMG]



    In my prior post using Spatial Sound would force 2.0/Stereo thus having the same effect as disabling 5.1.

    Could someone who uses headphones only test this to see if you get the same experience?

    -Type a search box: Change System Sounds > Playback Tab > Speakers > Configure: Go from Stereo to 5.1 Surround (next, next, next)
    -Right Click on Desktop and select AMD Radeon Software > Gear Icon in Upper Right corner > General > Enable Record Desktop
    -Home > Record a Video

    Are you able to Record going from Stereo to 5.1?

    Update:

    It seems that if you Enable Separate Mic Track you can leave Audio Channels on Automatic. Thus Recording will work. So the issue appears to stem from Separate Mic Track having a negative effect on Audio Channels which causes Recording to only work if you either:
    A. Change it to Stereo.
    B. Change win10 audio settings to Stereo (which doesn't work as on reboot it reverts back to 5.1 do to audio device requirements)

    The issue was mitigated/circumvented with the use of Microsoft's Store variant of DTS Unbound/Dolby Acesss as that required and forced Stereo in win10 through Spatial Sound.


    Temporary Solution:
    Enable Separate Mic Track.
    Hope that RTG is capable of fixing the issue.

    Edit:

    Addendum to investigation:

    It appears there is some sort of conflict with how Sound Blaster's Command use of headphones. If you disable Sound Blaster Audio Service AE Series (found in services) and reboot (Disable: Separate Mic Track). Recording works. As you are now back to Stereo in win10's Speaker option (Configure) found in "Change System Sound > Playback Tab".


    As long as you don't go messing with it you should be fine. But once you do it there is the potential to cause it to get stuck using 5.1. Thus causing the issue with recording. You are suppose to simply disable in Services:
    -Audiosrv
    -AudioEndpointBuilder

    However, both are tied into Creative Audio Service and Sound Blaster Audio Service (In Services) and you would have to stop them 1st in order to do so. Meaning you would stop all 4 1st just to re-start:
    -Audiosrv
    -AudioEndpointBuilder
    then
    -Creative Audio Service
    -Sound Blaster Audio Service (this is the service that causes win10 to default to 5.1)

    But, it doesn't seem to "reset". It will work with that session of win10 but as soon as you reboot it defaults back to 5.1.

    The options all stem around either change audio back to Stereo through:
    -win10
    -Radeon Software's Audio Channels

    Or use Radeon Software's Separate Microphone Track and set it enabled. Which seems the easiest so far.

    Wow, that was fun troubleshooting. But why did it spring up all of a sudden o_O?
    I can answer that. I was changing the default settings and alternating back and forth between speakers and headphones around the time I notice an issue recording (testing stuff). But had no idea it would stick at 5.1 (it set to Stereo in the past). Which is why I believe that if you do the same it may also happen to you if you aren't experiencing this issue.


    End of Investigation :D
     
    Last edited: Sep 16, 2020
    Undying likes this.
  2. Eastcoasthandle

    Eastcoasthandle Ancient Guru

    Messages:
    2,667
    Likes Received:
    383
    GPU:
    Nitro 5700 XT
  3. Eastcoasthandle

    Eastcoasthandle Ancient Guru

    Messages:
    2,667
    Likes Received:
    383
    GPU:
    Nitro 5700 XT
    Ok found a temp. fix for this


    [​IMG]

    You have to use Audio Channels from Automatic to Stereo. Now recording will work even in 5.1.
     
    Montville likes this.
  4. Montville

    Montville Master Guru

    Messages:
    250
    Likes Received:
    26
    GPU:
    Aorus RX 570 4GB
    Tried it, and yes, you are right!
    Still a ridiculous situation especially in year AD2020 - AMD drivers are always fascinating in the faults they produce.

    upvote from me for you for finding this ;)

    you can skip this step - just change to stereo in the driver (audio channels) and recording should work
     
    Last edited: Jun 5, 2020
    Eastcoasthandle likes this.

  5. Krteq

    Krteq Master Guru

    Messages:
    661
    Likes Received:
    204
    GPU:
    RX Vega 56 +64 BIOS
    Yep, confirmed, replicated on my side
     
    Eastcoasthandle likes this.
  6. Eastcoasthandle

    Eastcoasthandle Ancient Guru

    Messages:
    2,667
    Likes Received:
    383
    GPU:
    Nitro 5700 XT
    Thanks for taking the time to confirm this. I've tried 20.4.1/20.4.2/20.5.1 and all exhibit the same behavior.

    There seems to be a bug in the way Audio Channels operate.

    UPDATE
    In the Registry it's found in:
    HKEY_CURRENT_USER\Software\AMD\DVR

    AudioChannelType= Audio Channels
    0=Automatic
    1=Stereo

    MicPassthroughEnabled = Separate Mic Track
    0=Disabled
    1=Enabled

    It seems that if you Enable Separate Mic Track you can leave Audio Channels on Automatic. Thus Recording will work. So the issue appears to stem from Separate Mic Track having a negative effect on Audio Channels which causes Recording to only work if you either:
    A. Change it to Stereo.
    B. Change win10 audio settings to Stereo (which doesn't work as on reboot it reverts back to 5.1 do to audio device requirements)

    The issue was mitigated/circumvented with the use of Microsoft's Store variant of DTS Unbound/Dolby Access as that required and forced Stereo in win10 through Spatial Sound.


    Temporary Solution:
    Enable Separate Mic Track.
    Hope that RTG is capable of fixing the issue.

    End

     
    Last edited: Jun 8, 2020
    Krteq likes this.
  7. Montville

    Montville Master Guru

    Messages:
    250
    Likes Received:
    26
    GPU:
    Aorus RX 570 4GB
    no such options here
     

    Attached Files:

  8. Eastcoasthandle

    Eastcoasthandle Ancient Guru

    Messages:
    2,667
    Likes Received:
    383
    GPU:
    Nitro 5700 XT
    Do a search for AudioChannelType (one word) and see what comes up.
    With AMD Radeon Software Open along with regedit opened change Audio Channels from Automatic to Stereo. Then (with regedit already open and you've found AudioChannelType) refresh Regedit (F5 key) to see if it turns from a 0 to a 1. If so you found the correct location.

    But I want to be clear with you. You don't have to resort to Regedit to fix it. All you have to do is Enable Separate Microphone Track and you are done. It should work after that.
     
    Last edited: Jun 6, 2020
  9. Montville

    Montville Master Guru

    Messages:
    250
    Likes Received:
    26
    GPU:
    Aorus RX 570 4GB
    However, I found it under a different path:
    Computer\HKEY_LOCAL_MACHINE\SOFTWARE\AMD\DVR which is different from yours in post #6

    okay, found that one under General (driver)
     
  10. Montville

    Montville Master Guru

    Messages:
    250
    Likes Received:
    26
    GPU:
    Aorus RX 570 4GB

  11. Eastcoasthandle

    Eastcoasthandle Ancient Guru

    Messages:
    2,667
    Likes Received:
    383
    GPU:
    Nitro 5700 XT
    I see, thanks for checking. Apparently it's in different locations based on hardware.
    I didn't get any stutters, it's smooth as butter on my end.
     
  12. Montville

    Montville Master Guru

    Messages:
    250
    Likes Received:
    26
    GPU:
    Aorus RX 570 4GB
    So we now need a 5700 (or better GPU) to record smoothly?

    Good for you but won't help anyone with a weaker GPU like me - looks like I return to an older driver, where all records smoothly, coz AMD again is unwilling to fix their bad coding.
     
    Last edited: Jun 7, 2020
  13. Eastcoasthandle

    Eastcoasthandle Ancient Guru

    Messages:
    2,667
    Likes Received:
    383
    GPU:
    Nitro 5700 XT
    Yeah, I don't know what to tell you. There has been very little issues I've seen with recording up to now. All I can tell you is to try a reboot. With fastboot disabled in win10. And see if that takes care of the stutter when recording.
     
    Last edited: Jun 7, 2020
  14. Montville

    Montville Master Guru

    Messages:
    250
    Likes Received:
    26
    GPU:
    Aorus RX 570 4GB
    Okay, did a test with Doom (2016) and no such stutterfest issues when recording - seems to be only FC4?!
    I may try other games too..

    Things to mention:
    I play smoothly on 4k display resolution even in FC4 - no issues, just recording stutters the screen
    My C drive is a SSD.m2 (970 Evo) hence more than plenty of juice... as is the CPU (2700x) and 16GB/3200 ram

    why the driver fails on FC4 is puzzling
     
  15. Eastcoasthandle

    Eastcoasthandle Ancient Guru

    Messages:
    2,667
    Likes Received:
    383
    GPU:
    Nitro 5700 XT
    I've always saved records on a drive other then C and the drive the game is on. But that's just me. I recall someone using a fast USB thumbstick at one time (cost less then a SSD at the time). But I never looked into it.
     

  16. Montville

    Montville Master Guru

    Messages:
    250
    Likes Received:
    26
    GPU:
    Aorus RX 570 4GB
    Okay, finally, looks like I (hopefully) fixed the issue - I tried DOOM and even FC3 without recording issues (wth?:)
    Then I trashed C:\Users\Me\Documents\My Games\Far Cry 4... and after that (all settings restored) no more rec stutter!?

    All smooth again...Okay, I hope it stays that way...

    have a good weekend, all! (what's left of it)
     
    Eastcoasthandle likes this.
  17. Eastcoasthandle

    Eastcoasthandle Ancient Guru

    Messages:
    2,667
    Likes Received:
    383
    GPU:
    Nitro 5700 XT
    Glad you got it sorted, enjoy your weekend.
     
    Montville likes this.
  18. Eastcoasthandle

    Eastcoasthandle Ancient Guru

    Messages:
    2,667
    Likes Received:
    383
    GPU:
    Nitro 5700 XT
    I've tried a few more registry/service adjustments along with several reboots. I've concluded that this is coming from the drivers and not win10.

    Could a possible update cause the problem? Well, I reverted them back to last known dates it was working still the same results.

    What seems to trigger this event is if win10 boots up using 5.1.
    IE: Sound Blaster AE series: Sound Blaster Commander seems to default to 5.1 even if you are using headphones virtual surround 7.1. You have to force stereo in order to get stereo in win10.
     
  19. Eastcoasthandle

    Eastcoasthandle Ancient Guru

    Messages:
    2,667
    Likes Received:
    383
    GPU:
    Nitro 5700 XT
    Addendum to investigation:

    It appears there is some sort of conflict with how Sound Blaster's Command use of headphones. If you disable Sound Blaster Audio Service AE Series (found in services) and reboot (Disable: Separate Mic Track). Recording works. As you are now back to Stereo in win10's Speaker option (Configure) found in "Change System Sound > Playback Tab".

    As long as you don't go messing with it you should be fine. But once you do it there is the potential to cause it to get stuck using 5.1. Thus causing the issue with recording. You are suppose to simply disable in Services:
    -Audiosrv
    -AudioEndpointBuilder

    However, both are tied into Creative Audio Service and Sound Blaster Audio Service (In Services) and you would have to stop them 1st in order to do so. Meaning you would stop all 4 1st just to re-start:
    -Audiosrv
    -AudioEndpointBuilder
    then
    -Creative Audio Service
    -Sound Blaster Audio Service (this is the service that causes win10 to default to 5.1)

    But, it doesn't seem to "reset". It will work with that session of win10 but as soon as you reboot it defaults back to 5.1.

    The options all stem around either change audio back to Stereo through:
    -win10
    -Radeon Software's Audio Channels

    Or use Radeon Software's Separate Microphone Track and set it enabled. Which seems the easiest so far.

    Wow, that was fun troubleshooting. But why did it spring up all of a sudden o_O?
    I can answer that. I was changing the default settings and alternating back and forth between speakers and headphones around the time I notice an issue recording. But had no idea it would stick at 5.1 (it set to Stereo in the past). Which is why I believe that if you do the same it may also happen to you if you aren't experiencing this issue.


    End of Investigation :D
     
    Last edited: Jun 8, 2020
  20. Montville

    Montville Master Guru

    Messages:
    250
    Likes Received:
    26
    GPU:
    Aorus RX 570 4GB
    I am not that often recording a gaming session hence can't tell this latest win10 update is the culprit. What I do know is the older GPU drivers (19.4.3 in my case) did not show such recording stutter issues even with the latest Win10 update (19041.264)

    Yes, I too believe it's a driver issue even it is generally working for me but it's not 100% stable especially recording long sessions (30+ minutes) the stutter can be back.

    I am not using SBlaster - just Realtek 5.1 sound
     

Share This Page