Used Sapphire Pulse RX 570

Discussion in 'Videocards - AMD Radeon' started by MaCk0y, Feb 6, 2020.

  1. MaCk0y

    MaCk0y Master Guru

    Messages:
    970
    Likes Received:
    370
    GPU:
    GB 5700XT Gaming OC
    I've got this graphic card that was bought used. Can anyone please tell me what the stuff on the cooler is?

    [​IMG]

    [​IMG]

    [​IMG]

    [​IMG]

    [​IMG]

    [​IMG]
     
  2. Undying

    Undying Ancient Guru

    Messages:
    15,744
    Likes Received:
    4,770
    GPU:
    Aorus RX580 XTR 8GB
    Is the card even working? That looks like some type of corrosion.
     
  3. SpajdrEX

    SpajdrEX AMD Vanguard

    Messages:
    2,805
    Likes Received:
    1,087
    GPU:
    Sapphire RX 6800XT
    Looks like dust combined with something from cigarette smoke
     
  4. MaCk0y

    MaCk0y Master Guru

    Messages:
    970
    Likes Received:
    370
    GPU:
    GB 5700XT Gaming OC
    The GPU worked for a month but now not powering on at all. No fan spin, no LED lights. Though I haven't tried it again yet after disassembling it. Temperatures were good.

    It seems to be kind of dust in combination with something else like SpajdrEX suggested that is stuck on pretty well. When I try to brush it off, I see dust smoke rising in the air.
     

  5. Astyanax

    Astyanax Ancient Guru

    Messages:
    10,578
    Likes Received:
    3,871
    GPU:
    GTX 1080ti
    thats white mould and dust, this card has been stored somewhere with high humidity.
     
    MaCk0y likes this.

Share This Page