Updated XP64 Patchscript for HD2x00 series

Discussion in 'RivaTuner Advanced Discussion forum' started by schoko, Jan 24, 2008.

  1. maxtorag

    maxtorag Member

    Messages:
    49
    Likes Received:
    0
    GPU:
    Asus Radeon HD2900XT @ FireGL V8650
    Yeh I know about that workaround...and I don't think it's a processor problem...had Intel Core Quad with Quadro fx1400 without the problem, have intel core duo and geforce 7900GS without the problem and have Quad with modded V8650 and always the problem :(

    Btw...I am not sure if anyone else experienced this problem, but...with the 8.39 x32 mod, sometimes switching the shelf in Maya on/off or quick Alt-Tab to e.g. Photoshop caused a critical error of ati driver (thus bug report on blue screen) and restart. I did not experience this bug with 8.44 x32 mod. But sadly I am experiencing this porblem again with 8.39 x64 mod...

    Any advice, schoko?

    Btw...it happened with Maya 2008 and 8.5 also

    How does it look with 8.44 x64 mod?
     
  2. maxtorag

    maxtorag Member

    Messages:
    49
    Likes Received:
    0
    GPU:
    Asus Radeon HD2900XT @ FireGL V8650
    I don't have that file anymore...if you send it to me...I will check that for you ;)
     
  3. Fragmichnicht

    Fragmichnicht Member

    Messages:
    24
    Likes Received:
    0
    GPU:
    8800 GT
    Hi Maxtorag,

    Thank you for your offer! http://rapidshare.com/files/90684412/hand_smooth.rar.html

    I am sorry, I have seen that I have not the original hand.ma file. I have applied a single mesh smooth to the originals, to make it evil and get a proper lag at my 8800GT. As far as I can remember the problem was that I got no lag, so I have modified the real hand model to understand what "hand.ma file selection lag" means. I have a lag of 1.5 seconds.
    In addition if you press play in Maya the models rotates and you can see how fast your persp view works in fps (Display > Heads Up Display > Frame Rate).
    I have 8.5 frame per second. You should get something around 34 FPS, if these Specviewperfs are a reasonalbe benchmark.

    Thanks Again!
     
  4. NormanBates

    NormanBates Master Guru

    Messages:
    376
    Likes Received:
    0
    GPU:
    ATI HD3870 / ATI HD4670

  5. maxtorag

    maxtorag Member

    Messages:
    49
    Likes Received:
    0
    GPU:
    Asus Radeon HD2900XT @ FireGL V8650
    Sooo...nice of you guys, but sadly rapidshare does not work for me...some kind of bug with my ISP :wanker:
    try http://depositfiles.com - no problem with them ;)
     
  6. Fragmichnicht

    Fragmichnicht Member

    Messages:
    24
    Likes Received:
    0
    GPU:
    8800 GT
    Hi there,

    I have uploaded my disgusting persp view nightmare hand_smooth.rar at depositfiles. Have fun!
    http://depositfiles.com/files/3481272
     
  7. NormanBates

    NormanBates Master Guru

    Messages:
    376
    Likes Received:
    0
    GPU:
    ATI HD3870 / ATI HD4670
    ooops... after asking so loudly for a 64-bit patch, I find out now that there is no PLE for x64, so I won't be able to test this on my home PC, where my modded HD2600@v5600 lives :(

    i may put on a wooden leg and an eye patch for a couple of days, just to test if the mod works... or maybe not, it just doesn't make that much sense anymore...

    sorry, guys
     
  8. dhatadi

    dhatadi New Member

    Messages:
    3
    Likes Received:
    0
    I am also interested in this too. It sounds likely that this newer driver will fix the selection bug. I'm interested in getting a HD2900XT for use with Maya.

    Schoko, you are doing a brilliant job! Keep up the good work.

    Cheers,
    Daniel
     
  9. maxtorag

    maxtorag Member

    Messages:
    49
    Likes Received:
    0
    GPU:
    Asus Radeon HD2900XT @ FireGL V8650
    Bad news guys :(
    Tried that smoothed hand.ma provided by fragmichnicht and the results:
    1) basically unable to selec a hand just by clicking in viewport...Maya basically freezes...or calculates, I am not sure, but after a minute I always terminated the process
    2) I was able to select a hand by selection drag, but it took around 30 secs

    looking forward to new script, schoko :3eyes:
     
  10. Fragmichnicht

    Fragmichnicht Member

    Messages:
    24
    Likes Received:
    0
    GPU:
    8800 GT

    Oh no :cry: that is awful, sorry to hear about Maya freezes. Those smoothed hand.ma have 3.674.304 Edges. That's a lot, but not too much. I have worked last year on a huge scene with nearly 17.000.000 Edges on my old Workstation (Quadro FX4000, P4). That was paintful but feasible. Okay, forget rotate but it was always possible to select something without a lag and work (rotate) in a short distance.
    Have you tried to press PLAY in Maya? How many FPS do you get?
     

  11. schoko

    schoko Member Guru

    Messages:
    178
    Likes Received:
    0
    GPU:
    Hd2600 Mobility

    seems to be the problem is on your side, and most likely a new script won´t help either. maybe you wanna check for the error on your side

    i have just opened the hand.mb file from fragmichnicht, and i don´t have any problems here at all selecting the hand in shaded mode.
    it takes around 2 seconds from the moment i click on the hand , until the hand is highlighted and ready for transformation.

    i have the hd2600 mobility running as v5600 with mobility features under xp64. my maya is 64bit also, and i´m using the 8.391.2.1.1.1 driver.

    so i guess this lag of 2 seconds (in words: two) seconds cannot really be called a selection lag.

    as a reminder one hand has 1837152 edges. selecting both hands with selection window gives me the same 2 seconds.

    and during i did this i had another maya session open with a huge nurbs model, that was rendering in maxwell, at the very same time.
    NO PROBLEM with the selection lag on my notebook.

    and to add this too, i don´t have the selection bug here either, maya always selects the object that is closer to the camera.

    I state this again : I do NOT have the selection bug and the selection lag with my setup.
     
    Last edited: Feb 11, 2008
  12. Fragmichnicht

    Fragmichnicht Member

    Messages:
    24
    Likes Received:
    0
    GPU:
    8800 GT

    Hi Schoko!

    Thanks for the infos! That sounds great.:rock: Maybe I should buy a Radeon 2600 XT, there some nice offers at ebay. A 2 sec selection lag is nearly the same what I got for those scene in maya (8800GT). So that should be normal and by the way that is realy good with a large scene rendering in the background in a second maya session.
    How fast is your mobil FireGL v5600? Have you tried to press PLAY in Maya in that evil hand_smooth.mb scene? How many FPS do you get? I have 8.5 frames per second. (Display > Heads Up Display > Frame Rate)
     
  13. NormanBates

    NormanBates Master Guru

    Messages:
    376
    Likes Received:
    0
    GPU:
    ATI HD3870 / ATI HD4670
    Hi again

    just so you know, with xp32 and 8.44 and the evil hand_smooth...

    * hit play: nearly 60fps
    * select a hand with a click: 27 seconds
    * select a hand with a window: 17 seconds
    * right-click to go to vertex: 14 seconds
    * rickt-click to exit vertex: 60 seconds
    * deselect a hand: 13 seconds

    and while it lags the cpu use goes to 25% (so 100% of the one core Maya is using)
     
  14. maxtorag

    maxtorag Member

    Messages:
    49
    Likes Received:
    0
    GPU:
    Asus Radeon HD2900XT @ FireGL V8650
    That is weird. How come that schoko does not have any problems? What do you think could be a problem on my side?

    Thanks Norman for such a descriptive breakdown. Tomorrow I will try to do something about it and post similar breakdown. It could be close to my scenario.

    When I tried to rotate, I had around 80fps. And selection using Outliner was instant without any noticeable delay. So I do NOT know any reason that could be slowing my Maya this way. I dont have x32 system anymore, but I can tell, that the lag with my other scenes I use was basically the same with 8.39x32, 8.44x32 and also 8.39x64. Just this hand is giving me hard time. But still, I experience and experienced SOME lag with two systems and three scenarios, so it hardly can be a problem on my side. Can you try to give me a clue, schoko?
     
  15. maxtorag

    maxtorag Member

    Messages:
    49
    Likes Received:
    0
    GPU:
    Asus Radeon HD2900XT @ FireGL V8650
    Oh, and just to add...I have xp64 sp2...
    so...just to repeat, everything works like a charm, speed, overlays etc., but selection lag is there...how could that be explained against schoko's statement?
     

  16. Fragmichnicht

    Fragmichnicht Member

    Messages:
    24
    Likes Received:
    0
    GPU:
    8800 GT
    Thanks a lot Norman! Here are my results (with xp64 sp2, Maya 8.5 x64, 8800GT):

    * hit play: nearly 8.5fps :sleep2:
    * select a hand with a click: 1.5 seconds
    * select a hand with a window: 0-0.5 seconds
    * right-click to go to vertex: 0-0.5 seconds
    * rickt-click to exit vertex: 0-0.5 seconds
    * deselect a hand: 1.5 seconds

    Please let me know if I can help in anyway to support your fight against the lag. :vader:
     
  17. NormanBates

    NormanBates Master Guru

    Messages:
    376
    Likes Received:
    0
    GPU:
    ATI HD3870 / ATI HD4670
    (remember I have XP32)
     
  18. noney

    noney New Member

    Messages:
    9
    Likes Received:
    0
    GPU:
    2600XT@firegl5600
    first of all thanks to schoko....

    ok so i modified my 2600xt to firegl.....and @norman i have the about same configuration u have (Q6600(not overclocked), 4gb ram 800mhz ,abit ip35) but my lag is no where as severe as u ......i am on 8.39 xp 32 driver and have maya 2008 unlimited;)

    i download the hand file u uploaded and tested it


    * select a hand with a click: round about 2-3 seconds
    * select a hand with a window: i dont know what it is but if u meant drag selection then it also takes 2-3 seconds :(
    * right-click to go to vertex: >1 second
    * rickt-click to exit vertex: >1 second
    * deselect a hand: >1 se.cond

    i tried to select a vertex and that thing took some 10-15 second :D.....

    also i juss drag and drop the hand file instead of double clicking it to open...

    one think i would like to ask u @schoko is that .....did u installed the scripted driver on freshly formatted hard drive?....cause i had 2600xt driver previously and i just updated it ......so i am thinking it may be the case of this small lag........

    edit : also with my 2600xt driver the wrong selection of the background object happened a lot but with this driver it didnt :D.....i can live with the lag but that thing was annoying :p

    edit:and also @norman maya does use one core more on my pc but it never hits 100% on one core.other also share the load and on my pc it also gives around 25% cpu utilization.

    and i am not sure about this but my maya had that severe lag after the mod (i can recall that after i downloaded hand and opened it by double clicking it, it did took 17 sec to select hand )but then i had to repair my maya installation after i didnt close the maya properly(if u press power on/off button to shutdown while maya is running it gets corrupted).... .....i dont know if it was the repair or somthing but things have improved ......a lot!!!
     
    Last edited: Feb 13, 2008
  19. maxtorag

    maxtorag Member

    Messages:
    49
    Likes Received:
    0
    GPU:
    Asus Radeon HD2900XT @ FireGL V8650
    I don't know, guys...there is something weird about this hand scene...
    When I open or drag-and-drop it and hit play, I get around 95fps. After selecting one of the hands and reopening the scene, I get a 5fps playback...And as I mentioned previously, when trying to select just by clicking, Maya starts to pack up continuously more and more RAM so I have to terminate it.

    For reference, when I use one of my working scenes with 5.4mil faces, selection of one of the objects just by clicking takes around 35secs, drag selection takes around 25secs and while thumbling I get around 45-50fps.

    But still, I was doing a fresh install, repair of maya and so on and still this bad lag... So if schoko is right, there is either a luck parameter to setting up the mod right (which could be the case also in noney's situation), or I have some hardware issues ;)

    On my other x64 boot system where I had 8.1 Catalyst drivers, the lag was actually 3 times lower and I was even able to select a hand by clicking. After installing 8.39 mod there, the bug was back again the same way it is in the other system.

    Oh, and btw...do you use a profile in CP, or just the default? And could my source of the problem be the fact, that I use a 512GDDR version modded to 8650 (which is 1GB GDDR)?
     
    Last edited: Feb 13, 2008
  20. noney

    noney New Member

    Messages:
    9
    Likes Received:
    0
    GPU:
    2600XT@firegl5600
    i dont use those profile as i am not sure what they do......i did install the cp just to see what it was :D

    anyway at any given moment while working on that hand1.ma my ram usage is about 450 mb .....when i click to select my three core works together (and still they give the lag of 2 sec :p) ......but when i do the things from context menu like vertex ,face ,and select all then only one core works and gives no lag at all......whats up with that ???
     

Share This Page