Unwinder: How about ATI 9x00 to FireGL X1? SoftQuadro for ATI?

Discussion in 'RivaTuner Advanced Discussion forum' started by Spike Lee III, Jan 8, 2003.

  1. RabS

    RabS Guest

    Was this using the drivers from dell
     
  2. i got the 1021 drivers from ati website...
     
  3. PaQ

    PaQ Member

    Messages:
    17
    Likes Received:
    0
    GPU:
    Ati Radeon 9700 Pro
    Well it works with the dell and the ati drivers ... but I had some glitches in lightwave with the 1021 from ati (with the grid) ... with the dell's driver it's ok so far !
     
  4. dezire2003

    dezire2003 New Member

    Messages:
    6
    Likes Received:
    0
    Instructions

    INstructions!!!

    Download Fire Gl x1 driver from Dell. Called R55024.exe.
    Unzip to a location c:/r55o24 folder for instance
    Open Rivetuner...Select "power user" and then "open patch script"
    Choose folder "patch scripts" then "ati" then "softfiregl"
    then "1024+", select file "SoftFireGL w2k"...Select X1 or Z1!!then continue.
    RIvatuner will then ask you to locate the "ati2mtgl.sys" ----this is located
    folder that you unzipped (r55o24). Direct to this location and bingo!
    Next.
    Go to device manager (right click my computer)
    Select your display driver tab.
    Select primary display source.
    Choose "update from list" then "dont search, I will choose.."
    The "have disk". Browse to location of unzipped folder (r55o24)
    Select "atiixpgl.inf", then click ok.
    Finally choose "ATI FIRE GL X1 AGP PRO" from list and ok..blah, blah..Then
    "continue anyway" etc.
    Repeat this proceedure for the Secondary Display device in the device Manager.
    Choose "ATI FIRE GL X1 AGP PRO SECONDARY VIDEO.." . END>
    Hope this helps guys ;)
     

  5. PaQ

    PaQ Member

    Messages:
    17
    Likes Received:
    0
    GPU:
    Ati Radeon 9700 Pro
    >Ok, now an other dumb question:

    Is it normal to have so few settings in the display properties ??? I mean I can config my new firegl:):):) for a lot of 3D softs, but there is only 3 parametres to play with ... (how to config the antialiasing for exemple ?????) ... Maybe there is a control panel to install after the driver like the one that comes with the radeon 9xxx driver ??????????????????????????????
     
  6. dezire2003

    dezire2003 New Member

    Messages:
    6
    Likes Received:
    0
    me too. No control panel???? Strange as this is what configures the driver for use with 3d applications. Any ideas?
     
  7. PaQ

    PaQ Member

    Messages:
    17
    Likes Received:
    0
    GPU:
    Ati Radeon 9700 Pro
    Well there is nothing about it in the readme.txt that comes with the driver ... in the other hand here's a screenshot of the "real" firegl properties tab :

    [​IMG]
     
  8. I think I love you--THANKS!!!! works smooth as butter :)
     
  9. PaQ

    PaQ Member

    Messages:
    17
    Likes Received:
    0
    GPU:
    Ati Radeon 9700 Pro
    Ok, I decide to install the control panel that comes with radeon 9xxx series and here's what I have :

    [​IMG]

    As you can see the adapter name and the bios version are wrong ... except that everything seems ok :gape:

    I don't know what I exactly have to find in the "normal" FireGL tab ... btw I didn't make any benchmark for the moment ...
     
  10. RabS

    RabS Guest

    i got it working with the 1026's from dell but crashed in 3dmark so ive gone back to the 1021's for now . Perhaps i need dx9 for the 1026 :)
     

  11. vtsantzalos

    vtsantzalos Guest

    I download the 1021 drivers unziped them patched them but when i try to reinstall the drivers it says that the hardware was not detected on my system... help please????

    P.S. I use a sapphire Radeon 9500 128mb
     
    Last edited by a moderator: Jan 30, 2003

  12. i would be willing to bet you probably do, i have DX9 and the dell drivers..runs awesome... for 3d mark you will need the patch for DX9 @ madonion's site.
     

  13. did you tell it you "had Disk" or Have Disk ( i forget the actual term) but it should run fine after that. you will have to hit OK a few times to get it to install if you are using win XP
     
  14. vtsantzalos

    vtsantzalos Guest

    Yes I go to reinstall driver->choose driver location->and it says it didnt detect the hardware and exits nothing i can do about it
     
  15. oh and for you gamers, the gl x1 runs mighty swanky.. taste this.

    settings.
    on a p4 2.4b 512megs pc2100 ddr, with now a FireGlX1 (formerly true 9700 pro)


    Video:
    res 1600x1200
    bit depth- 32
    refresh 85
    World Texture Detail-High
    Skin Detail-High
    Detail Texture [check]
    Fullscreen [check]

    Game:
    Game-normal
    Gore-High
    Ragdoll Details-High
    Fluid Serface Details-High
    Actor Details-High

    Misc:
    Master Shadow Detail- Custom
    Shadow resolution- Ultra High
    Max Visible Shadows-4
    Shadow Cull Distance- 1024
    Shadow Trace Distance- 512
    Shadows enabled-[check]
    Light Source Shadowed-[check]
    Blob Shadows-[check]
    Blur Shadows-[check]


    The EYE CANDY 56k beware!!
     

  16. hmmm do you mean UPDATE driver?
     
    Last edited by a moderator: Jan 31, 2003
  17. PaQ

    PaQ Member

    Messages:
    17
    Likes Received:
    0
    GPU:
    Ati Radeon 9700 Pro
    You have to install the drivers by hand :

    >MyComputer->Control Panel->System->Hardware->DeviceManager

    (1) Expand the Display adapters: Double click on the primay display driver (radeon9700 I guess),

    -> Driver -> Update Driver ...

    -> Next -> Select "Display a list of the know drivers" -> Next -> Have a Disk -> Browse the folder where you had unzip (and patched) your driver and open the .inf (atiixpgl.inf for the dell or fglry.inf for the ati)

    Select "ATI FIRE GL X1 Pro Video Accelerator"

    Select No if the computer ask you to reboot

    Return to point (1) for the SECONDARY driver, but chose "ATI FIRE GL X1 Pro SECONDARY Video Accelerator" :)
     
  18. Spline

    Spline Active Member

    Messages:
    70
    Likes Received:
    0
    GPU:
    Leadtek 5950ultra
    Trouble installing firegl drivers!!!

    I tried both 1021(from ati)&1026(from dell), none would install.

    First I patched the drivers, then uninstall catalysts, restart,
    try to install firegl drivers from device manager with update driver
    command. I get no cards to choose from when selected the proper directory containing the drivers. Then I tryed, with catalyst
    installed, updating the driver, then all the firegl cards appears.
    So I choose to install firegl x1 for primary and then secondary for
    secondary it goes fine, restart again and checking display settings, looks fine, seems like they installed properly. So I run lightwave but no opengl acceleration???!!!

    I think it's because I don't uninstall catalysts before updating but that seems to be the only way to even install firegl soft drivers.

    I have win2k SP3 and powercolor 9700 non-pro.

    Need help!!!
     
  19. RabS

    RabS Guest

    Lo Tom ive found the same my perfomance has improved with fire gl drivers less stuttering iq seems better so i r uber happeh
     
  20. vtsantzalos do as PaQ says, that pretty much is how to do it.. not hard at all.. i wish you luck :)
     

Share This Page