Trying to install very old Win 7 drivers in Win 10. Getting "unsigned" error even in Test Mode.

Discussion in 'Videocards - NVIDIA GeForce Drivers Section' started by CRTFTW, Dec 10, 2019.

  1. CRTFTW

    CRTFTW Member

    Messages:
    48
    Likes Received:
    0
    GPU:
    radeon 380x X2
    I'm trying to install some GeForce drivers from 2008/9 for my 8500 GT, because newer drivers are pretty buggy with some interlaced resolutions I'm creating for my CRT.

    Getting "drivers are not digitally signed" error, even when I'm running in Test Mode. This is all happening with the Device Manager "have disk" install method.

    I'm wondering if the format for "digitally signing" has changed significantly since 2009 and that's why I can't install them. Any help is appreciated.
     
  2. Mda400

    Mda400 Master Guru

    Messages:
    774
    Likes Received:
    55
    GPU:
    1660 - 2130/10ghz
    Last edited: Dec 10, 2019
  3. CRTFTW

    CRTFTW Member

    Messages:
    48
    Likes Received:
    0
    GPU:
    radeon 380x X2
    I never tried the advanced boot mode, I figured it was the same as Test Mode. I can give that a try later.

    The issue is that interlaced resolutions over 1920x1440 will cut off the frame at 1920 pixels, and just show the same frame again from that point to the edge of the screen. So at 2240x1680, the last 320 pixels are just a repeat of the first 320. I guess it's a glitch in the output of the frame buffer.
     
  4. Astyanax

    Astyanax Ancient Guru

    Messages:
    4,449
    Likes Received:
    1,289
    GPU:
    GTX 1080ti
    this is an exercise in futility, windows 10 can no longer load drivers that aren't sha 2 signed, regardless of test signing.
     

  5. CRTFTW

    CRTFTW Member

    Messages:
    48
    Likes Received:
    0
    GPU:
    radeon 380x X2
    Success!

    Sort of.

    I was able to install the drivers by basically doing all three methods mentioned in the link: disabling driver signature enforcement via Win 10 boot menu, and running Test Mode and disabling driver signing in the command prompt.

    And once it was installed, the GPU and driver continue to work after I reset all the commands above. So that's good.

    Unfortunately it seems older Geforce drivers are even less helpful, at least for my 8500 GT. I can't enable any custom resolutions via CRU, and Nvidia CP didn't have a custom resolution function back in 2009. Tried to use a EXE of the control panel that comes with Win 10's default drivers, but it must have some other dependencies because it looked the same as the 2009 version when I opened it.
    I thought it could be something like that, but maybe Nvidia was using sha-2 back in 2009. Or Windows is pretty lax on enforcement.
     
    Last edited: Dec 11, 2019

Share This Page