Trouble with Windows 8.1 2D/desktop performance

Discussion in 'Videocards - NVIDIA GeForce Drivers Section' started by jez_uk1, Nov 7, 2013.

  1. jez_uk1

    jez_uk1 Active Member

    Messages:
    78
    Likes Received:
    0
    GPU:
    GTX 1080 SLI
    Hi all

    I installed Windows 8.1 recently but I'm suffering from a problem identical to what is demonstrated in this video on YouTube:

    http://www.youtube.com/watch?v=6WPh57xymIU

    Dragging windows around was noticeably 'laggy' (for me it was often much worse than seen in the video). Have tried 331.40 and 331.65 but I've since returned to Win 8 until a solution can be found. Has anybody seen this or knows a fix? I'm guessing I'll have to wait for newer drivers and hope something gets solved.
     
  2. dsbig

    dsbig Ancient Guru

    Messages:
    4,052
    Likes Received:
    42
    GPU:
    EVGA RTX 2070
    only thing I can say is wait for microsoft for updates.

    8.1 just came out to the public last month.

    microsoft is slowy becoming aware of issues and are investigating the problems.
     
  3. CalinTM

    CalinTM Ancient Guru

    Messages:
    1,610
    Likes Received:
    12
    GPU:
    MSi GTX980 GAMING 1531mhz


    OMG OMG, i am not alone. I have the EXACT SAME thing on windows 8.1

    I use a 144hz monitor, and i have that laggy windows dragging. I noticed it right when i installed windows 8.1 when was released.

    I opened multiple threads on forums and got no reply, i opened a thread on windows 8.1 official Microsoft forum, and got nothing.

    Why the hell is causing this ? If i install windows 8.0 my windows are moving super smooth.
     
  4. Darren Hodgson

    Darren Hodgson Ancient Guru

    Messages:
    16,049
    Likes Received:
    569
    GPU:
    EVGA GTX 1080 Ti SC2
    Windows 8.1 uses WDDM 1.3 whereas Windows 8 is WDDM 1.2 so the issue may lie with that. I have not noticed any abnormal windows behaviour personally and I also have Stardock's WindowsFX and WindowsBlinds installed.
     

  5. CalinTM

    CalinTM Ancient Guru

    Messages:
    1,610
    Likes Received:
    12
    GPU:
    MSi GTX980 GAMING 1531mhz
    Possible they broke it some how. Also, sooo stupid thing for not providing some windows 8.1 ISO image to install it fresh, i bet this is the major issue(s).

    When i did a driver reinstall on windows 8.1, after i uninstalled the current driver then cleaned with friver fusion, then hit reboot, then i saw that windows 8.1 put my driver which was when i updated to 8.1 i said WTF ??
     
  6. dsbig

    dsbig Ancient Guru

    Messages:
    4,052
    Likes Received:
    42
    GPU:
    EVGA RTX 2070
    I noticed it with my monitor at 60hz

    and my 8.1 is a clean install using technet iso
     
  7. CalinTM

    CalinTM Ancient Guru

    Messages:
    1,610
    Likes Received:
    12
    GPU:
    MSi GTX980 GAMING 1531mhz
    ^ Yeah ? Clean install ? Then it's the windows 8.1, not some fresh installation.
     
  8. jez_uk1

    jez_uk1 Active Member

    Messages:
    78
    Likes Received:
    0
    GPU:
    GTX 1080 SLI
    Ah that's nice to know it's not only affecting the upgrade but the clean install too, rules out one thing I was wondering about. Hope to see a fix sometime soon (whether it be from Microsoft or nVIDIA - still unsure where the root cause is)
     
  9. dsbig

    dsbig Ancient Guru

    Messages:
    4,052
    Likes Received:
    42
    GPU:
    EVGA RTX 2070
    this problem can go to the list along with the mouse lag.
     
  10. Wagnard

    Wagnard Ancient Guru

    Messages:
    2,665
    Likes Received:
    344
    GPU:
    MSI Geforce GTX 1080
    This problem was also present on 8.1 preview.

    There are 2 workarounds that I know of.

    1- When Google Chrome is open, it wont happen. (at least for me)
    2- When Using DPCLAT, it wont happen. (at least for me)
     
    Last edited: Nov 7, 2013

  11. jez_uk1

    jez_uk1 Active Member

    Messages:
    78
    Likes Received:
    0
    GPU:
    GTX 1080 SLI
    For me the problem was still happening even when Chrome was open, although randomly - sometimes it would go smooth for short times. If the Chrome window went off the edges of the screen it would almost freeze in position for roughly half a second sometimes before catching up with the mouse cursor again.
     
  12. CalinTM

    CalinTM Ancient Guru

    Messages:
    1,610
    Likes Received:
    12
    GPU:
    MSi GTX980 GAMING 1531mhz
    Another problem could be: when i start the PC then i want to connect with my broadband connection, first says i get a error, then i click connect again and it connects. Happened in windows 8.1 preview also, they didn't even fixed this minor thing. I think they didn't worked on nothing on windows 8.1 official release.

    For the 2D Desktop performance windows dragging i guess it's some kind of minor thing to fix, but MS doesn't want to get feedback and doesn't fix things so soon...

    I will use win 8.0 until they fix it.
     
  13. BenYeeHua

    BenYeeHua Ancient Guru

    Messages:
    1,515
    Likes Received:
    0
    GPU:
    Asus 650M D3
    So, it can be the Timer Resolution issues.

    As I know, both software will set the timer resolution as 1ms after launch.
     
  14. dsbig

    dsbig Ancient Guru

    Messages:
    4,052
    Likes Received:
    42
    GPU:
    EVGA RTX 2070
    got paranoid about it.

    now I notice its really jerky for me

    no smooth movement.
     
    Last edited: Nov 9, 2013
  15. CalinTM

    CalinTM Ancient Guru

    Messages:
    1,610
    Likes Received:
    12
    GPU:
    MSi GTX980 GAMING 1531mhz
    Just install again windows 8.0, i dont think they will fix it...
     

  16. lucidus

    lucidus Ancient Guru

    Messages:
    11,835
    Likes Received:
    1,373
    GPU:
    .
    I don't remember seeing this in 8.1 RTM running in a virtual machine :-S
     
  17. Cygnific

    Cygnific Member

    Messages:
    39
    Likes Received:
    1
    GPU:
    2060S Gaming OC
    No problems here, but I have surround and side monitors are 60hz and middle at 120hz.
     
  18. CrazyCoder

    CrazyCoder New Member

    Messages:
    9
    Likes Received:
    0
    GPU:
    Gigabyte GTX690
    I had similar issue with Windows 7, described here. But it was caused by using multiple displays.

    I wrote a tool that tweaks DWM and increases timer resolution which seems to help me to fix the random lag.

    I understand that this 8.1 issue is different, but this DWMTweak tool may be of some use.
     
  19. fabiovtec

    fabiovtec Member

    Messages:
    33
    Likes Received:
    2
    GPU:
    ASUS R9 270X @1270
    same problem here... back to win8
     
  20. CalinTM

    CalinTM Ancient Guru

    Messages:
    1,610
    Likes Received:
    12
    GPU:
    MSi GTX980 GAMING 1531mhz
    They didn't said that there is a problem, i mean microsoft...
     

Share This Page