Tripple buffering d3d

Discussion in 'Videocards - NVIDIA GeForce Drivers Section' started by tsunami231, Mar 16, 2011.

  1. tsunami231

    tsunami231 Ancient Guru

    Messages:
    7,568
    Likes Received:
    1
    How do we enable (force ) triple buffering in d3d last i heard that option in nvidia panel is for opengl only?, Or better yet have it forced for specific D3D games only. sorry if this been answered so place already
     
    Last edited: Mar 16, 2011
  2. GanjaStar

    GanjaStar Maha Guru

    Messages:
    1,150
    Likes Received:
    0
    download riva tuner, install it, look in the folder where its installed and find the d3d overider folder. then you cant put in anywhere you want, delete rivatuner and still use d3d overider.
     
  3. tsunami231

    tsunami231 Ancient Guru

    Messages:
    7,568
    Likes Received:
    1
    thanks, I was wonder what the tool was for, one more question when I put the profile for the program in override, it says triple buffering is forced on already, does this mean triple buffering it on by default for everything d3d/opengl seeing I have triple buffering enabled in global profile threw nvidias panel?
     
  4. GanjaStar

    GanjaStar Maha Guru

    Messages:
    1,150
    Likes Received:
    0
    not completely sure what you are saying.

    but from what I know. triple buffering for d3d in nvidia drivers is only partial. a part of the spec isn't used. theres a post about it in one of the threads here, but I'm too lazy to look for it. I only use triple buffering in the control panel for individual OpenGL profiles, and d3doverider for the rest.
     

  5. tsunami231

    tsunami231 Ancient Guru

    Messages:
    7,568
    Likes Received:
    1
    D3D overide says triple buffering is on by default when I pick the program to use it, and even when I change setting for triple buffering and vsync for that program and restart the program it seem to have no effect, like i will disable vysnc and vsync will still be on when I restart the program.

    and d3d overide says triple buffering is enabled by defualt
     
  6. CPC_RedDawn

    CPC_RedDawn Ancient Guru

    Messages:
    7,372
    Likes Received:
    0
    You have to leave D3D Overrider running in the background, dont bother making individual game profiles in it. Just use the Global option, tick Force Vsync and then tick Triple Buffering to the ON position and run whatever game you want. You will now have both enabled and the verify you will hear a sound when you open a 3D application or game.

    EDIT: Also make sure you have Vsync and Triple buffering disabled in Nvidia control panel in global settings and also any game profiles you have made. I have found this to sometimes conflict with each other and cause massive stuttering. Also disable any in game options for these as well to avoid any more conflicts.
     
  7. tsunami231

    tsunami231 Ancient Guru

    Messages:
    7,568
    Likes Received:
    1
    ah ok i will try that
     
  8. HaZe303

    HaZe303 Ancient Guru

    Messages:
    1,941
    Likes Received:
    0
    You can make profiles if you want to disable vsync for some software, otherwise global will work fine. But to answer youre question, D3DOverrider will only force Vsync+tripplebuffering on Direct3D games/software.
     
  9. Bohi2_OGU

    Bohi2_OGU Member Guru

    Messages:
    143
    Likes Received:
    0
    There is no need to install the Rivatuner before you can use the D3D overrider.
    Download;
    The RivaTuner224c-[Guru3D.com]
    Extract that and you got the folder [Guru3D.com] open the [guru3d] and [setup] folder.. and extract the RivaTuner224MSIMOA2009Edition.exe

    Then goto the [tools] folder and when you look inside that you got the
    [D3DOverrider] folder and copy /paste that in your program files or where you want it and simply run it.

    Ps; i use 7zip for it but pretty sure other app do the same like IZArc
     
    Last edited: Mar 17, 2011
  10. PirateNeilsouth

    PirateNeilsouth Ancient Guru

    Messages:
    1,773
    Likes Received:
    0

  11. GanjaStar

    GanjaStar Maha Guru

    Messages:
    1,150
    Likes Received:
    0
    thx for correcting me guys. Im out of the loop, since I have d3doverider installed for a very long time, and didn't really look into other possible ways of acquiring it :)
     
  12. HaZe303

    HaZe303 Ancient Guru

    Messages:
    1,941
    Likes Received:
    0
    I dont think they were correction you, you were totally right. Most of us (atleast me) did it as you said. But yes, you dont need to install riva, just use 7-zip and unpack it. But its good to have options.
     
  13. PirateNeilsouth

    PirateNeilsouth Ancient Guru

    Messages:
    1,773
    Likes Received:
    0
    You don't even need to download Rivatuner :)
     
  14. tsunami231

    tsunami231 Ancient Guru

    Messages:
    7,568
    Likes Received:
    1
    I dont even use RT anymore so i dont know why I even have it installed. Thanks for the info, but me doing this didnt fix the problem that the newest nvidia drivers are cause for one game. but the new drivers did fix the hardware accelerations in browsers from not working, Cause apparently 197.xx drivers where the issue there
     
  15. GanjaStar

    GanjaStar Maha Guru

    Messages:
    1,150
    Likes Received:
    0
    what game are you having trouble with?
     

  16. tsunami231

    tsunami231 Ancient Guru

    Messages:
    7,568
    Likes Received:
    1
    A 10+ year old MMO called Ragnarok online Tabbing out of the game and back in results in stuttering of everything for about 2 seconds Graphics and mouse. I will get over it after a while tho
     

Share This Page