Tried to update my graphics card drivers and now Opengl doesn't work, need advice

Discussion in 'Videocards - AMD Radeon Catalyst Drivers Section' started by resbot, Jun 18, 2011.

  1. resbot

    resbot New Member

    Messages:
    1
    Likes Received:
    0
    GPU:
    ATI RadeonHD5870 1024MB
    I have a Radeon HD 5870, windows 7 64bit. I have been experiencing a crash in the game Minecraft when I play with the 'fancy' graphics setting. I wanted to try to fix this, and someone suggested I update my graphics card driver.

    I went to the site for downloading Radeon standalone drivers and downloaded the installer "11-6_vista64_win7_64_dd.exe" and ran the installer. It blue-screened halfway through, and my computer rebooted.
    The display driver was borked so I tried downloading the full Catalyst installer next "11-6_vista64_win7_64_dd_ccc_ocl.exe", and ran that exe. It extracted to my C drive but never continued the installation. SO I navigated to the folder on C that it had extracted to and tried running "Setup.exe" there.

    I got this Error: "C:\ATI\Support\11-6_vista64_win7_64_dd_ccc_ocl\Setup.exe has failed to start because its side-by-side configuration is incorrect."

    So then I followed the instructions to completely remove the ATI drivers, and restarted, but the Setup.exe in the exe installer still didn't run, still gave the same "side-by-side" configuration error.

    I emailed AMD's tech support, they just said "use the old drivers, maybe there will be a new driver next week" (REAL helpful) so I dug out my old graphics card instal cd and ran the old installer. Which worked EXCEPT now when I try to run Minecraft it says it can't "find an Opengl accelerated card" or something.

    So reverting to the old driver works except for Opengl which I need to play Minecraft which was the whole point of running the updater in the first place.

    TL;DR: So basically I tried to update my driver and it completely broke Opengl.

    Any ideas on what I can do to get OpenGL working again?
    I tried titaniumgl.tk, it mangled Minecrafts graphics into garbage, so that doesn't work.

    I can't even try to run the ATI installer again because it always says "side-by-side configuration" error.

    Any advice on what I can do?


    Update: I uninstalled using the ATI uninstaller, then I used Driver Sweeper, and reinstalled and it seems to be fine now.
     
    Last edited: Jun 18, 2011
  2. MIXXX

    MIXXX Member Guru

    Messages:
    156
    Likes Received:
    0
    GPU:
    EVGA 1070 GTX 8GB
    If Open GL seems broke,

    I would delete the config file for the game first and let the game engine rebuild another one.

    save your old copy just in case.

    Also try to set settings in CCC to application selection and try to adjust the Catalyst AI setting

    PEACE
     
    Last edited: Jun 22, 2011

Share This Page