To Full RGB or not to Full RGB

Discussion in 'Videocards - NVIDIA GeForce Drivers Section' started by FDisk, Dec 22, 2014.

  1. FDisk

    FDisk Master Guru

    Messages:
    766
    Likes Received:
    0
    GPU:
    ASUS STRIX GTX970 OC 4GB
    Here is a quick way to find out if your Monitor/HDTV supports Full RGB Mode (0-255).

    Set it to Full RGB Mode (0-255) in NVIDIA Control Panel obviously.

    Look at this picture: fullrgb_test.jpg
    You should be able to distinguish all 28 squares of the image.
    If you can see them all perfectly then you are good to go.

    If not and almost all the top squares look black, then go to your HDTV Picture settings and look for "Black Level".
    There should be 2 options there. Low & Normal.
    Set it to Normal.
    Now check the 28 squares again. They should all be distinguishable now.

    If you don't have Black Level option on your HDTV and your blacks are all wrong and picture looks over-saturated then you are out of luck and your HDTV probably supports only Limited RGB Mode (16-235). So go back to that mode.

    P.S.
    You need the 347.09 driver or latter for the RGB options to appear.
     
    Last edited: Dec 23, 2014
  2. HeavyHemi

    HeavyHemi Ancient Guru

    Messages:
    6,954
    Likes Received:
    959
    GPU:
    GTX1080Ti
    There is already a fairly long thread on this...

    http://forums.guru3d.com/showthread.php?t=371214&highlight=Limited
     
  3. NeoandGeo

    NeoandGeo Master Guru

    Messages:
    745
    Likes Received:
    9
    GPU:
    Geforce GTX 970 @1420
    Amazing how long Nvidia looked like complete fools in regards to color range. Such an embarrassment.
     
  4. wyldmagik

    wyldmagik Active Member

    Messages:
    56
    Likes Received:
    0
    GPU:
    EVGA-1070-FTW
    I dont see the colour range box in my adjust colour settings menu list at bottom.

    All I get is digital colour format rgb or ycbcr444 and the content type auto/desktop/full

    there is no range drop down on the right of the colour format menu as I see for many people posting info about it.

    I only see 17 squares clear and I dont seem to have a black level option, :D

    It is just a no special hdmi 24" screen though for extra use slotted in with my asus other monitors which are running dvi connections.

    Ive noticed as well everytime I boot pc I have to go to the hdmi's screen section in nvidia control panel and move the digital vibrance slider +1 or -1 to bring levels back to normal or as I originally set them to match close to my other screens. Otherwise it boots with it all much brighter, bug with driver setting saving or do away with the hmdi screen altogether? :p
     

  5. FDisk

    FDisk Master Guru

    Messages:
    766
    Likes Received:
    0
    GPU:
    ASUS STRIX GTX970 OC 4GB
    It's only available in the latest driver.
    Btw, WHQL driver was just released.
    Here you go: http://www.geforce.com/drivers/results/80913
    I would recommend you install the new driver with a clean option. To me it sounds like some of your settings are messed up. It should not be behaving like it does.
    If you only see 17 squares on that test with Limited RGB you monitor is probably badly calibrated. Try to also reset your monitor settings.
     
    Last edited: Dec 23, 2014
  6. wyldmagik

    wyldmagik Active Member

    Messages:
    56
    Likes Received:
    0
    GPU:
    EVGA-1070-FTW
    yup just saw and most kind thankyou, updating now via experience rubish, if it dont work out ill ddu and fresh install :p ( i know im being a bit lazy but xmas is upon us im needed everywhere in house )

    edit: hahah i just installed via experience and then after all done hit "check for updates" to make sure it knew what driver i had and.... :p

    http://prntscr.com/5k40dg

    ^^ lol dafuq

    time for reboot.
     
    Last edited: Dec 23, 2014
  7. TheDeeGee

    TheDeeGee Ancient Guru

    Messages:
    7,496
    Likes Received:
    1,637
    GPU:
    NVIDIA GTX 1070 8GB
    Gotta give the new drivers a try then.

    My Calibrated EIZO CX240 has 3 of the Block Top Left all Black.
     
  8. GhostXL

    GhostXL Ancient Guru

    Messages:
    6,084
    Likes Received:
    54
    GPU:
    Merc 319 6800 XT
    I know Full RGB on my 10-bit 2K panel does wonders.

    Any driver below the latest 347.09 will require the Nvidia RGB hack though.

    The 347.09 now has the option in the "Adjust desktop color settings area".

    I get much richer colors from Full RGB than Limited. Not just in videos but 2D images and games.
     
  9. FDisk

    FDisk Master Guru

    Messages:
    766
    Likes Received:
    0
    GPU:
    ASUS STRIX GTX970 OC 4GB
    The older drivers are default Limited RGB (16-235) and it was not possible to change this unless you use a reg hack.

    If you already see that 3 of the squares are the same black, changing this to Full RGB (0-255) will make more of the squares look black.
    So you will have to change the Black level setting on your Monitor or calibrate it better.
     
    Last edited: Dec 23, 2014
  10. SpecChum

    SpecChum Master Guru

    Messages:
    616
    Likes Received:
    12
    GPU:
    Vega 64 - Acer XR34
    If only the top 3 squares are black I can say you're definitely not correctly calibrated.

    If you were calibrated but the drivers were just on the "wrong" RGB setting you'd missing all the top row and most of the 2nd row.

    Sounds like you just need your brightness up a notch.
     

  11. wyldmagik

    wyldmagik Active Member

    Messages:
    56
    Likes Received:
    0
    GPU:
    EVGA-1070-FTW
    I see all those squares now :D

    But I think I will do a ddu fresh install, and custom install with only physx/drivers etc and remove all the other crap.

    anyone got a list of what I should not leave out if custom installing nvidia drivers.

    I only really need drivers for card but not sure if i need anything else as I have one hdmi screen with two dvi screens. This geforce experience stuff seems pointless for me, I set my own configs manually in game files etc or via control panel myself none of that "let me optimize that for you" business :D
     
  12. TheDeeGee

    TheDeeGee Ancient Guru

    Messages:
    7,496
    Likes Received:
    1,637
    GPU:
    NVIDIA GTX 1070 8GB
    I'm at 50cd/m² which is lowest, cuz higher burns by eyes.

    At 50 this monitor is alrdy pretty bright.
     
  13. SpecChum

    SpecChum Master Guru

    Messages:
    616
    Likes Received:
    12
    GPU:
    Vega 64 - Acer XR34
    Have you tried increasing the brightness and adding a bit of ambient light around you? That should lower the perceived contrast, which might help.
     
  14. TheDeeGee

    TheDeeGee Ancient Guru

    Messages:
    7,496
    Likes Received:
    1,637
    GPU:
    NVIDIA GTX 1070 8GB
    Looks like RGB already worked for me.

    Now if they could support Custom ICC Profiles in Games it would be cool. Because right now my Desktop has Pure Blacks, but as soon as i fire up a Game the Blacks become Greyish.

    I believe AMD support Custom ICC Profiles in Fullscreen Applications?

    Ye it's working just fine, my room is just a little bit too dark. Making it hard for the eyes to see the difference :) I can see the 3 Blocks in the Top Left now.

    I'm running Adobe RBG Mode btw. When i drop to sRGB they become even more visible, but damn... those crap colors compared to Adobe RGB :p
     
    Last edited: Dec 23, 2014
  15. SpecChum

    SpecChum Master Guru

    Messages:
    616
    Likes Received:
    12
    GPU:
    Vega 64 - Acer XR34
    Try increasing the gamma on the monitor a little? That'll bring the blacks out at the expensive of colour accuracy. Shouldn't affect the top end (whites) too much.

    Not sure if your monitor has that option? Should do I would have thought considering its a premium brand.
     

  16. SpecChum

    SpecChum Master Guru

    Messages:
    616
    Likes Received:
    12
    GPU:
    Vega 64 - Acer XR34
    Cool :)
     
  17. Dan

    Dan Active Member

    Messages:
    74
    Likes Received:
    25
    GPU:
    RTX 3070 FE
    From my understanding Full RGB is for monitors and Limited is for TVs (some TVs have a FULL option). If you have the setting at Full RGB and you can't see the top squares then you need to increase your gamma until you can barely see the first square.

    Alternate calibration image http://www.lagom.nl/lcd-test/black.php#blacktest.png
     
    Last edited: Dec 23, 2014
  18. SpecChum

    SpecChum Master Guru

    Messages:
    616
    Likes Received:
    12
    GPU:
    Vega 64 - Acer XR34
    Spot on Dan.

    However, a decent monitor should be able to distinctly display all the squares at 2.2 gamma.

    Raising the gamma is 'cheating' as you won't get the correct luminance across the gamut.
     
    Last edited: Dec 23, 2014
  19. Crimson Wolf

    Crimson Wolf Member

    Messages:
    30
    Likes Received:
    8
    GPU:
    GTX980 4GB
    To get more info about color profiles & games, take a look at this http://forums.guru3d.com/showthread.php?t=387074

    I use Color Sustainer http://forums.guru3d.com/showthread.php?t=386325

    I switched to using firefox because chrome doesn't support icc profiles. For firefox check http://cameratico.com/guides/firefox-color-management/

    I use BT.1886 using custom icc profile calibrated by dispcalGUI (ArgyllCMS) & 3dlut for madvr.
     
  20. zais

    zais Member Guru

    Messages:
    100
    Likes Received:
    0
    GPU:
    1070
    breaktrough @ display sislink antialiasing at electronic speed with no tearing and minimal input lag
     

Share This Page