1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

TITAN X Pascal Flickering In FPS Games (HW or driver issue?)

Discussion in 'Videocards - NVIDIA GeForce' started by king-dubs, Nov 6, 2016.

  1. king-dubs

    king-dubs Ancient Guru

    Messages:
    2,386
    Likes Received:
    1
    GPU:
    TITAN X (Pascal) + X34
    Hey guys,

    I've been noticing this behavior on my system recently, but am not sure if it's hardware related or drivers...

    Titan X Pascal paired with X34 GSYNC monitor.

    Video of the symptoms:
    https://drive.google.com/open?id=0B-zUIrdLz8cLY1ZXS19UUDJTNW8
    https://drive.google.com/file/d/0B-zUIrdLz8cLcGxfbTVQbjRWcGM/view

    I've tried clean installing the drivers, and changing Displayport ports.

    This never happened on the GTX 980 I had before.

    I've tried disabling GSYNC, and it had no effect on the issue.

    A game could be going for hours without a single flicker, but at certain spots in FPS games (tried BF4, BF1, COD), this happens. It never occurred in StarCraft.
     
    Last edited: Nov 12, 2016
  2. Agent-A01

    Agent-A01 Ancient Guru

    Messages:
    11,351
    Likes Received:
    881
    GPU:
    1080Ti H20
    Try enabling VSYNC inside the NVCPL. I have noticed this before in Overwatch.

    VSYNC on was the solution(make sure to limit your FPS a couple below refresh rate)

    Could be coincidence, but haven't seen it since.
     
  3. Pete J

    Pete J Master Guru

    Messages:
    425
    Likes Received:
    6
    GPU:
    Some of those as well
    Interesting. Mine do this in Shadow Warrior 2 from time to time.
     
  4. king-dubs

    king-dubs Ancient Guru

    Messages:
    2,386
    Likes Received:
    1
    GPU:
    TITAN X (Pascal) + X34
    Forcing VSYNC ON in NVCPL did not make a difference. I always cap in-game FPS to 2 - 5 below the max refresh rate (BF1 in video was running at constant 98 fps, 100 Hz).

    This didn't occur on the GTX 980.
     
    Last edited: Nov 7, 2016

  5. JaxMacFL

    JaxMacFL Ancient Guru

    Messages:
    1,660
    Likes Received:
    917
    GPU:
    Jedi Titan XP
    With vsync on in nvcp, make sure vsync off in game menu.
     
  6. king-dubs

    king-dubs Ancient Guru

    Messages:
    2,386
    Likes Received:
    1
    GPU:
    TITAN X (Pascal) + X34
    Hmm....turning VSYNC off in-game while leaving Force VSYNC ON in NVCPL seems to be working so far...:nerd:
     
  7. JaxMacFL

    JaxMacFL Ancient Guru

    Messages:
    1,660
    Likes Received:
    917
    GPU:
    Jedi Titan XP
    :thumbup:

    Rule of thumb for titan xp and gsync especially.
     
  8. king-dubs

    king-dubs Ancient Guru

    Messages:
    2,386
    Likes Received:
    1
    GPU:
    TITAN X (Pascal) + X34
    This has got to be some ridiculous regression driver bug for Pascal cards or something... it never happened on the GTX 980, with the same monitor...
     
  9. JaxMacFL

    JaxMacFL Ancient Guru

    Messages:
    1,660
    Likes Received:
    917
    GPU:
    Jedi Titan XP
    Read about this when I ordered my acer 34" predator gsync and titan xp a month or so ago. Did a lot of homework while waiting for delivery.

    Don't know about other cards as this is first nvidia card since geforce 8800gtx.
     
    Last edited: Nov 9, 2016
  10. king-dubs

    king-dubs Ancient Guru

    Messages:
    2,386
    Likes Received:
    1
    GPU:
    TITAN X (Pascal) + X34
    Last edited: Nov 12, 2016

  11. king-dubs

    king-dubs Ancient Guru

    Messages:
    2,386
    Likes Received:
    1
    GPU:
    TITAN X (Pascal) + X34
    I found a way to reproduce the flickering 100% without actually running a game!

    Repro steps:
    1. Set Desktop resolution to 3440x1440 @ 100 Hz
    2. Disable G-SYNC in NVIDIA Control Panel
    3. Open this PNG image in Full Screen: https://drive.google.com/file/d/0B-zUIrdLz8cLenNhWWs5TXVBQW8/view (make sure there's a 1-to-1 pixel mapping)
    4. Wait 10 seconds or so
    5. Screen will start flickering like crazy
     
  12. WinterMagican

    WinterMagican Member

    Messages:
    15
    Likes Received:
    0
    GPU:
    Pascal TITAN X 4Way-SLI
  13. king-dubs

    king-dubs Ancient Guru

    Messages:
    2,386
    Likes Received:
    1
    GPU:
    TITAN X (Pascal) + X34
    It appears that the root cause of the issue is the GSYNC module in the monitor blanking out when the refresh rate reaches very close to 100.00 Hz when certain images are displayed.

    I found a workaround that seems to resolve the flickering completely:
    [​IMG]

    Use CRU to make the "100 Hz" resolution 99.500 Hz and reduce the back porch.
     
  14. RealNC

    RealNC Ancient Guru

    Messages:
    2,941
    Likes Received:
    1,212
    GPU:
    EVGA GTX 980 Ti FTW
    What happens if you reduce BP without lowering refresh rate?
     
  15. king-dubs

    king-dubs Ancient Guru

    Messages:
    2,386
    Likes Received:
    1
    GPU:
    TITAN X (Pascal) + X34
    Neither reducing the back porch value alone, nor refresh rate alone worked. Had to do both.
     

Share This Page