1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Tip for nVidia users using HDMI and getting accurate color format

Discussion in 'Videocards - NVIDIA GeForce Drivers Section' started by jwb1, Nov 18, 2012.

  1. snorge

    snorge Member Guru

    Messages:
    122
    Likes Received:
    0
    GPU:
    gtx 970 SLI
    Nice guide I don't mind using the registry fix but I'm sure some people may prefer this.
     
  2. Viscerous

    Viscerous Active Member

    Messages:
    88
    Likes Received:
    0
    GPU:
    ASUS Geforce GTX 980
    I modified my monitor's driver to override the EDID since I got tired of needing to do these fixes so often.

    It would help if Nvidia included the option in the control panel as CCC does.
     
  3. Singleton99

    Singleton99 Maha Guru

    Messages:
    1,003
    Likes Received:
    58
    GPU:
    Aorus-Extreme-1080TI
    Just a quick thanks for this info it made a good piture even better, Worked a treat ,blacks are blacker and colours are just more vibrant , LG TV 32inch screen @1980x1020 , give it ago u wont be disappointed if the fix work for you.
     
  4. SwiftDragon

    SwiftDragon Active Member

    Messages:
    55
    Likes Received:
    0
    GPU:
    HOF gtx980ti
    Best post I've ever seen on this whole damn forum, thank you so much seriously.

    I've been struggling with this forever and it seemed the only way around it was making custom resolutions, that unfortunately didn't work in some games for whatever reason.

    Nvidia has brushed this to the side for too long, a lot of people use TV's now for pc gaming.
     

  5. Shadowdane

    Shadowdane Maha Guru

    Messages:
    1,303
    Likes Received:
    12
    GPU:
    MSI RTX2080Ti
    Thanks soo much for this!! Was a night & day difference here. I also had to remove the color profile installed for my monitor and change it to a sRGB profile for everything to look proper.

    Borderlands 2 looks great now, colors really pop!!
     
  6. jwb1

    jwb1 Master Guru

    Messages:
    466
    Likes Received:
    51
    GPU:
    MSI GTX 1080 Ti
    Last edited: Nov 30, 2012
  7. Nono06

    Nono06 Master Guru

    Messages:
    875
    Likes Received:
    0
    GPU:
    680 GTX SLI (1215/6884)
    I’m sorry but I agree with what Alco posted.

    Here is another link with some explanations:
    http://www.audioholics.com/tweaks/calibrate-your-system/hdmi-black-levels-xvycc-rgb

    Things look “different” (better for some) because your TV is calibrated differently for this type of source. You should be able to get the same result by using limited RGB and adjusting your TV options.

    Full RGB is a legacy feature coming from DVI specification.

    If you play also with the HDMI profiles (like desktop, games, full screen video…) you will notice that your TV will change the profile it is using (it is the case on my Sony TV). Each time the graphic card is switching from one profile to another (when set on Auto), I can see that my TV is using different contrast/brightness/color settings which can be modified in each mode.
    That is why I’m forcing the driver to be always in "full screen video" mode so it is using only one calibrated profile on my TV whatever I'm doing (gaming, using word, watching a film in full screen...)
     
  8. AaD-Marine

    AaD-Marine Master Guru

    Messages:
    254
    Likes Received:
    0
    GPU:
    Geforce GTX 980
    I use Displayport on my moniter, thats straight displayport from my 660ti to my asus ve278.

    would this RGB thing have any effect on me? I see under the one settings the limited/full RGB option

    and under adjust desktop color settings an option for RGB, YCbCr422 and 444
     
  9. MrBonk

    MrBonk Ancient Guru

    Messages:
    2,949
    Likes Received:
    71
    GPU:
    MSI RTX 2080

    Objectively, you should have at least 2 separate HDMI configuration settings/profiles or different ones on different HDMI inputs for different sources.

    1 for 16-235 4:2:0 broadcast material.
    2 for 0-255 4:4:4 RGB
     
  10. AaD-Marine

    AaD-Marine Master Guru

    Messages:
    254
    Likes Received:
    0
    GPU:
    Geforce GTX 980
    I must of missed your post when i first read the thread, have you set your TV's source name to PC?

    if you go to source select and set the source name of whatever HDMI slot your PC is connected to PC, PC DVI, or DVI The TV will change itself into a moniter basicly. this will fix any sharpness issues, and color issues.

    my Samsung UN40B6000 support this feature so your 8000 series should too.

    the screen will go black and come back on when it loads the PC profile after being set.

    EDIT: difference between the 3 settings is PC allows sound through HDMI, PC DVI has only video through the HDMI and accepts sound through the 3.5mm input jack, and last just DVI support only video.
     
    Last edited: Dec 7, 2012

  11. GMtm

    GMtm Active Member

    Messages:
    82
    Likes Received:
    0
    GPU:
    AMD Radeon HD 7950 3GB
    I have HDMI2, with custom-settings, game mode and still get HDMI audio. I will try the source rename tonight. Will let you know. Thanks for the advice.
     
  12. Phreakuency

    Phreakuency Master Guru

    Messages:
    668
    Likes Received:
    0
    GPU:
    Asus Titan
    When I click apply and it starts searching it crashes every time.

    Running as admin yes.

    :(
     
  13. dsbig

    dsbig Ancient Guru

    Messages:
    4,003
    Likes Received:
    27
    GPU:
    EVGA RTX 2070
    so maybe make this a sticky?

    without this RGB is far too bright. black screen are gray screens.

    I vote sticky. until nvidia fix the brightness issue. and dont say its not a nvidia issue because my amd card dont have this issue.
     
  14. Ghettorat

    Ghettorat Active Member

    Messages:
    82
    Likes Received:
    0
    GPU:
    EVGA GTX780 ClassifiedSLI
    It works great for me too on a Sharp Aquos LED. Thank you for sharing OP!
     
  15. yoe

    yoe Member

    Messages:
    39
    Likes Received:
    0
    GPU:
    GTX1080 2.15/11.1
    It's a nice trick, i tested it and i removed it. I like limited rgb more on my LG 660S i just like the detail seen in the darker areas with it and natural picture. With full rgb blacks are just crushed and it's not a fault of a screen calibration, it's just to intense level overall i think.
     
    Last edited: Dec 8, 2012

  16. Major Melchett

    Major Melchett Ancient Guru

    Messages:
    2,456
    Likes Received:
    0
    GPU:
    R9 280X @ 1100/1500
    Can't believe i didn't know about this until now, it worked quite nicely.
     
    Last edited: Dec 8, 2012
  17. Mufflore

    Mufflore Ancient Guru

    Messages:
    11,322
    Likes Received:
    569
    GPU:
    Redacted by NDA
    Look for a black level setting in the display or something similar.
    Set it to high, then use full RGB and adjust brightness etc to suit.
    You may not have this setting, but its worth a look.
     
  18. yoe

    yoe Member

    Messages:
    39
    Likes Received:
    0
    GPU:
    GTX1080 2.15/11.1
    I have this setting, and i tested both (low, max). It's still crushed and very intense at contrast/colour. You can't just calibrate the level of signal crushed blacks by a setting on a tv (brightness, etc), coz it will be a non natural picture then. My screen is very nice working with a limited rgb (whites are white, blacks are black but with a proper level of detail in shadows). And yup my tv does support full rgb.

    Just look at this two photos (not mine), first limited rgb, second full rgb (poor black details)

    [​IMG]

    [​IMG]

    Same situation. It may look better for a first time but then :).
     
    Last edited: Dec 9, 2012
  19. Mufflore

    Mufflore Ancient Guru

    Messages:
    11,322
    Likes Received:
    569
    GPU:
    Redacted by NDA
    It was a suggestion in case it helped.
    Your TV may have the setting reversed.
     
  20. SashaX

    SashaX Master Guru

    Messages:
    210
    Likes Received:
    0
    GPU:
    GTX TITAN @ 1150 MHz
    Much better now.
    Thanks ^^
     

Share This Page