Tip for nVidia users using HDMI and getting accurate color format

Discussion in 'Videocards - NVIDIA GeForce Drivers Section' started by jwb1, Nov 18, 2012.

  1. jwb1

    jwb1 Master Guru

    Messages:
    262
    Likes Received:
    0
    GPU:
    GTX 980 G1 Gaming
    EDIT: With driver 347.09+ color range has now been resolved.

    http://www.nvidia.com/download/driverResults.aspx/80913/en-us

    ---Original Post---

    This is only for nVidia users who are using HDMI on their display.

    If you're display supports Full RGB, which most do, you may notice you aren't getting the right colors and the blacks don't seem so black and the whites don't seem so white. This is because despite under Display->Adjust Desktop Color Settings your digital color format being set at RGB, its actually by default set at Limited RGB, not Full. And you will see there is no option for Full RGB. Don't use ycbcr444 as it will oversaturate reds and magentas.

    Full RGB is available only under Video->Adjust Video Color Settings, but this doesn't affect your games, applications, etc. Only videos.

    The trick to enable Full RGB for everything is a reg hack, and luckily you can use a tool to do instead. Find it here

    You must use this tool every time you install a new driver.
    Next, complain to nVidia to let this be a option in future drivers here:
    http://surveys.nvidia.com/index.jsp?pi=6e7ea6bb4a02641fa8f07694a40f8ac6
     
    Last edited: Dec 17, 2014
  2. Mr_ALLroy

    Mr_ALLroy Ancient Guru

    Messages:
    1,972
    Likes Received:
    1
    GPU:
    MSI GTX1080 Ti Gaming X
    No offence, but I'll wait to hear some feedback on this before I try it out.
     
  3. jwb1

    jwb1 Master Guru

    Messages:
    262
    Likes Received:
    0
    GPU:
    GTX 980 G1 Gaming
    Well I can tell you my feedback: my overall image quality in games is much improved.

    If Full RGB doesn't look good or improved, then there is also an option in the tool to go back to Limited RGB.
     
    Last edited: Nov 18, 2012
  4. JonnyRedHed

    JonnyRedHed Member Guru

    Messages:
    100
    Likes Received:
    0
    GPU:
    MSI GTX 670 PE/OC @1320
    Agreed it works just fine, thanks.

    I've just moved from ATI to NV and was wondering if my eyes were going with age or something as all my HD content (MKv etc) was less detailed and top white and bottom blacks were just not there. I then found this thread, and then Google it. The reg key hack has been around for sometime, with some writing a C# program to do the same thing, others posting the actual keys. But this little exe seems to work just fine. You see with ATI drivers you have an overall color format drop down and can toggle the various options which work over HDMI as well as DVI.

    I'm very surprised its not the same for NV, and cannot understand why they do not include this same option.

    One question with this though, does it clean its self and also what will happen when/if NV change the reg key names in future driver releases.

    Other than that, this works perfect and I can now see full range RGB once again over HDMI using Zoomplayer 8.5 + MadVR + Reclock.
     
    Last edited: Nov 18, 2012

  5. kingnosser

    kingnosser Banned

    Messages:
    105
    Likes Received:
    0
    GPU:
    MSI560tiTFII/OC/1GB
    Noticed the difference as soon as my desktop loaded, the difference it's made to web browsing is nice yet to try it in game, why on earth isn't this built into the drivers in the first place!!!

    Awesome try it out guys looking good here :D
     
  6. Supertribble

    Supertribble Master Guru

    Messages:
    463
    Likes Received:
    0
    GPU:
    too many to list :P
    My (rather old) Sony tele only supports limited RGB and the Nvidia driver defaults to full RGB not limited. As a result I have to use ycbcr444 to avoid black crush and it looks a bit crap. I'd love to be able to select limited RGB for desktop programs but Nvidia will never add that despite a lot of complaints over the years.
     
  7. HeavyHemi

    HeavyHemi Ancient Guru

    Messages:
    5,263
    Likes Received:
    5
    GPU:
    GTX1080Ti
    The last couple of these tools I tried didn't work. This one does and in Win8. Saves me the hassle of editing the nv_disp.inf file and needing to disable driver signing to clean install a driver.

    HeavyHemi Recommended.

    [​IMG]
     
  8. Bradders684

    Bradders684 Master Guru

    Messages:
    999
    Likes Received:
    0
    GPU:
    MSI GTX 980 Ti GAMING
  9. JonnyRedHed

    JonnyRedHed Member Guru

    Messages:
    100
    Likes Received:
    0
    GPU:
    MSI GTX 670 PE/OC @1320
    I found I needed to just run the windows 7 screen calibration tool again for my LG 50" plasma to just gamma correct a little. Rechecked my TV sets Black level and Dynamic contrast. Checked the black and white scale via this popular site checker here
    This will show a smooth gradient if using 0-255 and some banding if 16-235.

    Although your TV set's own settings and windows gamma calibration could also affect it slightly. I see a nice smooth black to white gradient, which along with my HD content tests using Zoomplayer + MadVR etc I now know I'm set at full RGB.
     
  10. PhazeDelta1

    PhazeDelta1 Moderator Staff Member

    Messages:
    15,613
    Likes Received:
    1
    GPU:
    EVGA 1080 FTW
    Thanks for the heads up.
     

  11. Uncle Dude

    Uncle Dude Ancient Guru

    Messages:
    2,307
    Likes Received:
    0
    GPU:
    GTX 1080 Ti
    Wow - massive difference on my Panasonic Viera. Love this forum; thanks for posting! :cheers:
     
  12. jwb1

    jwb1 Master Guru

    Messages:
    262
    Likes Received:
    0
    GPU:
    GTX 980 G1 Gaming
    If you uninstall or reinstall your driver, you will have to re-run this tool again.
     
  13. jwb1

    jwb1 Master Guru

    Messages:
    262
    Likes Received:
    0
    GPU:
    GTX 980 G1 Gaming
    This tool can allow you to pick Limited RGB as well.

    I do not recommend ycbcr444 for traditional displays, as it oversatures reds and magentas. And also adds a slight blur, as its a compressed signal format, unlike RGB which is uncompressed.

    Glad everyone is happy with it. Like I said, submit your feedback to nVidia to include this option in their future driver releases!
     
    Last edited: Nov 18, 2012
  14. vengeancerr1

    vengeancerr1 New Member

    Messages:
    4
    Likes Received:
    0
    GPU:
    EVGA 670 SC @ FTW 2GB SLI
    I know this is about Nvidia drivers but I was wondering if anyone knows how to get the same result for Intel drivers? I use my laptop to watch movies sometimes an it uses the Intel video for playback I think. I have to select the ycbcr mode because the screen is too bright without that checked in the Intel drivers.
     
  15. Supertribble

    Supertribble Master Guru

    Messages:
    463
    Likes Received:
    0
    GPU:
    too many to list :P
    Tried setting it to limited RGB and it doesn't work on my display. The only way I can get limited RGB working for desktop programs with this tele is to use an AMD card.
     

  16. MrBonk

    MrBonk Ancient Guru

    Messages:
    2,689
    Likes Received:
    0
    GPU:
    ASUS GTX 980 STRIX
    I suggest we make a thread for this over on the Nvidia forums and complain about it until they say they can fix it.
     
  17. jwb1

    jwb1 Master Guru

    Messages:
    262
    Likes Received:
    0
    GPU:
    GTX 980 G1 Gaming
    I have and I also notified two known nVidia employees.

    But as I said, spread the word via their feedback system and get your friends to do it as well!
     
  18. BetA

    BetA Ancient Guru

    Messages:
    3,950
    Likes Received:
    0
    GPU:
    MSI GTX670 PEOC@1350Mhz
    how do i use this if i have 2 monitors?
    i only need to set my second Monitor(HDTV) to full rgb.
    My first monitor is allready at full. since its an crt.

    Also, would that fix my prob im having when using HDMI?

    Im at VGA Cable now lol..and teh picture is 1000 times better then with hdmi.
    Its darker, blacks are black, and its sharp..
    with the hdmi cable its all washed out and sooo blurry i cant read anything..

    If someone would tell me that this would fix that i would be happy..also how to use it only on my second monitor..

    Thanks
     
  19. HonoredShadow

    HonoredShadow Ancient Guru

    Messages:
    4,220
    Likes Received:
    1
    GPU:
    MSI 980Ti OC+ASUS Swift
    Guess this does count with DisplayPort?
     
  20. lucidus

    lucidus Ancient Guru

    Messages:
    10,069
    Likes Received:
    31
    GPU:
    MSI Gaming X GTX 1070
    Interesting, bookmarked for future reference .. will give feedback to nvidia soon.
     

Share This Page