Three monitors on R9-290?

Discussion in 'Videocards - AMD Radeon Drivers Section' started by DrunkenDonkey, Mar 29, 2020.

  1. DrunkenDonkey

    DrunkenDonkey Master Guru

    Messages:
    207
    Likes Received:
    2
    GPU:
    2xPC 290 PCS+
    Hey, I'm not sure it is driver related problem, so not sure this is the right thread for it but here it goes:
    I do have Powercolor R9-290 PCS+, nice card that serves me still in the ever wait for a worthy upgrade. I do have a primary monitor attached to DP, secondary one to the DVI and when I try to plug the TV on the HDMI things gets interesting - I can't. The very millisecond I plug the HDMI and everything goes dark, the card's fan rave up to max and even the reset button is not working, have to power off the system completely. That works the other way around too - if I unplug the secondary (DVI) monitor and plug the HDMI - everythig is great, but if I plug the DVI again - black screen of death.

    Now... an year ago I used to have all three working, up to a point - it was unstable, the system will crash often and basically unmanageable thus I didnt use much, but that points me it is rather software than hardware problem... now it is 100% crash if I try. Yes, tried with various combinations from cold boot rather than on the fly. Any ideas or I shall just get used to having 2 things working at the same moment?
     
  2. Fox2232

    Fox2232 Ancient Guru

    Messages:
    10,529
    Likes Received:
    2,536
    GPU:
    5700XT+AW@240Hz
    Reset button not working is something that should not happen due to GPU. Then you have 2 graphics cards. And extra one integrated in CPU+MB with HDMI port.
    This means you have other options.
     
  3. G13Homi

    G13Homi Active Member

    Messages:
    99
    Likes Received:
    30
    GPU:
    5700xt 50th
    ye old trusty but loud r9 290x, i remember thee well. kept me very warm during the winters of '13 and '14.
     
  4. KyleStilkey

    KyleStilkey Master Guru

    Messages:
    475
    Likes Received:
    30
    GPU:
    Sapphire 5700 XT N+
    No issues here running 3 1 HDMI, DVI and Display 2 of them are 1080p the main is 1440p. What is the TV's resolution? It sounds like the moment it's trying to add another display the system is locking up which may be a driver/windows related issue to be honest. I would try testing without the DVI if possible and use a HDMI if possible or even try another device if it's a 4k TV and seeing if adding like another 1080p source causes the same issue. Might help pin the issue.
     

  5. DrunkenDonkey

    DrunkenDonkey Master Guru

    Messages:
    207
    Likes Received:
    2
    GPU:
    2xPC 290 PCS+
    TV is 4k indeed, but running in 1080 cuz yeah, can't handle it :) So all three are 1080.
    During the time I did a clean reinstall of the windows and countless driver changes (keeping up with the latest usually) and the problem became from bad (unstable) to worse (just crashing). The thing with the cables is a problem - the card has 1DP, 1HDMI, 2DVI, and thus I can't really try anything else besides using the 2 DVI instead of the DP, which is an idea and will try to find a cable
     
  6. KyleStilkey

    KyleStilkey Master Guru

    Messages:
    475
    Likes Received:
    30
    GPU:
    Sapphire 5700 XT N+
    Ah that's right, the 290 was that way, I've since replaced it with the 580 on my wifes PC but I would have then been DVI, DP, HDMI for my computer when I had it and when she had it but it's been pulled out since I upgraded to the 5700xt and she now has the 580.

    So yeah try two DVI and 1 HDMI or DP see if that's an issue but very strange.
     

Share This Page