this place seems to be my last hope...

Discussion in 'Videocards - AMD Radeon Drivers Section' started by Surebrec, Aug 29, 2012.

  1. kn00tcn

    kn00tcn Ancient Guru

    Messages:
    1,604
    Likes Received:
    2
    GPU:
    570m / MSI 660 Gaming OC
    12.7cap2 changed the f1 2011 profile to version 3, caps before it were version 2

    version2:
    version3:
    so, you could try using an older cap, modifying a new one, or forcing afrfriendly (maybe not, since that didnt scale at all for 2010, extremely rare case where an engine doesnt scale with afr, regardless of flickering... what a weird engine, the dirt games have been so much stabler)

    as for older drivers, you should be able to use dlls as mentioned

    aticfx32+atidxx32 = dx10+
    atiumdag = dx9

    the game hasnt been patched since 12.6 has it?

    oh &... isnt a single gpu of the 5970 fast enough for this game? at 1080p at least?
     
    Last edited: Aug 31, 2012
  2. Outrance

    Outrance Ancient Guru

    Messages:
    1,701
    Likes Received:
    0
    GPU:
    2x HD6950 950Mhz/1350Mhz
    You are correct, they were compressed.

    He has already tried disabling Catalyst AI and it didn't work. Renaming the .exe also doesn't work as it is essentially the same as creating a profile within Radeon Pro or CCC itself and they aren't achieving anything. There is something wrong with his driver install that is preventing CFX from being disabled.
     
  3. Surebrec

    Surebrec Member

    Messages:
    41
    Likes Received:
    0
    GPU:
    2GB ATI Radeon HD 5970
    it was before, had no problems running it.

    is it worth trying the 12.7 cap 2?
     
  4. kn00tcn

    kn00tcn Ancient Guru

    Messages:
    1,604
    Likes Received:
    2
    GPU:
    570m / MSI 660 Gaming OC
    12.7cap1, could try it..... uninstall current cap, install 12.7cap1, restart, try f1 2011
     

  5. Belz

    Belz Master Guru

    Messages:
    552
    Likes Received:
    0
    GPU:
    Sapphire HD5870 1GB
    Surebec, did you check the pci-e linkwidth as i asked above?
    I think you missed my post?
     
  6. Surebrec

    Surebrec Member

    Messages:
    41
    Likes Received:
    0
    GPU:
    2GB ATI Radeon HD 5970
    I can't find that one, only cap 3 seems to be listed on AMD now.

    no, I missed it, sorry. I'll check it now.
     
  7. Surebrec

    Surebrec Member

    Messages:
    41
    Likes Received:
    0
    GPU:
    2GB ATI Radeon HD 5970
    not sure what you mean by linkwidth, but here are some new screenshots is they help.

    [​IMG]

    these are profile the settings for F1 2011

    [​IMG]
     
  8. Belz

    Belz Master Guru

    Messages:
    552
    Likes Received:
    0
    GPU:
    Sapphire HD5870 1GB
    You only see that info in cpu-z
    You'll find that info in the Mainboard tab

    [​IMG]
     
    Last edited: Aug 31, 2012
  9. Surebrec

    Surebrec Member

    Messages:
    41
    Likes Received:
    0
    GPU:
    2GB ATI Radeon HD 5970
    oh right, sorry. I'll download that and give it a go, see what it pulls up
     
  10. Surebrec

    Surebrec Member

    Messages:
    41
    Likes Received:
    0
    GPU:
    2GB ATI Radeon HD 5970

  11. Alph4Dawg

    Alph4Dawg Member Guru

    Messages:
    108
    Likes Received:
    0
    GPU:
    Sapphire R9 280X Vapor OC
    WTH second card @X2 2.0...?
     
  12. Belz

    Belz Master Guru

    Messages:
    552
    Likes Received:
    0
    GPU:
    Sapphire HD5870 1GB
    It was worth a shot...

    PS: i just realised it's displayed in the gpu-z screen also... My bad



    Another thing i see now, is that your 2nd GPU isn't being stressed when running your game.
    Catalyst A.I is either disabled and gpu-z reports this wrong, or there is no good crossfire -profile associated with the game.

    I was being mislead in this thread by someone saying crossfire didnt work for this game and that the profile just disabled crossfire altogether when running it.


    Having not much experience in crossfire & profiles, i can only tell you to look for a good profile that enables AFR or something like that, or to rename the .exe from your game into the filename of another game that is configured to run in AFR (alternate frame rendering).

    Your drop in fps wouldnt be caused by a bad driver, but by your crossfire not kicking in...

    (sorry if this is a repost of what someone else already said, i didnt bother reading everything...)
     
  13. Belz

    Belz Master Guru

    Messages:
    552
    Likes Received:
    0
    GPU:
    Sapphire HD5870 1GB
    I missed that...
    That is weird indeed.
    Not sure if its a gpu-z bug with dual gpu cards or not though, since both gpus are on the same physical x16 bus
     
  14. Surebrec

    Surebrec Member

    Messages:
    41
    Likes Received:
    0
    GPU:
    2GB ATI Radeon HD 5970
    it is not a crossfire friendly game, that is why people suggest disabling it. most people that can disable it mention being able to get the frame rates they expect.

    I have no idea of the implications of this.
     
  15. Belz

    Belz Master Guru

    Messages:
    552
    Likes Received:
    0
    GPU:
    Sapphire HD5870 1GB
    It shouldn't matter to you, since your 2nd gpu is clearly not being used.

    Aren't the fps you're getting something a single 5870 would give?
     

  16. Surebrec

    Surebrec Member

    Messages:
    41
    Likes Received:
    0
    GPU:
    2GB ATI Radeon HD 5970
    unless a single 5870 gets on average about 25fps, no.

    besides, it has comfortably been able to get 60fps until recently.
     
  17. Outrance

    Outrance Ancient Guru

    Messages:
    1,701
    Likes Received:
    0
    GPU:
    2x HD6950 950Mhz/1350Mhz
    Have you ever tried playing F1 2011 with crossfire on? It has negative scaling. :stewpid:
     
  18. Valagard

    Valagard Guest

    Do the religious driver uninstall routine

    Goto programs and features

    Uninstall -EVERYTHING- AMD, and I mean everything. All of it, including CCC

    Go download Driver Fusion (Newest version of Driver sweeper) and install it

    Reboot to safe mode

    Run Driver Fusion, wipe out everything AMD/ATI

    Reboot to desktop

    Install newest drivers, complete package install

    Reboot

    Reboot again

    Configure graphic settings

    The -ONLY- other thing it could possibly be is you are cranking your graphics options far far far too high and you are exhausting the 1gig video memory limit, I know your 5970 says it has 2gigs of ram, but its using 1gig for each GPU, so essentially you only have 1gig of memory ram for the videocard.

    If you are exhausting this 1gig limit, you will show a severe FPS decrease, turning on things like AA etc can quickly exhaust the memory buffer. Hell me running TF2 with 2xAA, 16xAF and having 2xQAA enhance application settings and Adaptive anti-aliasing options on in TF2 takes up 970MB of my 7970's videocards ram
     
  19. Surebrec

    Surebrec Member

    Messages:
    41
    Likes Received:
    0
    GPU:
    2GB ATI Radeon HD 5970
    I already do all the steps you listed to uninstall drivers, it hasn't fixed the problem so far, and I don't think it will if I try again now.

    this game has never tested my graphics card in the past. I ran a test earlier with all the settings in the game set to either low, or off and I was still getting only getting about 33-35fps. even with one gpu disabled, it should not be giving that sort of performance.

    as for tf2. I have no problems at all running that, with everything maxed I can get a solid 59-60fps all the time, even with crossfire disabled in CCC.
     
  20. lmimmfn

    lmimmfn Ancient Guru

    Messages:
    10,461
    Likes Received:
    137
    GPU:
    AorusXtreme 1080Ti
    it used to work fine, i used to get F1 2010 performance withe 2011 version, i didnt have a chance to play it in several months, lol, now its completely unplayable, email sent to codemasters, fix or refund( doubt it will work but ill not buy any of their games from now on if thats the level of support they provide )
     
    Last edited: Sep 1, 2012

Share This Page