This is driving me freakin' Nuts.

Discussion in 'Videocards - NVIDIA GeForce' started by Zyrxil, Aug 15, 2002.

  1. Zyrxil

    Zyrxil Guest

    Long background short- In order to try to fix some problems with blurry text in Need for Speed: Porsche Unleashed, I was adjusting D3D texel alignment settings.

    Well, no matter what I adjusted them to, nothing seemed to change, visually, in anything. After a bit, I noticed no matter what I changed Texel alignment to in Display properties>Advanced>etc>etc, NVMax didn't reflect the change. In Rivatuner, the texel alignment option wasn't even workable. Something about not being able to change texel alignment on GF3 boards. After a bit, for some reason, I decided, while still having RivaTuner open, to disable FSAA. Closed the program, prompted me to reboot, no F'n way. Then I changed my mind, reenabled it, and again it prompted me to reboot, again I chose No.

    A few mins later, for some reason or other, I did reboot. Well after the WindowsXP starting screen, everything came up black, white line in upper left corner, login screen didn't show. Reboot, safe mode, uninstalled display drivers in Add/Remove programs, reboot, reinstall drivers, attempt to restore my old display settings when I noticedd...
    I can't. There is no Ti4200 tab under Advanced Display Properties. In fact, the damn thing wasn't even installed.

    Really long series of reboots, uninstalls cut short: Basically I've tried tons of uninstall reinstalls of the drivers, I've tried the 30.82 WHQL Detonators that I had been using, also the 28.32 off the Gainward CD that came with the card, no dice. Every single time, whether manually installing or using the setup programs, it never installs right. Only difference is, on manual installs, I actually get an error message that the installation process "could not find the specified file". That's just sooo bull considering 1. The 28.32 are on a CD, and I have used it successfully to install my vid card, 2. The 30.82 driver archive works fine and I used it not 2 weeks ago.

    No wait, I'm not done, I also tried other stuff- reenabling PnP OS in the bios, turning everything (using services.msc) to automatic that I disabled (besides the smart card stuff, QoS, Background intelligent server/transfer, and all the remote desktop/help session stuff).

    I've also tried running the Intel Chipset Application Software Installation Utility on the Asus PT-533C CD, which just gets me the message- This operating system already properly supports the Intel Chipset components blahblahblah INF files don't need updating.

    I run a newer version from the Intel website, same thing.

    The only thing I can add is that, once, between uninstall/reinstall/reboots, I noticed that the AGP controller was f'd for some reason, not being able to find enough resources or something like that. Disappeared after the reboot though.


    What the hell could be wrong? Keep in mind I didn't adjust anything physically. Also WinXP does detect the card and prompt me to install it on startup, and the monitor does actually get a signal (duh, how else could I have type this) so no, the card's not fried.



    Specs:
    Gainward Geforce 4 Ti4200
    P4 1.6a
    Asus PT-533C
    WinXP Pro
    NEC FE791SB monitor
    Antec True430 PSU
    Nothing OCed
     
  2. eugeneaiz

    eugeneaiz Guest

    I have basically the same problem.
    I 've been using 28.32 drivers successfully for some
    time and decided to upgrade to 30.82.
    Same results as you have with inability to
    install the old drivers, 'cause they also don't
    want to go in. Weird.....

    The only thing I've noticed is that if you try to
    use the newly installed driver BEFORE reboot,
    everything works like a charm and looks like it should.
    That suggests that drivers themselves are ok , but
    windows xp is screwing up installation somehow.

    Also , Nvidia tells to disable antivirus software in it's installation
    hints. Does that apply to you and have you tried that ?
     
  3. eugeneaiz

    eugeneaiz Guest

    Found a possible solution, a bit involved

    Here is a quote from the post by JNive on 8/10:

    Uninstall drivers and reboot
    create a folder to extract your drivers to : such as
    C:\Nvidia
    then go to these directories and delete any nv3.inf, nv4.inf, nv3.pnf , nv4.pnf and nv4_disp.inf files
    C:\WINDOWS\Inf
    C:\WINDOWS\System32\ReinstallBackups\ (all subfolders)
    C:\DRIVERS\Video (Dell Systems).

    Now run regedit (start menu->run->regedit)and navigate to this key.
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\Curr

    entVersion
    and add C:\Nvidia to the "device path" (eg %SystemRoot%\inf;C:\Nvidia) - semicolon between paths.
    Now uninstall driver from device manager.
    Then run regedit and navigate to
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Servic

    es
    and delete the nv and nv4 keys.
    Now reboot and the new drivers will be installed automatically.
    (if non-WHQL then click on "Automatically install best drivers" option when the hardware wizard appears).

    Now whenever you need to update drivers just place them in the C:\Nvidia folder - uninstall and reboot.
    (for .exe just right-click on the file and select "extract to" and point to the nvidia folder).


    Last edited by JNive on 08-10-2002 at 04:12 AM
     
  4. Zyrxil

    Zyrxil Guest

    Ah, deleting the nv3 and nv4 files did it, thank goodness. Not sure how many more reboots I could have gone through.

    Still don't understand why it was necessary though. Never had to do it in Win98, or when I installed 28.32 for the first time, or when I upgraded to 30.82. Oh well.
     

Share This Page