TheWorse v1.0 with Configurable Options

Discussion in 'Game Tweaks and Modifications' started by cmh175, Sep 24, 2014.

  1. cmh175

    cmh175 Master Guru

    Messages:
    412
    Likes Received:
    0
    Graphics Card::
    EVGA GTX 770 Classified
    TheWorse v1.0 with Configurable Options (Bad Blood Compatible)

    Ubisoft is releasing updates more and more frequently now and the majority of questions I answer on TW mod thread is where to find my Steam thread. This will be a copy and paste post from the thread and mainly used for updates so the mods are easier to find.


    Hey guys so TheWorse Mod v1.0 is finally out and considered completed, and as a whole I fully agree. It mostly delivers what we were hoping for and expecting prior to the games release. However somethings could still use some adjustments for a more realistic appearance and to optimize gameplay. I got a few pms about sharing my personal copy, but decided against opening yet another WD thread on Guru, so I'll share it here. My sweetfx are also included. I also included directions on how to increase performance to reduce stuttering, they'll work for vanilla or any mod of your choosing and are very simple. They're listed below under the screen shots.

    TheWorse mod has now been merged with my own mod as their similarities were too great after altering the colorgrading to fix the blue tint TheWorse mod had with the recent UBI patch.

    Downloads:

    cmh175_TW_Watch_Dogs Mod -> https://docs.google.com/file/d/0B1ZlTwoAa_q7alNFRTZONWwzOHc/edit

    Mirror: coming soon!

    High and Ultra Textures and Settings with Down Scaled Effects -> https://docs.google.com/file/d/0B1ZlTwoAa_q7UGxjNFNRclhXRDg/edit
    (For those who cant play with either High or Ultra settings. Use either High or Ultra textures and I suggest Ultra settings, but adjust for your own system accordingly.)

    Sweetfx for Windows 8.1 -> http://www.mediafire.com/download/ia1malgylpqkt4b/Watch_Dogs_Sweetfx_Win8.1.7z

    NOTE: Copy Sweetfx files into Watch_Dogs\bin folder.

    Yizan's Train Headlights -> http://www.mediafire.com/download/m...+Train+Headlights.7z#39;s_Train_Headlights.7z


    Those having issues installing Sweetfx should check the guide here -> http://steamcommunity.com/sharedfiles/filedetails/?id=289922515


    Changelog:

    -Merged with UBI patch v1.05.324.

    -TheWorse v1.0 merged with cmh175 Watch_Dogs mod.

    -Corrected Colorgrading issue in TheWorse mod to fix blue tint after recent patch.

    -New Bloom and Fog levels. Much more realistic and not nearly as blinding as TW v1.0.

    -Different Camera options based on location (far, near, or default) and level of DOF.

    -Choose between the light pollution effect at night or the default night sky.

    -TheWorse v1.0 enhanced Environment Lighting or Default (enhanced can cause very dark lighting at night, I suggest sticking with default which is already installed unless you've adjust your brightness for this)

    -Increased Civilian Density or Default.

    -Switch Dynamic Shadows Off or On.

    -Pick between TheWorse v1.0 Lens Flare, several different options from Solocreep, or the Default.

    -Pick between Maldo's Textures, TonyMBR's update of Maldo's Textures, or the Default.


    INSTALL DIRECTIONS:

    1) Unzip download folder and open "mods" folder in a separate window, then open the "Mod Options" folder.

    2) Select your preferred textures. Open the Texture Options and pick which texture mod you like (Default comes installed when you first unzip the download). Open the folder for that mod and copy the graphics folder inside, and paste it into the "mods" folder (overwrite everything when it asks, I already fixed this for compatibility).

    NOTE: If you decide to switch Texture options after installing another you MUST delete the graphics folder first inside the "mods" folder. Otherwise you will miss and match the mods. You will also need to reinstall your preferred Lens Flare mod.

    3) Now you can select the other options available. Just open up each configurable options folder, select the one you like, and copy the folders contents into the "mods" folder (overwrite everything when asked).

    NOTE: Solocreep's Lens Flare is the only option with multiple files. When you open the folder, select the option inside you like most, and copy the contents of THAT folder (don't copy anything that isn't a folder named generated, worlds or graphics). If you paste anything into the "mods" folder and see a new folder that wasn't there before, remove that new folder and try again.

    4) After you select the options you want open the MOD Installer.exe. It'll automatically recognize the "mods" folder you're about to zip. All you need to do is input your Watch_Dogs game install directory. Then just hit Install. When the green status bar is full the install status window will say it's completed, go ahead and close the MOD Installer.exe. The mod is now complete and installed, enjoy the game.

    NOTE: MOD Installer.exe has an uninstall option so you can now revert to the original mod you had installed. However the original patch files maybe overwritten if you run the MOD Installer.exe more than once.

    NOTE: Other than the Texture Options, you do NOT have to delete anything if you want to try any of the other options. I already fixed compatibility issues so you only have to pick what you want and copy the folders inside (example: to change camera and DOF options, just select a new option and copy the folders inside to the "mods" folder) Just remember to reinstall the mod every time you change something.

    NOTE: If you use a High Bloom setting and get a white out effect (weird bright white appearance) this is a known issue and I had originally dropped support for High Bloom settings. Try a Low Bloom setting and see if that fixes the issue, if not than post what settings you used and include a screenshot if possible.


    Troubleshooting Steps for Mod Installer Failing:

    -Try installing Visual Basic 2008, this will usually fix the issue -> http://www.google.com/url?sa=t&rct=...=cMffEyY91AWJD92Ua947qw&bvm=bv.75097201,d.aWw

    -If the Mod Installer still isn't installing correctly double check your install location for the installer. Make sure you have it set to the games main install directory (Watch_Dogs, not data_64 or anything else).

    -Sometimes there's an error about the file location having too many characters. If the mod is still failing try renaming the main folder something shorter, even just Mod. Chances are it'll work fine now.


    Here are some screen shots of the mod using my own preferred mod options (Ultra settings at 1080p).

    [​IMG]

    [​IMG]

    [​IMG]

    [​IMG]

    [​IMG]

    [​IMG]

    [​IMG]

    [​IMG]


    Performance Tips

    Now I'll share my findings on performance after tons of testing (which was more than I care to discuss lol).

    First I suggest basing your texture and quality settings on the suggestions from the game (some settings mention needing 3gb of vram). I suggest starting as high as you'd like to, and work your way down from there based on your performance.

    For this playing with Ultra textures and settings, you need to switch Shadows to High. They have a huge performance hit and the game really just cant handle it. You can max everything else out though.

    Next unless you're using SLI with anything higher than a 680 do not use 4x TXAA. It's not even recommend for a single Titan. Oddly enough 2xTXAA works fine though.

    For Nvidia users you can also make a custom graphic setting in Nivida Control Panel. Scroll to the bottom about Texture filtering and stuff and change your setting for Performance, though I recommend High Performance. It'll slightly degrade the image, but it's really not that noticeable. You can find more info on this here -> http://www.tweakguides.com/NVFORCE_6.html
    AMD users I'm sure there's a similar setup with RadeonPro, I just don't know anything about it.

    Now this is the biggest fix. WD has issues with v-snch, though I find it unplayable with screen tearing. What you need to do is Set VSync="1" AND RefreshRate="120" in C:\Users\yourname\Documents\My Games\Watch_Dogs\***\GamerProfile.xml (it's towards the very top, not too hard to find in notepad) Save the file and right click -> properties> enable read only.

    Now the game enables vsync only if the framerate is 60fps or above (like adaptive vsync) Only negative is you have to remove the read only tag to make permament changes to the settings in-game, and then set it to 120 and read only again.
     
    Last edited: Oct 2, 2014
  2. cmh175

    cmh175 Master Guru

    Messages:
    412
    Likes Received:
    0
    Graphics Card::
    EVGA GTX 770 Classified
    Hey guys. I updated the mods for the new patch and already tested compatibility issues. Both versions of the mod work fine with the game and the new dlc. I'll post an update when the links are updated.

    ~Good to go, updated mods are ready.
     
    Last edited: Sep 24, 2014
  3. Raz3d

    Raz3d Member

    Messages:
    31
    Likes Received:
    0
    Graphics Card::
    GTX 1080 FE SLI
    Hi, any idea why my game has a blue hue to it? I downloaded the custom configurable settings mod.

    Edit: Your other settings download works just fine and the colors are good but I can't get it to play the Bad Blood DLC. Anyway you can fix that?


    [​IMG]
     
    Last edited: Sep 24, 2014
  4. cmh175

    cmh175 Master Guru

    Messages:
    412
    Likes Received:
    0
    Graphics Card::
    EVGA GTX 770 Classified
    Your game is blue!? I can only suggest having Uplay check and repair your install files and try again. What happens when you try to play the dlc? Is it missing from the menu or does the game get hung or just crash to the desktop? Both the game and new T-Bone dlc work fine for me.

    ~Added alternate downloads for those having trouble with google.
     
    Last edited: Sep 24, 2014

  5. Marduk

    Marduk Master Guru

    Messages:
    663
    Likes Received:
    0
    Graphics Card::
    gtx 780m
    its blue, because they are wrong values in the windy_city.game.xml by using an other edited colorgrading lib.

    try to set them in windy_city.game.xml, in the line clorgrading in the weatherpresets

    1 . unpack mod with dirsrup
    2. go to the folder worlds\windy_city\generated\windy_city.game.xml
    3. rename windy_city.game.xml to windy_city.game.rml
    4 . open the file with notepad
    5. search the weatherpresets


    Clear
    Clear_Rain0_Cloud0.4
    Clear_Rain0_Cloud0.6
    Clear_Rain0.01_Cloud0.9
    Clear_Rain0.5_Cloud1
    Storm

    and check the colorgradingColorgrading=xxxxx values, and try to change them to 38291527)

    6. save
    7. drag drop to disrupt.conver.xml
    8. rename windy_city_converted.rml to windy_city.game.xml
    9. repack the mod and test
     
    Last edited: Sep 24, 2014
  6. cmh175

    cmh175 Master Guru

    Messages:
    412
    Likes Received:
    0
    Graphics Card::
    EVGA GTX 770 Classified
    I appreciate the suggestion but that doesn't make sense. If that were the issue wouldn't my game be blue too? I haven't changed these settings since the original TheWorse mod v1.0 released months ago too, this is the first I've heard of this since then. I also based my colorgrading on Lunayah's mod and the Pure E3, so they would have the same issues. I've seen previous posts about blue screens, it seems to be a rare anomaly, it usually seemed to clear itself up by repairing your install files and reinstalling the mod.
     
    Last edited: Sep 24, 2014
  7. Marduk

    Marduk Master Guru

    Messages:
    663
    Likes Received:
    0
    Graphics Card::
    gtx 780m
    I dont have this issue by the mods as they are release, but somebody merge some thing. and have this isues, also white blue at day (like the light flash when you Start profiler.
    as i have changed some values (to make my test and look how the values work) in the windy_city.game.xml i have Seen this to . seems to be an issue of a imbalance of a clorgrading.lib and the values in the windy_city.game.xml(if you have change the values, or merge different mods) .
     
    Last edited: Sep 24, 2014
  8. cmh175

    cmh175 Master Guru

    Messages:
    412
    Likes Received:
    0
    Graphics Card::
    EVGA GTX 770 Classified
    Ok that makes more sense. I agree, you can get some wonky results if you're merging different mods. If you're using nothing but the options in my downloads though that wont be the case. There's only one colorgrading.lib file and each windy_city.game.xml file available have matching settings, other than the alternate options for bloom and fog and such.
     
  9. Quest

    Quest Member Guru

    Messages:
    120
    Likes Received:
    0
    Graphics Card::
    SLI GTX 770 JETSTREAM 4GB
    Anyone can shere worse mod + 1.05
     
  10. cmh175

    cmh175 Master Guru

    Messages:
    412
    Likes Received:
    0
    Graphics Card::
    EVGA GTX 770 Classified
    You mean the latest patch right? The mods are kept up to date with patches and work with the new T-Bone dlc.
     

  11. DavidHigh

    DavidHigh Member

    Messages:
    16
    Likes Received:
    0
    Graphics Card::
    GTX680 2GB
    Updated version of the mod perfectly working with Watch Dogs main game AND Bad Blood DLC as well!!! I've played both for a couple of hours and everything works as usual with this mod! Thank you! :D
     
  12. cmh175

    cmh175 Master Guru

    Messages:
    412
    Likes Received:
    0
    Graphics Card::
    EVGA GTX 770 Classified
    Glad to hear it man. For those seeing the weird blue tint, are you using TheWorse mod with Config options? It hit me that Marduk had a point about the colorgrading. My mod works fine because the colorgrading isn't all that altered, but I forgot that TW mod is heavily altered. So let me know which you're using if you see the blue tint. I'll do some testing later, if I'm right I know what the problem is. It doesn't make sense it's an issue anyway since TW mod has worked fine for months. Ubi must have changed something that causes this if you have altered colorgrading, curious.
     
  13. Damazig

    Damazig Member

    Messages:
    13
    Likes Received:
    0
    Graphics Card::
    GTX 770 OC
    hey cmh175, I've downloaded your configurable mod, and as soon as I start unzipping, winrar diagnostics just fills up with errors.

    I'd love to try Theworse mod on the Bad Blood DLC. Any help you can give? is it something I'm doing wrong?

    Thanks
     
  14. cmh175

    cmh175 Master Guru

    Messages:
    412
    Likes Received:
    0
    Graphics Card::
    EVGA GTX 770 Classified
    Is that the file from google? Try the mirror link, for some reason google is having issues recently.
     
  15. Damazig

    Damazig Member

    Messages:
    13
    Likes Received:
    0
    Graphics Card::
    GTX 770 OC
    I tried both, same thing happens, it downloads fine, but when extracting from the zip, it has loads of errors, eventhough I did try the extracted files anyway, and when I use the mod installer, it just fails.
     

  16. cmh175

    cmh175 Master Guru

    Messages:
    412
    Likes Received:
    0
    Graphics Card::
    EVGA GTX 770 Classified
    I'm sorry man, I tested all the links and everything downloads and unzips fine for me. My only suggestion would be to try a different browser.
     
  17. Damazig

    Damazig Member

    Messages:
    13
    Likes Received:
    0
    Graphics Card::
    GTX 770 OC
    I think I may have found the error, I tried unzipping now with 7zip instead of winrar, and it tells me that the name path is too long, too many characters and that might be the problem, gonna try shortening the folder names a bit and unzip it outside of so many other folder paths and see if it works.
     
  18. cmh175

    cmh175 Master Guru

    Messages:
    412
    Likes Received:
    0
    Graphics Card::
    EVGA GTX 770 Classified
    Ah ok. Yeah rename the main file WD mod or something, and try put it on your desktop. That's weird, but at least an easy fix.
     
  19. Damazig

    Damazig Member

    Messages:
    13
    Likes Received:
    0
    Graphics Card::
    GTX 770 OC
    Yeah its working mate :D thanks alot, so far the only thing I've seen that doesn't work well is using the lighting from Theworse mod, places like T-bones new base has 0 lighting, its all dark. His phone on his back seemed to also have some lighting and bloom on default and its missing now.

    Thanks alot mate :D
     
  20. cmh175

    cmh175 Master Guru

    Messages:
    412
    Likes Received:
    0
    Graphics Card::
    EVGA GTX 770 Classified
    Are you using TheWorse mod or the cmh175 mod? TW mod may have some issues with a blue tint to the overall appearance. As for the lighting, did you use the environment lighting option? This makes it super dark at night or in dark rooms, I suggest just using default.
     

Share This Page