1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

The Witcher 3 microstutter when using RTSS @60

Discussion in 'Rivatuner Statistics Server (RTSS) Forum' started by Johnny99, Aug 16, 2018.

  1. Johnny99

    Johnny99 Member

    Messages:
    10
    Likes Received:
    0
    GPU:
    GTX 1060 6GB
    Hello. I was experiencing heavy microstuttering in TW3 before I started using RTSS. Using it removed the microstutter completely, except I can still see slight microstuttering, especially visible in bright areas (sunshine on the ground, lit braziers etc). I have tested both in-game unlimited and in-game FPS limiter - they stutter a lot worse, but not in this particular way.
     
  2. RealNC

    RealNC Ancient Guru

    Messages:
    2,240
    Likes Received:
    538
    GPU:
    EVGA GTX 980 Ti FTW
    Lower the RTSS cap a bit. If you have it at 60 right now, use 59.9 instead and see if that helps. When using vsync, the frame cap might not get triggered all the time because of vsync. A cap that's slightly lower than your refresh rate will usually smooth out frame times correctly in Witcher 3.

    Note that you need at least RTSS 7.2.0 Beta 2 to be able to enter fractional FPS caps. Get it from here:

    https://www.guru3d.com/files-details/rtss-rivatuner-statistics-server-download.html

    You might also want to read this, as it's somewhat related:

    https://forums.guru3d.com/threads/the-truth-about-pre-rendering-0.365860/page-12#post-5380262
     
    StephenEnzor likes this.
  3. Johnny99

    Johnny99 Member

    Messages:
    10
    Likes Received:
    0
    GPU:
    GTX 1060 6GB
    Thanks, tried it but doesn't seem to be the issue (I already had the latest beta, too).
     
  4. RealNC

    RealNC Ancient Guru

    Messages:
    2,240
    Likes Received:
    538
    GPU:
    EVGA GTX 980 Ti FTW
    Does it happen while moving, or also when standing still? If it happens when moving, that appears to be normal (asset loading stutters.)
     

  5. Johnny99

    Johnny99 Member

    Messages:
    10
    Likes Received:
    0
    GPU:
    GTX 1060 6GB
    No, doesn't happen while moving. It's more or less only noticeable when walking past bright areas, for some reason. A very little stutter.
     
  6. RealNC

    RealNC Ancient Guru

    Messages:
    2,240
    Likes Received:
    538
    GPU:
    EVGA GTX 980 Ti FTW
    What happens if you cap to 59? (Temporarily to see if the fast micro-stutter gets fixed. You will get 1 hiccup per second with 59FPS, so ignore that.)
     
  7. Johnny99

    Johnny99 Member

    Messages:
    10
    Likes Received:
    0
    GPU:
    GTX 1060 6GB
    If I cap to 59, I can't see it because of the hiccup you mentioned. The little jitter I see at 60 is no problem at all, I just wanted to know if anyone else experiences it with RTSS. RTSS is as close to perfect as it can get.
     
  8. RealNC

    RealNC Ancient Guru

    Messages:
    2,240
    Likes Received:
    538
    GPU:
    EVGA GTX 980 Ti FTW
    Experiment, man. Try 59.5. That should give you two seconds of no hiccup to see if the jitter is there. Then go to 59.6, 59.7, etc.

    I do not get any jitter while standing still and just looking around. When moving, I do get a bit of very minor stutters, but that's due to the game streaming stuff from disk.

    Edit:
    Btw, I assume you're using vsync. If you use fast sync (bad idea at 60FPS), a bit of jitter is normal. Also, try disabling vsync in-game, and enable it in the nvidia panel instead. Sometimes this cures jitter issues. Also try setting "max pre-rendered frames" to 1 and then 2 in the nvidia panel to see if that does affect anything.
     
  9. Johnny99

    Johnny99 Member

    Messages:
    10
    Likes Received:
    0
    GPU:
    GTX 1060 6GB
    I think we are experiencing the same thing then. 59.9 seems to be the only setting other than 60 where I don't get the hiccups, but it behaves exactly the same as 60. I'm not using Fast Sync, never did, I honestly find it terrible, it's nowhere near as smooth as normal VSync. About the pre-rendered frames, I have pre-rendered frames set to 1, and VR pre-rendered frames set to Application controlled. I also have Triple Buffering on, even though I heard setting it via NVCP only applies to OpenGL games but eh. I do not notice any difference when fiddling with pre-rendered frames and using RTSS at the same time, only when not using RTSS (when playing with Max FPS set to Unlimited). Then the game is smoother with less input lag, but RTSS gets rid of it much better.
     
  10. Smough

    Smough Member

    Messages:
    44
    Likes Received:
    2
    GPU:
    GTX 1060 3GB
    Witcher 3 seems to go nuts with frame rate limiters or frame time stabilization. I have the latest version of RivaTuner and still, the game has big lag spikes when I limit the frame rate, no game does this. Also, another alternative is to use Windows 10 Full Screen Optimizations, most games get perfect frame time with this without RivaTuner but on this game the CPU goes 100% at towns with NPCs and creates fps drops with this setting on, if you disable it CPU usage goes back to normal. Its like the devs. of The Witcher 3 don't even know how to make their game work properly.

    The game gives me issues with two PCs: One with an i5 4590, GTX 970, one with an i7 4770, GTX 1060. Both computers are free of malware, they both have an SSD and enough RAM (8). The issues are present at any frame rate, 30, 40, 60...

    Perphaps I should contact CDPR, but I honestly doubt they be able to solve anything if they haven't done so in years.
     

  11. RealNC

    RealNC Ancient Guru

    Messages:
    2,240
    Likes Received:
    538
    GPU:
    EVGA GTX 980 Ti FTW
    Did you disable in-game vysnc and in-game FPS limiter?
     
  12. Smough

    Smough Member

    Messages:
    44
    Likes Received:
    2
    GPU:
    GTX 1060 3GB
    Yeah, I tried all of that, the game just seems to hate it. At the moment, using the nVidia frame rate limiter V2 and RivaTuner seem to make the game stutter less, even so, not a 100% free of stutter. The only way the game runs "smooth" is when you don't use any frame rate limiter and just use normal v-sync or half v-sync, the problem with this is that the Witcher 3 has crazy frame times all over the place, that to be honest, never seen before at any game to this date. This even with max pre rendered frames set to 1.

    If you could do some testing and see if you can get it better I would be eternally grateful because to be honest, I am not a fan of the nVidia frame rate limiter, but is the best thing for me right now.

    On a side note, the nVidia frame rate limiter by itself WITHOUT RivaTuner frame rate limiter frees the game of any stutter, but the frame time line shows small bumps that sometimes can be seen in-game even though MSI Afterburner reports perfect frame times in-game. If you want, I can give you the graphs.
     
  13. Smough

    Smough Member

    Messages:
    44
    Likes Received:
    2
    GPU:
    GTX 1060 3GB
    All forms of v-sync disabled, locking the fps with RivaTuner plus nVIdia Inpector's frame rate limiter made the game a 100% smooth with no stutter at all for the moment. I will keep playing the game to see how it keeps going.
     
  14. Smough

    Smough Member

    Messages:
    44
    Likes Received:
    2
    GPU:
    GTX 1060 3GB
    Go to RivaTuner "Setup" and set "Frame Averaging Interval" to 0 for the your Witcher 3 .exe and see if it gives you any positive results.
     
  15. Johnny99

    Johnny99 Member

    Messages:
    10
    Likes Received:
    0
    GPU:
    GTX 1060 6GB
    I can't find that anywhere. Edit: nevermind, found it.
     

  16. Smough

    Smough Member

    Messages:
    44
    Likes Received:
    2
    GPU:
    GTX 1060 3GB
    Tell me if it works. I also have a similar issue with the game at 60 fps with RivaTuner and have not found a perfect fix yet.
     
  17. Smough

    Smough Member

    Messages:
    44
    Likes Received:
    2
    GPU:
    GTX 1060 3GB
    Basically, without RivaTuner the games runs pretty well at 60 fps even on an i5 4590, the CPU does not go to a 100% even on Novigrad, which is quite nice, but the problem is the frame time and only RivaTuner can give me good frame times with some stutter, my screen is 60.002 Hz so I am bit clueless where to se the limiter, I've tried several (59.999, 59.982, 59.995) but the issue persists.
     

Share This Page