The Witcher 3 Best Performance

Discussion in 'Videocards - AMD Radeon Drivers Section' started by Raziael, May 19, 2015.

  1. nevernamed

    nevernamed Master Guru

    Messages:
    231
    Likes Received:
    3
    GPU:
    Saffire R9290x VaporX 8gb
    This might be a faux pas, but I lowered the game to 900p.. It's not quite as sharp. but in the areas that I couldn't hold 60 fps, it now pretty much stays there. with everything ultra except for foliage/shadows.. It's either that or lock down to 30 fps.. and to me, 900p doesn't really negatively affect this game.
     
  2. PrMinisterGR

    PrMinisterGR Ancient Guru

    Messages:
    7,005
    Likes Received:
    138
    GPU:
    Sapphire 7970 Quadrobake
    Or you can enable 1080p50 from the CCC, and lock it at 50Hz. I have made a little script that I added to RadeonPro that switches the screen to 50Hz when the game launches, and then switches back to 60 for the desktop. RadeonPro's Hz setting is not working unfortunately. The scripts are using Display Changer.
     
  3. nevernamed

    nevernamed Master Guru

    Messages:
    231
    Likes Received:
    3
    GPU:
    Saffire R9290x VaporX 8gb
    Problem is it seems to drop to the mid 40s in busy town areas and even with rain.. does 50 look good on a 60 hz screen?

    you wouldn't have any amd suggestions for the GTA v 1920x1080 59hz issue would you?
     
  4. PrMinisterGR

    PrMinisterGR Ancient Guru

    Messages:
    7,005
    Likes Received:
    138
    GPU:
    Sapphire 7970 Quadrobake
    If you drop everything to high, and enable SSAO, it will stay locked at 50. I have no issue with GTA V. 59Hz is another way to say 60. They are both 59.94 anyway.
     

  5. isidore

    isidore Ancient Guru

    Messages:
    6,183
    Likes Received:
    10
    GPU:
    R9 FuryX 4GB HBM
    then push all settings to max and run the game in higher resolution with down sampling if your monitor can't support at stock and see if your gpu load increases. Also disable v-sync.
     
  6. nevernamed

    nevernamed Master Guru

    Messages:
    231
    Likes Received:
    3
    GPU:
    Saffire R9290x VaporX 8gb
    I've dropped everything to low and it still fluctuated all over the place, thats the strange thing. as for GTA V, the 59hz thing causes as a stutter, since when its locked to 59 hz, the framerate seems to hang 58/59, which causes weird stuttering all the time.. when i run 1920x1200, it runs at a solid locked 60. which is fine, it doesn't bother me aside from some menus and overlays looking slightly funny, but in this game, the 59 / 60 hz thing 100% makes a difference.
     
  7. PrMinisterGR

    PrMinisterGR Ancient Guru

    Messages:
    7,005
    Likes Received:
    138
    GPU:
    Sapphire 7970 Quadrobake
    Do you have the game installed on a mechanical drive or an SSD? Do you have the 1.07 patch? The game fluctuates, but if as you say you have everything on low, you should be stuck at 60, I know at least I am.
     
  8. kandata94

    kandata94 Active Member

    Messages:
    53
    Likes Received:
    0
    GPU:
    R9 280X DirectCU II
    Is there a way to play this game with a "smooth" 30fps lock? I've tried everything (Msi, dxtory, fps cap ingame, fullscreen and borderless windows), but the game stutters anyway. Thanks in advance.
     
  9. tibbtobb

    tibbtobb Member

    Messages:
    10
    Likes Received:
    0
    GPU:
    MSI 280x @ 1150
    Have you tried Double Vsync in Radeon Pro?
    That's what works best for me and a number of other people including PrMinisterGR.
     
  10. PrMinisterGR

    PrMinisterGR Ancient Guru

    Messages:
    7,005
    Likes Received:
    138
    GPU:
    Sapphire 7970 Quadrobake
    Double vsync from RadeonPro and the in-game 30 fps lock. It will be a bit stuttery the first couple of minutes you load a game, and you might get momentary stutters if you go to a big area with a different tileset.
     

  11. kandata94

    kandata94 Active Member

    Messages:
    53
    Likes Received:
    0
    GPU:
    R9 280X DirectCU II
    Unfortunately radeonpro forces witcher 3 to crash at startup (catalyst 15.07, gog version, win7 64bit), i tried to disable api monitoring and add the exe to the compatibility list, but the game keeps crashing. Is there something else i can try to run witcher 3 with radeonpro? Thanks guys
     
  12. tibbtobb

    tibbtobb Member

    Messages:
    10
    Likes Received:
    0
    GPU:
    MSI 280x @ 1150
    Have you tried closing all other programs that could interfere? You should be able to launch the game without GoG as it is DRM free.
     
  13. howzz1854

    howzz1854 Member

    Messages:
    27
    Likes Received:
    0
    GPU:
    dual Sapphire Tri-x R290x
    hey guys,

    what's the "latest general consensus" on crossfire, in particular for Witcher 3. is it worth it? i ask because i already have a 290X, and is looking to get another one due to a decent deal. but if it's not worth it, i'll pass on the deal.
     
  14. kandata94

    kandata94 Active Member

    Messages:
    53
    Likes Received:
    0
    GPU:
    R9 280X DirectCU II
    I tried to close all overlays software, i tried formatting windows and switching drivers, i tried to launch the game without gog, but nothing to do. This happens with GTA V and fifa 15 as well.
     
  15. tibbtobb

    tibbtobb Member

    Messages:
    10
    Likes Received:
    0
    GPU:
    MSI 280x @ 1150
    When you added the game to the compatibility list you ticked all the boxes except D3D11 and API detection?
    Sorry, there is nothing else I can think of.
     

  16. kandata94

    kandata94 Active Member

    Messages:
    53
    Likes Received:
    0
    GPU:
    R9 280X DirectCU II
    Yes, but it keeps crashing. I'm starting to think there is an incompatibilty issue with my asus r9 280x. The problem is that there isn't another software with dynamic/adaptive v-sync features for amd cards. Thanks for your help anyway, i'm going crazy :bang:
     
  17. PrMinisterGR

    PrMinisterGR Ancient Guru

    Messages:
    7,005
    Likes Received:
    138
    GPU:
    Sapphire 7970 Quadrobake
    Do you have D3dGear or Xsplit installed? Or OBS? All these could interfere. RadeonPro works fine here with the GoG release of the Witcher.
     
  18. kandata94

    kandata94 Active Member

    Messages:
    53
    Likes Received:
    0
    GPU:
    R9 280X DirectCU II
    No, no software running in background. I don't understand, with old games that i have (borderlands, batman arkham city) it works well, but with these new games like fifa15, arkham knight, the witcher 3 and gta v it forces these games to crash at startup.:bang::bang:
     
  19. The Mac

    The Mac Ancient Guru

    Messages:
    4,408
    Likes Received:
    0
    GPU:
    Sapphire R9-290 Vapor-X
    FRAPS will mess it up too if you try to use smaa/sweetfx/reshade.
     
  20. janos666

    janos666 Master Guru

    Messages:
    689
    Likes Received:
    51
    GPU:
    MSI GTX1070 SH EK X 8Gb
    I don't claim these are the best settings for everyone but I just started the game and spent a relatively long time with tuning the settings on the first few areas (both indoor and outdoor). My subjective opinion is that it's best played on a 290X (although, mine comes with Stilt BIOS and clocked at 1150/1350 MHz) with these settings for ~FullHD resolution (you will obviously need a faster GPU department or lower settings for significantly higher resolutions...):

    - Every post-process filters turned OFF, except Ambient Occlusion at HBAO+
    - Every graphics options at their maximum except HairWorks at OFF and Foliage Visibility Range at High


    Reasoning:

    I hate (both objectively and subjectively) every post-process filters which has to do anything with artificial blurring and/or sharpening (especially if they are both active at the same time -> HORROR!), so Blur and Motion Blur, as well as Sharpening were no-brainer OFF. These are just silly things IMHO. (If you think you need these, you probably have some configuration problems somewhere else and you try to counter those, in a wrong way...)

    I took some screenshots and found that the in-game Anti-Alising (like practically every similar post-process AA) introduces too much blur on the overall image to make it a good trade. It also leaves behind a decent amount of aliasing and not entirely "free" on the GPU performance which makes it an easier decision to turn it OFF. (But it's not as obvious as the settings above.)

    Bloom is a tough one. The effect is pretty but leaves a heavy "obvious fake" taste in my mouth. Since it's not fully "free" either (although, the cost is really low) I decided to turn this OFF as well. But yeah, it's a really tough decision. It's probably better to flip a coin than to start over-analyzing it...

    DOF, CA, V, LS -> I think these are just silly "HollyWooDooo" effects. They taste like fake and makes my stomach hurt. For example, if Chromatic Aberration was a thing on PC graphics, I would like a filter to get rid of it, not to make it more obvious. The same thing with DOF: I would carve for a camera which can take the shot without DOF, I wouldn't pay for a camera to make more DOF, let alone add an artificial fake-DOF and pay GPU performance for it...

    I have to admit, I like Ambient Occlusion. It's fake but HBAO+ is a decent fake (much better than simple SSAO). It would obviously be better to achieve a "real" result through actual shading but the fake result is better than nothing and it looks "right" more often than not. But make your own decision because it's fake and it's far from being free on the GPU (especially HBAO+ on AMD cards but SSAO is too fake-ish for me, so I would opt for OFF or HBAO+ but no simple SSAO, that one is just too fake for me...).

    HairWorks - Way too expensive (at least on AMD cards) for what it is. It's nice but I can't afford it. I need that performance to make the overall image look good, not just the hair. And I won't sacrifice the smooth 60fps PC gameplay for pretty hairs.


    Take it into consideration that this is an overclocked 290X and I have Win10 with the latest 1055 beta driver. I probably wouldn't have ~60fps with Win8.1 and older Win8 drivers because it's only ~90% of the time I actually get it. It drops below 60 on rare occasions. But I won't tune everything down significantly to make it run at rock stable 60fps. It's not fast paced FPS game, so I can accept some rare fps drops (not too often though and I definitely wouldn't enjoy playing at fix 30fps regardless of the game style).


    Edit:

    One more thing... Fullscreen mode has a broken Gamma control (it's doesn't matter where I set it, the image looks absolutely the same) and the default custom gamma is very different from the default gamma in Windowed mode (where you have no Gamma control at all ; well, not even a fake one which doesn't work anyway, like in Fullscreen mode...).
    For this reason, I use Windowed mode because I believe that's the correct gamma. The seemingly adjustable but in fact fixed custom gamma in Fullscreen looks way too dark in my opinion. The gamma in Windowed mode looks right (which is probably an un-managed "passthrough" --as it should be at default-- or precessed with a perfectly linear table).
     
    Last edited: Jul 21, 2015

Share This Page