The Witcher 3 Best Performance

Discussion in 'Videocards - AMD Radeon Drivers Section' started by Raziael, May 19, 2015.

  1. theoneofgod

    theoneofgod Ancient Guru

    Messages:
    4,161
    Likes Received:
    83
    GPU:
    RX 580 8GB
    Tried those settings too. Does my head in.
     
  2. sammarbella

    sammarbella Ancient Guru

    Messages:
    3,931
    Likes Received:
    178
    GPU:
    290X Lightning CFX (H2O)
    Maybe RTSS will solve frametime problems in single GPU (and in window borderless) but in CFX scenario where the game MUST be run in real fullscreen mode frametime problem is a different beast to "beat".
     
  3. theoneofgod

    theoneofgod Ancient Guru

    Messages:
    4,161
    Likes Received:
    83
    GPU:
    RX 580 8GB
    Tiger Team suggestion was not to disable the second GPU but to take it out and put it away. I might take them up on that.
     
  4. Bloodred217

    Bloodred217 Master Guru

    Messages:
    356
    Likes Received:
    1
    GPU:
    2x GTX 1080 G1 Gaming 8GB
    There was an article that said the in-game lock just works on the number of frames rendered in a second, it doesn't actually lock frame time. RTSS definitely locks frame time so as long as the system is fast enough to render at that frame rate it should be very smooth.

    I use it so I don't have to fiddle with 2 controls for the same thing since I sometimes lock FPS to 45 (can't hold 60 using Steam IHS and 30 is too stuttery for me).
     

  5. sammarbella

    sammarbella Ancient Guru

    Messages:
    3,931
    Likes Received:
    178
    GPU:
    290X Lightning CFX (H2O)
    Hopefully i have a true 290X CFX and not a 295X2 so no scissor needed here to apply Tiger Team CFX "solution". :D
     
  6. Chanhkun

    Chanhkun New Member

    Messages:
    4
    Likes Received:
    0
    GPU:
    2x HD7970 3gb
    the framerate is limited to 50. there is no tearing.
     
  7. theoneofgod

    theoneofgod Ancient Guru

    Messages:
    4,161
    Likes Received:
    83
    GPU:
    RX 580 8GB
    Huh?
     
  8. VAAS

    VAAS Member Guru

    Messages:
    143
    Likes Received:
    0
    GPU:
    Asus R9270OC 2Gb
    I always run my games with RTSS cap + borderless window for DWM triple-buffered v-sync, it just works
     
  9. zerowalker

    zerowalker Master Guru

    Messages:
    351
    Likes Received:
    0
    GPU:
    AMD R9 380
    Wait, RTSS cap + Vsync is better than just vsync?
     
  10. theoneofgod

    theoneofgod Ancient Guru

    Messages:
    4,161
    Likes Received:
    83
    GPU:
    RX 580 8GB
    No they meant disable in game vsync and use borderless windowed which in itself enables Windows vsync/tripple buffering for the windows (that's why it's there in games).
     

  11. The Mac

    The Mac Ancient Guru

    Messages:
    4,408
    Likes Received:
    0
    GPU:
    Sapphire R9-290 Vapor-X
    TB is enabled by default on the desktop, so if you run in windowed mode its automatically enabled so you dont have to force it with RadeonPro or D3DOverrider.
     
  12. soulburner

    soulburner Member

    Messages:
    12
    Likes Received:
    0
    GPU:
    Asus R9 290 DirectCU II
    The game runs pretty much fine, with a mix of high and ultra settings, hairworks off, HBAO+ enabled, I get 60fps most of the time with occasional drops to 50-something. When it's 60, it's super smooth, however when dropping below 60 it's stuttering very badly. Using RTSS doesn't help - it even makes things worse causing stuttering all the time :p
     
  13. oGow89

    oGow89 Maha Guru

    Messages:
    1,213
    Likes Received:
    0
    GPU:
    Gainward Phoenix 1070 GS
    Well yea the game runs fine for me too, but i put on hold and waiting for a driver that could possibly squeeze more performance out of the card. With the latest game patches, nvidia cards saw performance boost whilst not the case for amd. When the game first came out the 970 and r9 290 delivered the same performance, now the 970 is pulling a head with avg of 10 fps. So yeah just finish some other games and wait for this awaited miracle driver. I play the game btw without hairworks so if anyone has objections to my post, and no i ain't using any setting other than ultra for any game just to please any of you, that is why i got 290. So yea to amd i too got my downs and ups, but your down is taking a major slide down the road of bankruptcy. I got wanting to build gaming pcs and i can't really convince them to go with amd anymore. Over here in germany, amd is like an uncharted territory. Most electronic stores don't even have amd cards on their shelves. Mindfactory the newegg of germany and neighboring countries, rates nvidia gpus over amd and the 970 is selling here faster than fire spreading on gas. I'm just saying ;)
     
  14. RexOmnipotentus

    RexOmnipotentus Master Guru

    Messages:
    796
    Likes Received:
    4
    GPU:
    Vega 64
    If you want better scaling with the new drivers, you need to enable Vsync. This gives me better scaling and a higher framerate.

    Instead of a maximum scaling of 88/88 i can reach 95/95+ scaling. Alsof gives me 60/61 FPS instead of 53 FPS.
     
    Last edited: May 29, 2015
  15. PrMinisterGR

    PrMinisterGR Ancient Guru

    Messages:
    7,005
    Likes Received:
    139
    GPU:
    Sapphire 7970 Quadrobake
    Is this in-game vsync, or from a 3rd party utility?
     

  16. sammarbella

    sammarbella Ancient Guru

    Messages:
    3,931
    Likes Received:
    178
    GPU:
    290X Lightning CFX (H2O)
    Thanks! :)

    Strange thing V-sync increase FPS and GPU usage on CFX!

    What about frametimes, flickering and stutter?

    Edit: PR you get me only by a few seconds :D
     
  17. PrMinisterGR

    PrMinisterGR Ancient Guru

    Messages:
    7,005
    Likes Received:
    139
    GPU:
    Sapphire 7970 Quadrobake
    If it is the in-game vsync, it is probably linked to some other parts of the engine, and that is why the behavior might be different/better with it on.
     
  18. sammarbella

    sammarbella Ancient Guru

    Messages:
    3,931
    Likes Received:
    178
    GPU:
    290X Lightning CFX (H2O)
    It could be as you said but the action to force sync frames at 60 FPS cause a strange behaviour if it's able to increase FPS from 53 to 60 and GPU usage from 88 to near max on a CFX setup when normally is the contrary. :3eyes:

    If it works this way it's a nice and strange find. :)
     
    Last edited: May 29, 2015
  19. RexOmnipotentus

    RexOmnipotentus Master Guru

    Messages:
    796
    Likes Received:
    4
    GPU:
    Vega 64
    It's the in-game Vsync. Actually it works just like the sdhdship profile. If you enable it, CrossFire somehow performance better.

    I also use Rivatuner Statistics Server to limit my FPS. This somehow seems to remove stutter and reduce frametime variance in some games.
     
    Last edited: May 29, 2015
  20. velocityx

    velocityx Master Guru

    Messages:
    310
    Likes Received:
    0
    GPU:
    EVGA 1080 Ti FE - EK FCB
    I had the same experience in GTA 5 where running the game without sync would give me around 53 fps but with vsync it would be higher usage and 60 fps.
     

Share This Page