The Witcher 3 Best Performance

Discussion in 'Videocards - AMD Radeon Drivers Section' started by Raziael, May 19, 2015.

  1. Raziael

    Raziael Member

    Messages:
    22
    Likes Received:
    1
    GPU:
    2x AMD Radeon HD6970
    Hi Everyone,
    I have tried The Witcher 3 on a PC with i5 2500k, 8gb of ram and 2x6970 AMD RADEON. Well, game runs crazy on my configuration. If you want to run it at the best way, disable HBAO+ And Nvidia Hairworks. Next, if you have crossfire, Add the witcher 3 .exe and use it with The Witcher 2 profile. For now, after an hour of gameplay, no sluttering or flickering.
     
  2. Nurmi

    Nurmi Member Guru

    Messages:
    139
    Likes Received:
    0
    GPU:
    R9 Fury Tri-X
    Zero usage at the second card, The Witcher 2 profile doesn't work.
     
  3. sammarbella

    sammarbella Ancient Guru

    Messages:
    3,931
    Likes Received:
    178
    GPU:
    290X Lightning CFX (H2O)
    Where is the TW3 crossfire profile?

    ?¿?
     
  4. Roceh

    Roceh New Member

    Messages:
    4
    Likes Received:
    0
    GPU:
    Gigabyte 7990
    AFR gets FPS boost but has various corruptions and flickering.

    Tried a few profiles and got not noticeable change from single card rendering.
     

  5. WarDocsRevenge

    WarDocsRevenge Master Guru

    Messages:
    294
    Likes Received:
    0
    GPU:
    Fury-x Crossfire
    40fps maxed out using hair works 60-88fps with hair works off it's a sad day for witcher fans because of nvidia broken works
     
  6. Alphy B

    Alphy B New Member

    Messages:
    9
    Likes Received:
    0
    GPU:
    980 TI Sli
    Sad day for us crossfire users, lets just hope amd is fast on releasing a good driver for this game
     
  7. Shadowxaero

    Shadowxaero Master Guru

    Messages:
    200
    Likes Received:
    21
    GPU:
    Radeon VII
    I get 50% scaling on any profile but AFR in which case i got 90ish % but flickering everywhere....I am a sad panda.


    AFR on high settings with a few ultra turned on gives me 60FPS but on any other profile I am getting 25-30
     
  8. Tronman

    Tronman Member Guru

    Messages:
    102
    Likes Received:
    0
    GPU:
    XFX 295x2
    Make sure borderless window is turned off in witcher 3 settings. It was on by default when I first started.

    Profit.
     
  9. Scout

    Scout Member Guru

    Messages:
    166
    Likes Received:
    0
    GPU:
    2 x GTX 980Ti
    it's fullscreen and not working with the witcher 2 profile, afr does but flickers, what drivers are you using ?
     
  10. Tronman

    Tronman Member Guru

    Messages:
    102
    Likes Received:
    0
    GPU:
    XFX 295x2
    I'm using 15.4 betas... also make sure "enable crossfire for games that don't have a profile" is checked in CCC.

    I added the witcher 3 .exe and just used the witcher 2 profile. Found AFR had a crazy amount of flickering and corrupt textures.
     

  11. Shadowxaero

    Shadowxaero Master Guru

    Messages:
    200
    Likes Received:
    21
    GPU:
    Radeon VII
    What kind of scaling are you getting?
     
  12. Nurmi

    Nurmi Member Guru

    Messages:
    139
    Likes Received:
    0
    GPU:
    R9 Fury Tri-X
    Right it was that, I'm getting now decent usage at the second card. But the Witcher 2 profile is causing the scenery to vibrate, and the fps doesn't really improve.

    Thanks anyways.
     
  13. Scout

    Scout Member Guru

    Messages:
    166
    Likes Received:
    0
    GPU:
    2 x GTX 980Ti
    with that enabled crossfire now works with both gpus at 60% but I have the same fps and still some flickering on distant mountains :\
     
  14. Tronman

    Tronman Member Guru

    Messages:
    102
    Likes Received:
    0
    GPU:
    XFX 295x2
    It doesn't look to be great scaling (I was playing with vsync on for the most part so didn't notice). From memory the AFR provided heaps better scaling but unplayable due to flickering etc...

    Looks like we really need a driver. Anyone getting really obvious stutters in pre-rendered cutscenes???
     
  15. ObscureangelPT

    ObscureangelPT Master Guru

    Messages:
    533
    Likes Received:
    61
    GPU:
    Gigabyte HD 7850 OC
    Yes.. Even sound desynchronize with the video.
    Same is happening on consoles. So maybe they will fix it.
     

  16. lorikano

    lorikano Master Guru

    Messages:
    323
    Likes Received:
    0
    GPU:
    2x Sapphire 7950@1150
    Simply said CF is not working no matter how you tweak it, it will not show satisfactory results. As usual we have to wait for both AMD and CDPR to sort this out.
     
  17. applejack

    applejack Master Guru

    Messages:
    589
    Likes Received:
    7
    GPU:
    GTX 1070 GAMING X
    you might want to try lowering the tessellation level via CCC, as HairWorks is heavily utilizing it, for obvious reasons.
    unfortunately the CCC 'trick' would affect all tessellated objects in scene (e.g. water) not only hair/fur, but i'd say its definitely worth a try.
    (I can't verify if it works or even worth it, but please do share results)
     
  18. WarDocsRevenge

    WarDocsRevenge Master Guru

    Messages:
    294
    Likes Received:
    0
    GPU:
    Fury-x Crossfire
  19. OmegaX

    OmegaX Member

    Messages:
    17
    Likes Received:
    0
    GPU:
    Geforce 980ti
    I can't find this checkbox you are talking about in CCC. Can you point us in the right direction?

    and like stated earlier, the only good profile is AFR friendly -- which essentially gives me 60fps but flicker and corruption everywhere. 30fps otherwise.
     
  20. XWolfGhost

    XWolfGhost Member

    Messages:
    22
    Likes Received:
    0
    GPU:
    MSI 290x 4GB x2
    It's only in windows 8.1. If that's what you're using then it should be directly under the Enable AMD CrossFireX option in Gaming>CrossFireX.
     

Share This Page