The Witcher 2 Flickering!

Discussion in 'Videocards - AMD Radeon Drivers Section' started by panoulhs007, May 17, 2011.

  1. nzweers

    nzweers Master Guru

    Messages:
    241
    Likes Received:
    0
    GPU:
    Inno3D 980Ti iChill Ultra
    Okay, I found that my flickering problem was caused by monitor color profile. I use LUT Manager to load a custom color profile.

    When I load a color profile, and alt-tab to the witcher 2, it flickers, when I alt-tab back, reset it, and alt-tab back ingame it's steady. It is possible that a monitor profile or windows setting that edits the colors is responsible too.
     
  2. panoulhs007

    panoulhs007 Guest

    I found the Problem for all Flickering problems!!

    When you right click on desktop and go personalize and then choose display you can calibrate your display throught windows.

    But in games windows only sync the brightness with the first GPU so one Gpu is Brighter than the other and that cause the Flickering!!!

    Reset all settings to default if you calibrated your display throught windows!
     
  3. =GGC=Phantomblu

    =GGC=Phantomblu Active Member

    Messages:
    60
    Likes Received:
    4
    GPU:
    2 x XR 5700XT SE 8G


    I think that this explanation is'the most'right also because' Crysis in crossfire with 2 HD 5970 had even enable v-sync is not synchronized and otherwise Crasci the operating system.
    We want to make this known to Catalyst Maker in Twitter?
     
  4. panoulhs007

    panoulhs007 Guest

    Can someone give this to catalyst maker because i dont have twitter account!?
     

  5. jesyjames02

    jesyjames02 New Member

    Messages:
    9
    Likes Received:
    0
    GPU:
    6950 Crossfire 2gb
    That actually worked for me. I have my display calibrated with an eye one. I unloaded the color profile and the flickering went away. Great find.

    My question is-- how do I get the color profile to be loaded on both gpus so that they are in synch?
     
  6. jesyjames02

    jesyjames02 New Member

    Messages:
    9
    Likes Received:
    0
    GPU:
    6950 Crossfire 2gb
    I may of figured it out. What I did was load the calibration profile with the monitor plugged in as it was.

    Then I unplugged it and plugged into the 2nd gpu and loaded the calibration profile again.

    Rebooted just to make sure the settings would stick and no more flickering.
     
    Last edited: May 18, 2011
  7. Scout

    Scout Member Guru

    Messages:
    166
    Likes Received:
    0
    GPU:
    2 x GTX 980Ti
    can you plug back into your main gpu and it works ?
     
  8. fullrespect

    fullrespect Member

    Messages:
    20
    Likes Received:
    0
    GPU:
    2 x Gigabyte HD6850 CFX
    You have to disable crossfire first , then you can make the calibration on every single card.

    Disable CFX - Calibrate - unplug - plug the 2nd card - calibrate - unplug - replug the 1st card - enable CFX.
     
    Last edited: May 19, 2011
  9. panoulhs007

    panoulhs007 Guest

    Now lets wait for the new Caps for better Crossfire Scaling!
     
  10. Skinner

    Skinner Master Guru

    Messages:
    442
    Likes Received:
    26
    GPU:
    Radeon VII 16 GB
    One thing to note, I use also the dirt2 and AFR-combo with RPro, and the flickering goes away once the game is a few times reloaded, and that wil happen a lot in this game :D (damn it's tough sometimes)
     

  11. Morhaus

    Morhaus Member

    Messages:
    11
    Likes Received:
    0
    GPU:
    XFX Radeon HD 5970 2Go
    Hello. I'm a not-so-happy owner of a HD5970, getting average performances one TW2. My problem is that I can play the Witcher 2 with high settings and no ubersampling, but I've got an average 20-30 FPS.

    With Dirt 2 profile and AFR it's more like 50-60 but my screen is flickering...

    So I tried all of the solutions listed here and it seems that no one is working for me, even with my screen settings set to default.
     
  12. WDeranged

    WDeranged Member

    Messages:
    25
    Likes Received:
    0
    GPU:
    MSI GTX 580 Twin Frozr II
    Gotta wait for a driver update, because that's how PC gaming rolls now :pc1::biggun:
     
  13. Lane

    Lane Ancient Guru

    Messages:
    6,361
    Likes Received:
    3
    GPU:
    2x HD7970 - EK Waterblock
    There's no CFX profile for Witcher2 right now , you have 2 solutions:

    1) disable CFX ..

    2) Use radeonPro, make a new profile and point the witcher2.exe who is located in game folder " Bin " ...

    - Set Crossfire profile to Dirt2, + MVPU mode AFR ...

    - in CCC or in profile be sure to let AF to "controlled by appliccations " .

    - Before launch the game: open RadeopPro > launch the game from the folder bin : Witcher2.exe ( you avoid the launcher, 1) it launch in 0,1sec, and it will apply the cfx profile ....

    I have no flickering ... and nearly constant 60fps ultra setting, no Ubersampling ..... ( 1920x1080 )

    If you have flickering, this could mean your CFX profile from RadeonPro have not been enabled, and so you have the standard cfx profile who make it bug .

    [​IMG]

    [​IMG]
     
    Last edited: May 23, 2011
  14. kn00tcn

    kn00tcn Ancient Guru

    Messages:
    1,604
    Likes Received:
    2
    GPU:
    570m / MSI 660 Gaming OC
    more like how multi gpu rolls always :nerd:

    very few games have needed single card driver updates (like borderlands with the missing textures bug on a specific cat, fixed in next one)
     
  15. paquiem

    paquiem New Member

    Messages:
    2
    Likes Received:
    0
    GPU:
    2xHD 6850
    I have this ICC problem as well and would like to use the ICC profiles but can't disable CF from CCC to load the profile to the second GPU. I've read somewhere that you can't disable CF any more with newer drivers. Is this correct?
     

  16. panoulhs007

    panoulhs007 Guest

    In 11.5 rc5 i can confrm that you can disable CF.
     
  17. paquiem

    paquiem New Member

    Messages:
    2
    Likes Received:
    0
    GPU:
    2xHD 6850
    Yea I unchecked the box and applied the changes but the check came back. After a reboot it was gone. Anyway got Witcher 2 working now with AFR and ICC profiles :nerd:
     
  18. AudiTuner

    AudiTuner Member Guru

    Messages:
    141
    Likes Received:
    0
    GPU:
    2x Gigabyte 7950
    As someone mentioned on another thread, there's an easy way to fix the Crysis 2 flickering. This is without any special CFX profile on RadeonPro or changing the MVPU mode from default.

    All you need to do is pause the game, turn the brightness up or down one notch and then unpause the game. The flickering should be gone and you can then turn the brightness back to your original setting.

    This works for me on Crysis 2 v1.4. Credits to whoever originally posted this quick fix.
     

Share This Page