The witcher 2 Enhanced Edition gtx 670/680 preformance

Discussion in 'Videocards - NVIDIA GeForce Drivers Section' started by RPGgamesplayer, Jul 9, 2012.

  1. RPGgamesplayer

    RPGgamesplayer Maha Guru

    Messages:
    1,475
    Likes Received:
    10
    GPU:
    RTX 2080 TI EVGA XC
    hey gurus just wanted to get a idea of what settings you guys are playing the witcher 2 at

    on my single gtx 670 media center build i have been testing the game on the fight with the kayran,

    ultra settings with uber disabled and dof settings disabled
    i have noticed no matter what setting i have even on low the game at at 1080p
    has alot of slowdown when the kayran drops its tentacles it seems like this happens when the gpu is rendering the smoke effects, for me it is a game breaking experience and wanted to know if anyone other then myself can confirm this issue, also with the 304.79 beta drivers there is a huge amount of stuttering vsync on or off its defiantly game breaking,
     
  2. Darren Hodgson

    Darren Hodgson Ancient Guru

    Messages:
    16,062
    Likes Received:
    578
    GPU:
    EVGA GTX 1080 Ti SC2
    The stuttering is a known issue with the 30x.xx drivers I believe (I seem to remember reading it on the NVIDIA forum) so it doesn't appear to be fixed in the latest beta. NVIDIA are aware of the issue and will presumably include a fix in a future driver.

    It is annoying though to see issues in games that were previously working fine with the drivers. Breaking things in games is the kind of thing I'd expect from AMD not NVIDIA.
     
  3. RPGgamesplayer

    RPGgamesplayer Maha Guru

    Messages:
    1,475
    Likes Received:
    10
    GPU:
    RTX 2080 TI EVGA XC
    yes its frustrating especially when you have spent a huge sum of money on a product that is not preforming as it should, it is very disappointing and somewhat depressing, i have undergone surgery and was looking forward to playing games on my recovery but i guess that is not going to happen for sometime to come, this issue i have read has been happening since release so its been more then enough time for nvidia to pull there fingers out and sort this driver issue out, but my main concern is it may not be as simple as we think and it could be a issue with there 28nm gpu (this right here would be impossible to fix and a error on there accord) well obviously unless they redesign and get all companys to rma which would cost them a fortune :bang:
     
  4. RPGgamesplayer

    RPGgamesplayer Maha Guru

    Messages:
    1,475
    Likes Received:
    10
    GPU:
    RTX 2080 TI EVGA XC
    Darren thanks for the insight, what drivers are working best for yourself?
     

  5. StrikeQ

    StrikeQ Master Guru

    Messages:
    956
    Likes Received:
    1
    GPU:
    1080 Waterforce 2139/5500
    With a GTX 680 I haven't noticed this issue on The Witcher 2, been getting ~80-100+ FPS with everything maxed (Uber off, get ~30-40 FPS with it on). Using 304.48 Drivers
     
  6. PowerK

    PowerK Master Guru

    Messages:
    505
    Likes Received:
    87
    GPU:
    2x RTX 3090 HOF
    For me, Witcher 2 was smooth with 301.42 WHQL. (Everything maxed including ubersampling enabled @ 2560x1600).

    The stuttering problem started with 304.48 BETA driver (and 304.79 BETA). The game started to stutter with those two BETAs. And ManuelG @ nVIDIA forum said, they could reproduce this issue. So by next driver release, it's going to get fixed hopefully.
     
  7. Brendruis

    Brendruis Maha Guru

    Messages:
    1,242
    Likes Received:
    1
    GPU:
    Reference GTX 680 SLI
    You won't notice with VSYNC off like you describe
     
  8. Darren Hodgson

    Darren Hodgson Ancient Guru

    Messages:
    16,062
    Likes Received:
    578
    GPU:
    EVGA GTX 1080 Ti SC2
    I haven't played the game properly in a while so I'm currently using the v304.79 drivers but I believe the game was running OK with the v301.42 drivers (verified by someone else earlier) when I briefly tried the tutorial post v3.2 update.
     
  9. Anvi

    Anvi Member Guru

    Messages:
    131
    Likes Received:
    1
    GPU:
    R9 390 8GB
    I have horrible frame skipping in Witcher2 EE. I have read about it on forums and I'm not completely certain whether it is driver or game issue..
     
  10. Xzibit

    Xzibit Banned

    Messages:
    4,383
    Likes Received:
    0
    GPU:
    7970 Windforce
    Interesting :nerd:
     

  11. cmdrdredd

    cmdrdredd Master Guru

    Messages:
    235
    Likes Received:
    0
    GPU:
    GTX 670 SLI @ 1240/6772
    Is the skipping going on when you are vsync off or just on?

    Going to be playing through this one soon as I finally bought it on steam.
     
  12. RPGgamesplayer

    RPGgamesplayer Maha Guru

    Messages:
    1,475
    Likes Received:
    10
    GPU:
    RTX 2080 TI EVGA XC
    skips with it on and off but if you use evga precision x or afterburner and limit the frames to 60 with vsync on or off it plays ok
     
  13. tyRant.594

    tyRant.594 Master Guru

    Messages:
    472
    Likes Received:
    0
    GPU:
    MSI R9 280x
    try the 300.83 driver, again ive tried every driver out this is the only one that gives me the least amount of stuttering. This is starting to get annoying with a 500dollar card.
     
  14. AlmondMan

    AlmondMan Master Guru

    Messages:
    829
    Likes Received:
    224
    GPU:
    5700 XT Red Devil
    Game stutters horribly on my 680 with 304.79 :( I just tried it today after finishing Arkham City, and I'd been looking forward to it for so long. But it was unplayable with how running animations looked jerky and skippy :| just majorly distracting. It ran better on my 5870 :| and I postponed playing it till I could upgrade... Now what? Wait for a hopeful driver fix? Roll back and suffer in other games, as I always play a handful of games, BF3 being one of them.

    I have vsync off...
     
  15. dnottis

    dnottis Master Guru

    Messages:
    695
    Likes Received:
    0
    GPU:
    EVGA SSC 970 GTX 4GB
    Arkham city was choppy as hell at times with the 680 too. That game could've been great, they screwed the pooch performance wise with the latest patch.
     

  16. AlmondMan

    AlmondMan Master Guru

    Messages:
    829
    Likes Received:
    224
    GPU:
    5700 XT Red Devil
    During gameplay it was fine, but cutscenes tended to drop frames... but nohing like TW2.
     
  17. DrunkenDonkey

    DrunkenDonkey Master Guru

    Messages:
    208
    Likes Received:
    4
    GPU:
    2xPC 290 PCS+
    I had the witcher shuttering on 470 using 304.79, what fixed it for me is from nvidia control panel forcing vsync to adaptive, single monitor performance mode and power management put on max power. May give it a go.
     
  18. Netherwind

    Netherwind Ancient Guru

    Messages:
    7,831
    Likes Received:
    1,661
    GPU:
    MSI 3080 Gaming X
    Guys, I had the same problems on my GTX680 and after having done some research I tried disabling Cinematic DOF and something more which removed slowdowns during cinematics. Overall gameplay though was ok (Vsync enabled @ Ultra 1920x1200) and was around 55-60fps which is not perfect but playable.
     

Share This Page