The Left 4 Dead 2 Thread

Discussion in 'Games, Gaming & Game-demos' started by [ R ], Nov 17, 2009.

  1. Veteran

    Veteran Ancient Guru

    Messages:
    12,103
    Likes Received:
    20
    GPU:
    2xTitan XM@1590Mhz-CH20
    Yes this game is still being played by loadsa people.
     
  2. chris

    chris Ancient Guru

    Messages:
    1,573
    Likes Received:
    0
    GPU:
    GTX460
    great,installing now.
    add me on steam if u guys want:)
     
  3. Mkilbride

    Mkilbride Banned

    Messages:
    8,058
    Likes Received:
    2
    GPU:
    EVGA GTX470 1.2GB
    http://store.steampowered.com/stats/

    14,846 people are playing Left 4 Dead 2 right now. Considering the average game is 4 people, that's over 3,500 matches you could play in. PLENTY.
     
  4. Cronik

    Cronik Maha Guru

    Messages:
    1,233
    Likes Received:
    90
    GPU:
    Nvidia GTX 1080
    why is blops and warfail still on the top ten?
     

  5. Mkilbride

    Mkilbride Banned

    Messages:
    8,058
    Likes Received:
    2
    GPU:
    EVGA GTX470 1.2GB
    Dunno, but if you follow the stats like I do, you'd know that Warfail has lost 9/10th's of it's playerbase and BLops has lost more than half.
     
  6. Veteran

    Veteran Ancient Guru

    Messages:
    12,103
    Likes Received:
    20
    GPU:
    2xTitan XM@1590Mhz-CH20
    Got expert and realism achievements on this within 4 weeks of playing it with a good co-op team from l4d1,havent played it since,although i should as its a great game even now,l4d1 is harder though cause of no melee,Easier to finish on expert:)
     
  7. Digika

    Digika Member Guru

    Messages:
    125
    Likes Received:
    1
    GPU:
    GTX 670
    N-n-necro post!

    Does anyone know how any tricks how to make the game work on non-standard refresh rate in exclusive fullscreen mode on Windows 7? I tried the -refresh and -freq, none of them works. I DO NOT WANT to use Borderless because it causes massive stutter here.

    My desktop refresh rate is 80HZ but game always starts in 60 if I set it to exclusive fullscreen (regardless of vsync setting).
     

Share This Page