**The HD5770 Thread**

Discussion in 'Videocards - AMD Radeon' started by keenan, Nov 7, 2009.

  1. DSK

    DSK Banned

    Messages:
    17,917
    Likes Received:
    1
    GPU:
    HD5770/BenQ G2220HD
    What res do you play at?
     
  2. Donkeylips

    Donkeylips Member

    Messages:
    25
    Likes Received:
    0
    GPU:
    2x POWERCOLOR pcs+ 5770
    tried 1024x768, 1280x1024 , 1600x1200 and 1920x1080 and all had slightly lower FPS (due to occasional hiccups) than I was getting with the 5770 in just the PCI-e 2.0 x4 slot.
     
  3. ScoobyDooby

    ScoobyDooby Ancient Guru

    Messages:
    7,114
    Likes Received:
    86
    GPU:
    1080Ti & Acer X34
    Guys my card has been performing well in game but I find I have a weird issue that I did not have with my 4890. When my system turns off the monitor, all i would normally do is wiggle the mouse and it would open back up, but with the 5770 I find that it does not do this.. it stays off and I have to literally turn off my monitor and then turn it back on and THEN wiggle the mouse for it to turn back on.. wtf??
     
  4. Tristor

    Tristor New Member

    Messages:
    9
    Likes Received:
    0
    GPU:
    MSI HD5770 @ 1000/1400
    Not sure about your particular issue, but suspend/resume is a generally problem-prone power management feature on every OS with every hardware setup. I suggest disabling it. The difference in power usage when your system is at idle vs suspended is negligible, and it will eliminate a lot of headaches. Hibernate is even more error prone, disable it as well.

    The only power management features that aren't destined to cause problems at some point are those which deal with reduced power modes for wireless cards and shutting off hard drives when the system has been idle for a time (although you have to disable this if you use SSDs).
     

  5. ScoobyDooby

    ScoobyDooby Ancient Guru

    Messages:
    7,114
    Likes Received:
    86
    GPU:
    1080Ti & Acer X34
    ^ Had a feeling that it was related to what you were mentioning.. just suspicious that it would happen now with the 5770 as I never had any issue with the 4890. Weird!
     
  6. Joebear55

    Joebear55 Active Member

    Messages:
    55
    Likes Received:
    0
    GPU:
    Xfire:Asus 5770+XFX 5770
    Yeah I had that problem with every single setup I have ever had, suspend/resume or hibernate they only cause problems. As the man said disable them.
     
  7. FULMTL

    FULMTL Ancient Guru

    Messages:
    6,704
    Likes Received:
    2
    GPU:
    AOC 27"
    BadCompany2 is a CPU dependant game. OC the CPU 0.5Ghz+ for more performance. You could have tested out your video card overclocked and not overclocked, there is almost no difference in that game.
    Have you tried to unlock the 4th core on the X3 435? I got 2 of them to unlock before, but only one of them worked 100%. There is a big performance jump when unlocked of course.
     
  8. Sever

    Sever Ancient Guru

    Messages:
    4,826
    Likes Received:
    0
    GPU:
    Galaxy 3GB 660TI
    common troubleshooting tips,

    go to CCC, check that crossfire is enabled.

    ensure that catalyst ai is not turned off, and set it to either standard or advanced (probably standard would be fine with your specs).

    make sure you are running the game fullscreen, as crossfire will only work in fullscreen mode (kombuster/furmark excepted).

    the issue with that link posted previously is that it stated that there was only 5% performance loss when going from 16x to 4x, but youre forgetting, thats running a single card only. with crossfire, you'll get synchronisation issues and some more notable microstuttering with both cards running at different speeds unless you turn on vsync.

    your cpu is probably holding the crossfire setup back a fair bit imo. either try unlocking the fourth core, or oc it into the mid 3ghz range (for best results).
     
  9. Olorin

    Olorin Maha Guru

    Messages:
    1,079
    Likes Received:
    5
    GPU:
    MSI Armour OC GTX1060 6GB
    I experienced something weird with my 5770 card. I posted in another thread of mine but since this is the 5770 thread, it would make sense to share it with you all.

    Dead Space. The game has been a problem for my PC for a while. It usually takes around 2 minutes to load levels and the game used to have a few pauses here or there while playing. The frame rate never used to dip below 25 fps. But it never really exceeded 25 fps either.

    However, I disabled v-sync. I can't explain it, but loading now takes seconds. If I load a level, it takes about 4 seconds to load ! As soon as I unchecked the v-sync, everything was super responsive. Getting around the menu was super fast.

    The game itself ? I've more than doubled my frame rates. Everything is now super fast. Has anyone experienced this ? Or am I the only one ? I swear, I'm not making this up. If I check v-sync, and I did this several times, the game takes minutes to load levels, the menu speed is sluggish and the thing is, I assumed it was supposed to be that way.

    I can't believe I never experienced the game at this kind of speed, because I've never played a game at 60fps or so. It's fantastic.

    Regards,
     
  10. GenClaymore

    GenClaymore Ancient Guru

    Messages:
    6,072
    Likes Received:
    52
    GPU:
    3070 TI XC Ultra
    its the game, Dead space Vsync makes the game lock at 30fps and adds mouse smoothing. The Devs did that on purpose for some bs reason. IT was know that you disable it within game,then outside of game you Force it thru a tool like D3D override that comes with rivaturner if you wanted vsync as well Triple buffering.
     

  11. Olorin

    Olorin Maha Guru

    Messages:
    1,079
    Likes Received:
    5
    GPU:
    MSI Armour OC GTX1060 6GB
    Yes, but how does that explain the load times ? Why does the game take 4-5 seconds to load with v-sync disabled when it takes +- 2 minutes to load otherwise ?

    I knew that disabling v-sync would give me some kind of fps improvement but not nearly what I expected.

    Regards,
     
  12. Olorin

    Olorin Maha Guru

    Messages:
    1,079
    Likes Received:
    5
    GPU:
    MSI Armour OC GTX1060 6GB
    As an update, after I reinstalled my drivers, the loading speed has improved considerably but it still takes almost a minute to load a level in Dead Space (with v-sync enabled).

    With v-sync disabled, it's a different story. I've taken a video on youtube. It's still getting processed but once it does, I'll post a link.

    Regards,
     
  13. Olorin

    Olorin Maha Guru

    Messages:
    1,079
    Likes Received:
    5
    GPU:
    MSI Armour OC GTX1060 6GB
    A bigger problem (besides Dead Space which I've since corrected) is some games have experienced major slow downs and pauses and I never could understand why that was.

    It wasn't a graphical setting because even the lowest settings gave the same pausing glitches.

    Mass Effect 2, when it first came out, I was complaining why the game was pausing left, right and center. There were 3-4 second pauses while playing. Even the loading screen itself, it never flowed smoothly, there were pauses even then !

    But I uninstalled my drivers, reinstalled them and guess what ? No pauses whatsoever ! The game even loads quicker. The problem I'm experiencing is that if I shut my PC down, and play the game again, it's back to the same problem. Pauses galore.

    This concerns me. Prototype does the same thing. Major pauses in the game. Reinstall drivers and it's smooth as silk, no pauses. But if I shut down or restart my PC, the issues I experienced come back.

    Some have told me to install the hot fix drivers ? I'm not sure what they are and how they would help me ? Heck, I don't know if anyone else has experienced what I am experiencing.

    All I know is that it's really frustrating that I couldn't enjoy a game like ME2 because of this.

    Regards,
     
    Last edited: Mar 20, 2010
  14. Olorin

    Olorin Maha Guru

    Messages:
    1,079
    Likes Received:
    5
    GPU:
    MSI Armour OC GTX1060 6GB
    Here is my video :

    http://www.youtube.com/user/Brick100?feature=mhw5

    Apologies for the REALLY crappy picture quality. I took this in a hurry and I didn't have space left. Just check out the load times. I just wish I could show you how much of an improvement it made to frame rates as the video makes it seem like its 10-15 fps when it's anything but.

    Regards,
     
  15. IPlayNaked

    IPlayNaked Banned

    Messages:
    6,559
    Likes Received:
    0
    GPU:
    XFire 7950 1200/1850
    You using an old version of MSI afterburner?

    I don't think the drivers are too blame. More likely, reinstalling the drivers breaks the background program that is causing the problem.

    Old versions of MSI Afterburner did this. Close all the programs that access sensor data/GPU data and try again.
     

  16. Olorin

    Olorin Maha Guru

    Messages:
    1,079
    Likes Received:
    5
    GPU:
    MSI Armour OC GTX1060 6GB
    MSI afterburner ? Forgive my ignorance, what is that ? How do I disable 'sensor data/gpu ? Not sure.

    Regards,
     
  17. Olorin

    Olorin Maha Guru

    Messages:
    1,079
    Likes Received:
    5
    GPU:
    MSI Armour OC GTX1060 6GB
    I don't even know if I have MSI afterburner. LOL

    Regards,
     
  18. IPlayNaked

    IPlayNaked Banned

    Messages:
    6,559
    Likes Received:
    0
    GPU:
    XFire 7950 1200/1850
    Just disable as many background programs as you can and see if the problem persists. I think it is likely that your problem is a program in the background and not the video card, or drivers.
     
  19. Olorin

    Olorin Maha Guru

    Messages:
    1,079
    Likes Received:
    5
    GPU:
    MSI Armour OC GTX1060 6GB
    I'll do a test. I'll restart my PC, try Mass Effect 2 since that game is affected the most. I'll make sure no background programs are running.

    Then I'll report back.

    Regards,
     
  20. ScoobyDooby

    ScoobyDooby Ancient Guru

    Messages:
    7,114
    Likes Received:
    86
    GPU:
    1080Ti & Acer X34
    I dunno how me2 is failing for you.. I have had literally not a single issue with me2 on my 5770 using 10.2..
    all settings high vsync enabled 1900x1200
     

Share This Page