The application failed to initialize properly (0xc0150002)

Discussion in 'ATI Tray Tools Public Beta Section' started by Stereotypical, Feb 17, 2010.

  1. Stereotypical

    Stereotypical New Member

    Messages:
    5
    Likes Received:
    0
    GPU:
    ASUS/ATIRadeonHD4870/512M
    Greetings, this is my first post.
    I'm experiancing a problem while trying to launch the latest beta of ATI Tray Tools. When I double click atitray.exe I get the following error message:

    Code:
    [I]The application failed to initialize properly (0xc0150002). Click OK to terminate the application.[/I]
    I 've googled a lot but I can't find any solution to this problem. I 've even tried Dependency Walker but it didn't help at all even by manually downloading the "missing" DLLs and putting them to the main ATI Tray Tools installation directory.
    I tried some older versions of ATI Tray Tools but I can't seem to get it to run properly no matter what I do.

    Is there anything else that I can try? Any helpful information would be appreciated.
     
  2. WhiteLightning

    WhiteLightning Don Illuminati Staff Member

    Messages:
    28,727
    Likes Received:
    1,582
    GPU:
    GTX1070 iChillx4
    have you tried to install/update Visual C++ ??
    vcredist.exe is the file you are looking for.
     
  3. Stereotypical

    Stereotypical New Member

    Messages:
    5
    Likes Received:
    0
    GPU:
    ASUS/ATIRadeonHD4870/512M
    Hello and thank you for your reply.
    Yes, I 've tried installing and repairing the following updates by this order:

    1. Microsoft Visual C++ 2005 Redistributable Package (x86)
    2. Microsoft Visual C++ 2008 Redistributable Package (x86)
    3. Microsoft Visual C++ 2005 SP1 Redistributable Package (x86)
    4. Microsoft Visual C++ 2008 SP1 Redistributable Package (x86)

    Unfortunately none of those helped.
    I never experianced a single problem with Visual C++. I am using Greek language OS by the way. Maybe this can be the problem? I can't think of something else! Any help will still be appreciated!
     
  4. Ray Adams

    Ray Adams Ancient Guru

    Messages:
    4,942
    Likes Received:
    0
    GPU:
    ATI HD6950
    All you need are these:
    1. Catalyst driver
    2. VC++2008 Redistributable
    3. Last DirectX update
     

  5. Stereotypical

    Stereotypical New Member

    Messages:
    5
    Likes Received:
    0
    GPU:
    ASUS/ATIRadeonHD4870/512M
    Hello! I guess you developed this program! Thank you for your reply and this program too!
    So far I 've tried everything that you suggested:

    1. Downloaded & successfully installed the Latest ATI Catalyst 10.2 Driver Suite.
    2. I re-downloaded, unistalled, re-installed and repaired for the 3rd time
    the VC++2008 Redistributable with and without SP1 update.
    3. I 've downloaded the Latest Version of DirectX, and tried to install but according to it:
    Code:
    DirectX setup has determined that a newer or equivalent version of DirectX has been installed already. No installation is necessary.
    Again, none of those suggestions solved my problem! It seems that im unable to run this program properly :(. Maybe there 's some conflict with my registry?
    Please suggest more things that I can try in order to make it run properly!!!
    Thanks in advance..

    P.S.: Once, I thought it was my anti-virus that was preventing me from successfully & properly installing & running the program. But even when I turned it off, I saw no change.
     
  6. Ray Adams

    Ray Adams Ancient Guru

    Messages:
    4,942
    Likes Received:
    0
    GPU:
    ATI HD6950
    That looks very strange for me. Need more information about error
     
  7. Stereotypical

    Stereotypical New Member

    Messages:
    5
    Likes Received:
    0
    GPU:
    ASUS/ATIRadeonHD4870/512M
    Hey, just tell me what information you need and I will post it here! Please, I really need ATI Tray Tools!
    Thanks in advance again..

    P.S.: I 've attached a HiJackThis log in case you 're interested. Please tell what else I can do.
     
  8. Stereotypical

    Stereotypical New Member

    Messages:
    5
    Likes Received:
    0
    GPU:
    ASUS/ATIRadeonHD4870/512M
    Hey all and sorry for the double post. I 've managed to solve this problem and successfully/properly run this application. What I did was to uninstall ALL Visual C++ Redistributables (there were a lot of different versions installed on my computer). And now the program runs without problems and without VC++.
    Strange, huh?
    Anyways, thanks for the help! I hope this helped anyone else that had the same problem.
     
  9. Ray Adams

    Ray Adams Ancient Guru

    Messages:
    4,942
    Likes Received:
    0
    GPU:
    ATI HD6950
    So that was VC++ version conflicts :)
     

Share This Page