Thank you AMD for great Software Quality & Support

Discussion in 'Videocards - AMD Radeon Drivers Section' started by Yezirael, Mar 10, 2015.

  1. FunkyMike

    FunkyMike Master Guru

    Messages:
    539
    Likes Received:
    0
    GPU:
    ATI 6850m /Intel HD3000

    You have to watch out for some users this patch can cause a blackscreen + mouse on boot.

    As the description says:

    "This issue occurs because the AMD driver does not support Runtime Power Management (RTPM), but the Intel driver does support RTPM."

    However to overcome this issue the MS patch mods the Intel driver.

    In case you do receive the above mentioned bug then you can simply remove the patch or reinstall the Intel driver.
     
  2. shadow_craft

    shadow_craft Member Guru

    Messages:
    189
    Likes Received:
    0
    GPU:
    ASUS StiX OC 1070
    perhaps a solution is to disable the iGPU on the intel processors, I have never had this sleep/wake issue with my video card or monitor, but I have my iGPU disabled with no drivers installed for it
     
  3. FunkyMike

    FunkyMike Master Guru

    Messages:
    539
    Likes Received:
    0
    GPU:
    ATI 6850m /Intel HD3000
    This isn't really about the Intel GPU. More about what the AMD driver lacks in terms of features and support.

    Depending on your setup you cannot simply disable the iGPU since the AMD dGPU routes through the iGPU to the monitor.

    Older laptops have mux chips where you really do not need the iGPU. In those cases turning it off is feasible.
     
  4. Espionage724

    Espionage724 Guest

    With most dual-graphics laptops, there is no presence of a hardware mux. The primary (built-in) screen on such laptops is driven by the iGPU (Intel's chip on I+A setups; AMD's chip on the APU on A+A), and the dGPU passes through it since it can't push things to displays/outputs on it's own.

    (that's the general gist of it anyway)
     

  5. Passus

    Passus Ancient Guru

    Messages:
    1,928
    Likes Received:
    597
    GPU:
    3060Ti GamingZ Trio
    you will probably find its your mobo causing this i had same issue with same board but with an nvidia video card
     
  6. gx-x

    gx-x Ancient Guru

    Messages:
    1,507
    Likes Received:
    156
    GPU:
    1070Ti Phoenix
    changing the GPU to nVidia also solves the problem. I mean really, disabling perfectly good features of other hardware to solve the issue with AMD power play (or whatever it is called these days)?

    I have the same issue as OP does and yes, I am using omega drivers. It is less frequent with omegas but it still there. I resolve it by putting PC in sleep mode (S3 I presume) and waking it up. Maybe you should suggest this instead of disabling features on non-AMD hardware. How would you feel if I asked Dell support how to resolve the issue and they suggested I disable AMD card and use intel HD graphics instead?

    --------------

    That's just bananas. nVidia bought 3dfx 15 years ago.
     
    Last edited: Mar 19, 2015
  7. snip3r_3

    snip3r_3 Ancient Guru

    Messages:
    2,983
    Likes Received:
    0
    GPU:
    1070
    If any of you can try, I found that using the mini DP ports on my 7950s have never resulted in a wake up fail. Using DVI and HDMI would cause it VERY often. Both 7950s have had the black screen issues until I swapped my monitors to use DP. One is a XFX and the other is a MSI.
     
  8. gx-x

    gx-x Ancient Guru

    Messages:
    1,507
    Likes Received:
    156
    GPU:
    1070Ti Phoenix
    well I am using Dell p2314H since it got out and DP is pretty much the only connection it has so I am on DP for a long time and problem is still present.
     
  9. progrox

    progrox Member

    Messages:
    39
    Likes Received:
    0
    GPU:
    Sapphire R9 270X 2GB OC
    Doubt it very much. I had an old GTX 275 until ~5 months ago and never ever an issue with waking the display. This was a well known pre-14.12 driver issue that's simply not gone away yet.
     
  10. Deathchild

    Deathchild Ancient Guru

    Messages:
    3,970
    Likes Received:
    2
    GPU:
    -
    Just turn off the monitor sleep thing. Solves your problem. lol.

    The same happened to me a few times which was really annoying but I just turned it off, issue resolved.
     

  11. Espionage724

    Espionage724 Guest

    This doesn't resolve the issue though; it's simply avoids it.

    Try using multiple monitors, and then try having the startup logo sequence take 7-10 seconds on monitor power on, and you'll realize how annoying your "solution" is :p

    So far I haven't seen this black screen issue happen yet (haven't seen it on Win7 with 15.4 nor 10 (10056 with WDDM 2.0 3/27 and 4/1 drivers), but I only used them for about a day or two; using Win8.1 with 15.4 for a few days now without problem), but now that I've said this, I'm sure it'll happen now :p

    In the event it doesn't though, then a driver update probably between 14.12 and now or a OS update would have fixed it (didn't change my hardware nor settings).
     
  12. Deathchild

    Deathchild Ancient Guru

    Messages:
    3,970
    Likes Received:
    2
    GPU:
    -
    Espionage, I'm not sure we're talking about the same thing? We're talking about the thing that turns off the monitor after a while right, power saving? To save power. After that you move your mouse nothing comes up, no screen, blackness. That's the thing we're talking about right?

    So to fix it you just turn off the power saving thing, that's it.. nothing else. The monitors will be constantly on after that. Unless you actually turn them off physically by the button.
     
  13. Espionage724

    Espionage724 Guest

    Yeah that's what I was talking about.

    In order to "avoid" the sleep/wake bug, you can disable monitor suspending. This either means you'll run your monitors all day/night, or manually power them on/off.

    Manually powering monitors on/off can be annoying though (depends on the monitor(s); particularly with screens that have long startup times due to all the logos and stuff they show on power on, and then multiplied with multiple monitors), but then again, I guess it's better than to have your computer lock-up.

    Disabling monitor suspend doesn't fix the sleep bug; it just puts you in a position to not experience it.
     
  14. PrMinisterGR

    PrMinisterGR Ancient Guru

    Messages:
    7,889
    Likes Received:
    755
    GPU:
    Inno3D RTX 3090
    Did you get it again after the software updates and the new drivers?
     
  15. Deathchild

    Deathchild Ancient Guru

    Messages:
    3,970
    Likes Received:
    2
    GPU:
    -
    Yeah you're right, but it's a fix nonetheless. I mean what do you do if anything else cannot be done.. Just gotta wait till AMD fixes it, nothing else there. :D
     

  16. Espionage724

    Espionage724 Guest

    Na (should have clarified that in that post); I haven't seen it happen on a 3-day old Win8.1 install with 15.4 so far.

    Not really sure how long it took me to see it happen before.
     
  17. Espionage724

    Espionage724 Guest

    And it happened. Tried waking my computer up a little bit ago and only one monitor (out of 3) woke up, did the TDR recovery thing (where it blanks and turns back on) while only displaying a black background and a mouse cursor, and eventually the system hung.

    15.4 on Windows 8.1.
     
  18. PrMinisterGR

    PrMinisterGR Ancient Guru

    Messages:
    7,889
    Likes Received:
    755
    GPU:
    Inno3D RTX 3090
    Could you post a CPU-Z screen and send me a vbios dump?
     
  19. Espionage724

    Espionage724 Guest

    [​IMG]
    VBIOS (extracted with GPU-Z)
     
  20. PrMinisterGR

    PrMinisterGR Ancient Guru

    Messages:
    7,889
    Likes Received:
    755
    GPU:
    Inno3D RTX 3090
    I misstyped, I meant GPU-Z screen. :)
     

Share This Page