SWTOR (Star Wars MMO) -- And Crossfire? Any ideas on how to make Xfire work?

Discussion in 'Videocards - AMD Radeon Drivers Section' started by Logikos, Dec 22, 2011.

  1. Logikos

    Logikos New Member

    Messages:
    7
    Likes Received:
    0
    GPU:
    Asus GTX 780
    Hey guys,

    The game, MMO, SWTOR (Star Wars The Old Republic) went live with 'online' the 13th, it went official in stores the 20th. 3Million+ have purchased it, so it's pretty big. Which to me, would mean that AMD would want to have their Xfire working on a new game?

    At any rate we have a fail here, and Crossfire is not recognized and hence doesn't work in this game.

    I have dual 5850 HD's,.. and all I want for Xmas is my cards to work. I mean they are 2 years old, come on.. it's old tech, this shouldn't be an issue .. I wouldn't have imagined 2 years ago.

    But QQ, right?

    On to more important discussion.

    Any of your Guru's have any ideas (hard or simple) to make this work?

    There was a program a single user made to force Xfire on any game before.. but he , to my knowledge, is gone.. as his website is even gone and the post is old.

    I tried to program , but it doesn't have any way (that I see) to make it work with a new game that isn't IN the program right now.

    I've gotten the 12.1 Preview drivers.. which have an option that is *supposed* to make Xfire be forced.

    Doesn't work for me, in this particular, game.

    Side note: Nvidia SLI Does work for this game. Shrug?

    I don't know the specifics of Xfire and how it relates to EACH game- but I would have to think the tech itself should be more native to the hardware and not the software. To have to program each game with any 'depth' to work with Xfire doesn't seem like the way the Dual GPU's would work.

    So that being the case, it seems some 'work around' , a jerry rig , type of way would be 'ok' until AMD got their drivers inline to work without outside help.

    The game plays 'ok' with one card, but I run 120Hz monitors.. and as such, dual cards will run this at 120fps or better all day long at 1650x1080 reso (that I use).

    Help? If you don't play the game, it really doesn't matter :) _ it's just getting Xfire to work on a game not already supported and thus working automatically.

    I fixed issues myself for others with these cards by reprogramming the bios's etc.. this is out of my league because I don't know where to start. Even if you only knew what was involved maybe I could work on making it work myself.

    Thanks for your time,
     
  2. SpajdrEX

    SpajdrEX AMD Vanguard

    Messages:
    2,200
    Likes Received:
    521
    GPU:
    Sapphire RX5700XT
    Well .. Xfire or Trifire works for me. I also been in few betas of SWTOR and it works even now with retail version.
    Only problem that i had was screwed shadows in one of the beta tests, they were flickering, when you used more then one GPU.
    Try to create game profile and set Crossfire Settings to Alternate Frame Rendering.
     
  3. Freeaked1

    Freeaked1 New Member

    Messages:
    8
    Likes Received:
    0
    GPU:
    Ati HD5770 in crossfire.
    Xfire works fine of my 5770's
     
  4. Snarl

    Snarl Member Guru

    Messages:
    115
    Likes Received:
    0
    GPU:
    GTX 1080 Ti 11GB
    Cross-Fire works fine on my 6970's and 12.1 Drivers.
     

  5. Heinrich

    Heinrich Member

    Messages:
    26
    Likes Received:
    0
    me also
     
  6. bishi

    bishi Master Guru

    Messages:
    557
    Likes Received:
    8
    GPU:
    GTX 1080 SLI
    My 6990 also refuses to run this game in xfire, 12.1
     
  7. Rotary8

    Rotary8 Master Guru

    Messages:
    226
    Likes Received:
    0
    GPU:
    SLI 680
    fine seems ok, but im sure they can get more out of it if amd took 10 min looking at it
     
  8. Metz

    Metz Master Guru

    Messages:
    229
    Likes Received:
    0
    GPU:
    2x 5850 TOP CF
    I'm using AFR+AFR-Friendly profile with 11.11c and it works great.
     
  9. Matthew Simis

    Matthew Simis Active Member

    Messages:
    73
    Likes Received:
    0
    GPU:
    HD7970 + GT240 Physx
    Yeah it doesnt run well in Crossfire atm. I found that forcing Wow's profile worked better than AFR with the 12.1 drivers. Really bad stuttering with Vsync on and still not great with it off no matter.

    This is on a HD5970.
     
  10. Steppis

    Steppis Master Guru

    Messages:
    842
    Likes Received:
    0
    GPU:
    2xXFX 5870 "XT" Crossfire
    no go for my two 5870 12.1
     

  11. Matthew Simis

    Matthew Simis Active Member

    Messages:
    73
    Likes Received:
    0
    GPU:
    HD7970 + GT240 Physx
    Just to update this, Im now playing with Cat 12.1 and the Age of Conan profile. No artifacts, not stuttering, map works and 75-81fps consistently at 2x AA and 6080x1200 . Massively better. Set in CCC not RadeonPro btw.

    Try it!
     
  12. Joaoo

    Joaoo Active Member

    Messages:
    76
    Likes Received:
    0
    GPU:
    480RX
    How did you use that CAP? Can't find any thing about it in CCP

    Edit; Found it :) THNX! Servers are on maintenance now, il report tonight!
     
    Last edited: Dec 27, 2011
  13. Arsaneus

    Arsaneus New Member

    Messages:
    6
    Likes Received:
    0
    GPU:
    AMD 5870 CF 1GB
    Can you explain me how you did it? I really can't find it.

    EDIT: Well ok I found where I can select the AoC profile but it does not save the profiles after I select swtor.exe - Any solution to that?
     
    Last edited: Dec 27, 2011
  14. streakpt

    streakpt Master Guru

    Messages:
    277
    Likes Received:
    0
    GPU:
    Sapphire 290 Crossfire
    That sucks on mine...
     
  15. Arsaneus

    Arsaneus New Member

    Messages:
    6
    Likes Received:
    0
    GPU:
    AMD 5870 CF 1GB
    Yeah doesn't work well either. Both GPUs run with around 30% load and performance goes down to 10fps sometimes in fleet, in ship and in battlegrounds.

    :wanker:
     

  16. Matthew Simis

    Matthew Simis Active Member

    Messages:
    73
    Likes Received:
    0
    GPU:
    HD7970 + GT240 Physx
    Press Apply then scroll up to where it says <<New Application>> and change it to swtor.exe (you will have to browse and select the EXE the first time). You have to press Save and get the overwrite prompt everytime, Apply doesnt Save.

    Have you turned Shadows to Low? Shadows at the moment look crap and absolutely cripple performance, Crossfire or not. I can have everything else on High and 2x AA, 6080x1200 and get 85-90% GPU load (Afterburner with Logitech LCD on keyboard). Memory load is 1950mb'ish (divide by 2 of course on Crossfire).
     
  17. Arsaneus

    Arsaneus New Member

    Messages:
    6
    Likes Received:
    0
    GPU:
    AMD 5870 CF 1GB
    I set all the options to low/off today but didn't get better performance at all.
     
  18. Joaoo

    Joaoo Active Member

    Messages:
    76
    Likes Received:
    0
    GPU:
    480RX
    Tried the Age of Conan thing, micro stuttering :(

    Its a shame it isnt working yet, if i dont ALT-TAB my GPU's run like crazy and heavy lagg.
    If i ALT-TAB once i have normal FPS but stuttering sometimes.

    I think we would just have to wait for a CAP release.
    I tried sending a tweet to the Catalyst creator but he isnt responding; must be on vacation -.-

    x
     
  19. ldwar

    ldwar Member Guru

    Messages:
    100
    Likes Received:
    0
    GPU:
    Sapp HD390x crossfire
    +1 with my quadfire
     
  20. Miken420

    Miken420 Member Guru

    Messages:
    135
    Likes Received:
    0
    GPU:
    NVIDIA GTX 1080 Ti FE
    Although when I enable CFX my GPU-Z shows both cards at over 80% usage almost always, my performance is still better with CFX off. This is on HD5770s too which in single card config aren't very powerful at all lol.

    Hopefully a CAP will come out soon to get multi-gpu working properly.
     

Share This Page