1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Stuttering on PC connected TV (419.35)

Discussion in 'Videocards - NVIDIA GeForce Drivers Section' started by Mbi2011, Mar 16, 2019.

  1. Mbi2011

    Mbi2011 Member

    Messages:
    38
    Likes Received:
    0
    GPU:
    Sapphire HD 7970 OC
    I have stuttering on PC connected to TV, when monitor is also connected to PC at the same time, but it in standby.

    TV - LG SK9500 connected to 1080ti via some HDMI 2.0 rated cable (CC-HDMI4F-6)
    +
    PC Monitor - Philips 247elh connected to 1080ti via some HDMI 1.4(?) noname cable

    Stuttering occurs in games like BF5 and Forza Horizon 4 (didn't test anything else). FH4 benchmark shows ~80 skipped frames in one run and i have stuttering (at equal intervals) ingame. In BF5 i also have stuttering (at equal intervals). And sometimes randomly TV lost video/audio signal for 1-2 seconds.

    Here is a sample of that stutters (on TV):


    But then i turn off the PC monitor by button (not even by power plug) - stuttering is gone and all is smooth on the TV. What it can be, how do you think guys?
     
    Last edited: Mar 16, 2019
  2. Chastity

    Chastity Ancient Guru

    Messages:
    1,602
    Likes Received:
    353
    GPU:
    Nitro 390/GTX1070M
    What are your power settings in global and game profile in NVCP?
     
  3. Caesar

    Caesar Master Guru

    Messages:
    498
    Likes Received:
    165
    GPU:
    GTX 1070Ti Titanium
    Try to check refresh rate first (from TV and Nvidia Control Panel)
    Also, reduce your graphics resolution to the maximum TV resolution that it can support.
    ------------------------------
    Easy one: Disable TV standby mode!:cool:
     
    Last edited: Mar 16, 2019
  4. Mbi2011

    Mbi2011 Member

    Messages:
    38
    Likes Received:
    0
    GPU:
    Sapphire HD 7970 OC
    All in default, but i've also tried maximum performance - no luck

    Tried different resolutions and refreshrates - still the same

    Problem occurs then i play on TV and monitor in standby mode, but then i play on monitor and TV in standby mode - there is no issues
     

  5. Chastity

    Chastity Ancient Guru

    Messages:
    1,602
    Likes Received:
    353
    GPU:
    Nitro 390/GTX1070M
    "Standby mode" as in when the panel sleeps? Or, are you referring to being the secondary panel, and the desktop is extended? @Mbi2011
     
    Caesar likes this.
  6. MrBonk

    MrBonk Ancient Guru

    Messages:
    2,899
    Likes Received:
    50
    GPU:
    MSI RTX 2080
    Bad cable perhaps or try without the other monitor conected.

    Also are you running the display in PC mode using a PC resolution and not an "HDTV resolution" in NVCP? Sometimes you think you will be using the right one but depending on the game it will call the wrong display mode and the refresh rate in the edid can often be slightly different in Video Timings vs PC Timings.
     
  7. Caesar

    Caesar Master Guru

    Messages:
    498
    Likes Received:
    165
    GPU:
    GTX 1070Ti Titanium
    As Chastity said, the problem might be with extended displays.
    Use one display only.
     
  8. Mbi2011

    Mbi2011 Member

    Messages:
    38
    Likes Received:
    0
    GPU:
    Sapphire HD 7970 OC
    It goes in that mode then didn't get any input signal, i didn't use extended desktop

    I didn't use extend / duplicate display options. Only "Show only on 1 / 2" display option

    I am using the same resolution and refresh rate as on PC monitor - 1080p 60hz. No stuttering without PC monitor connected to video card
     
  9. HARDRESET

    HARDRESET Master Guru

    Messages:
    322
    Likes Received:
    116
    GPU:
    1080ti G1 GAMING OC
    Try Lasso ?
     
  10. Mbi2011

    Mbi2011 Member

    Messages:
    38
    Likes Received:
    0
    GPU:
    Sapphire HD 7970 OC
    Didn't find any strange activities

    Also then PC is off (TV and monitor connected to videocard), TV shows me every few seconds that PC input is active:

    And then i turn off the monitor by button - this message disappears.

    So it's probably not PC settings related
     
    Last edited: Mar 18, 2019

  11. Caesar

    Caesar Master Guru

    Messages:
    498
    Likes Received:
    165
    GPU:
    GTX 1070Ti Titanium
    Install Smartcontrol Software.

    Got to Setup in Menu.

    RESET
    -------------
    Whats your windows version?
    -------------
    Check this tool: Intelligent Standby List Cleaner

    • The application will monitor and clear the memory standby list when it is > 1000mb (1gb).
    • It should help users who have stutters in games when using windows 10 Creator update and higher version of windows.
     
    Last edited: Mar 18, 2019
  12. Dan

    Dan Member

    Messages:
    46
    Likes Received:
    12
    GPU:
    RTX 2060
    Does your TV have a PC mode you can enable so that your PC sees it as a monitor rather than HDTV? On Samsung TVs you would just rename the input to PC. This might make it play nicer with your GPU maybe.
     
  13. Mbi2011

    Mbi2011 Member

    Messages:
    38
    Likes Received:
    0
    GPU:
    Sapphire HD 7970 OC
    Yep, already set that source to PC
     
  14. rylen

    rylen Active Member

    Messages:
    86
    Likes Received:
    0
    GPU:
    Zotac GTX1060 6GB
    I also have that issue, the only fix that works for me is using this tool: MSI Utility v2
    Just run it as an administrator, tick the check box for your GPU then restart your PC.
    [​IMG]

    EDIT: You need to do this every time you update your GPU driver.
     
    Last edited: Mar 19, 2019
  15. janos666

    janos666 Master Guru

    Messages:
    625
    Likes Received:
    37
    GPU:
    MSI GTX1070 SH EK X 8Gb
    The latest FreeSync capable Samsung TVs might be different but most TVs look exactly the same on the source side whether you put them to PC mode or not . That switch usually alters the behavior of the TV's internal processor but that's fully transparent on the other end of the HDMI link. And even if the EDID changes between TV/PC modes (as seen by the source device) the main differentiating factor is if the display is detected as legacy DVI, native HDMI or native DP and that won't change. Native HDMI devices will be treated as TVs (even if they are in fact more alike of monitors than televisions, like small sized and have no DVB tuners, etc).
     

  16. Mda400

    Mda400 Master Guru

    Messages:
    702
    Likes Received:
    18
    GPU:
    1660 - 2130/10ghz
    Unless your hard drive/SSD is causing the system to hitch, It seems to come down to possible refresh rate differences between the two monitors and when one display is turned on, there is no stutter.

    At least when using borderless/windowed display modes, both displays should be running at the same or half of the highest refresh rate available.
    This is how DWM works when extending desktops. It runs at the primary monitor's refresh rate and whatever the secondary is running at will have to synchronize to the primary display's refresh rate.

    Try the below with only your TV connected first, then do the same with only your monitor connected

    - When your TV is only connected, if the Nvidia control panel shows refresh rates of 23, 29, or 59hz in the list it is reporting NTSC timings and these are what should be used. 60hz is still sent as 59hz for compatibility with applications that expect 60hz.

    - The exception to the above is if when your monitor is only connected, if none of the above refresh rates are available then 60 hz should be selected for BOTH displays because the monitor dictated it has the higher refresh rate.
     
    Last edited: Mar 21, 2019

Share This Page