Strix 3090 LG CX48 Gsync

Discussion in 'Videocards - NVIDIA GeForce Drivers Section' started by BoxChevy, Jan 28, 2021.

  1. BoxChevy

    BoxChevy Active Member

    Messages:
    88
    Likes Received:
    22
    GPU:
    Asus Strix OC 3090
  2. itpro

    itpro Maha Guru

    Messages:
    1,362
    Likes Received:
    731
    GPU:
    AMD Testing
    I do not believe it is cable's fault or 3090's. You should go with 2019 models like C9 which had 4x48gbps true hdmi 2.1 models or wait for 2021. CX like BX, GX and all 2020 lineup are problematic cheap trash. Never had any issues with my 2019 models. I will exchange 2020 model for a 2021's one.
     
  3. Mda400

    Mda400 Maha Guru

    Messages:
    1,016
    Likes Received:
    142
    GPU:
    3080Ti 1950/21.3g
    Can't say that's been my experience with my CX 48 and there is no reason for 48 gbps when the panel is 10-bit.

    Does something not work? Even though it says its not certified for G-Sync, have you tested an application with G-Sync enabled?
     
  4. BoxChevy

    BoxChevy Active Member

    Messages:
    88
    Likes Received:
    22
    GPU:
    Asus Strix OC 3090
    I don't agree with this at all if it was a bandwidth issue then it would work at lower resolution's. My cx has been amazing this is a driver issue with nvidia it worked fine on my 2080ti

    @Mda400 , yes getting screen tearing in death stranding.
     
    Last edited: Jan 28, 2021

  5. Mda400

    Mda400 Maha Guru

    Messages:
    1,016
    Likes Received:
    142
    GPU:
    3080Ti 1950/21.3g
    You can still have screen tearing with G-Sync enabled. You need to enable V-Sync to engage the VRR frametime compensation feature that will prevent tearing but not induce input delay when the framerate is inside the VRR range.

    You then want to limit your fps to at least 3 fps below the maximum refresh rate to prevent the framerate from running into the V-Sync limit. G-Sync will still provide smooth motion below this limit. You can check if G-Sync is enabled in an application, by toggling its indicator feature in the Nvidia control panel when you click on an option under "Display". You'll also notice it working when the framerate varies a lot inside the VRR range and how smooth the transition will be.

    Also, make sure "enable settings for the selected display model" is checked in the G-Sync section.

    [​IMG]
     
    Last edited: Jan 29, 2021
    BoxChevy likes this.
  6. BoxChevy

    BoxChevy Active Member

    Messages:
    88
    Likes Received:
    22
    GPU:
    Asus Strix OC 3090
    That was it vsync was off.
     
    Mda400 likes this.
  7. PPC

    PPC Master Guru

    Messages:
    257
    Likes Received:
    126
    GPU:
    3070
    I have a problem with Q80T and VRR, i know this tv aint nvidia certified but it is compatible, every test on the internet says so and i found couple of videos where its working for people but it flickers on mine like crazy. Tried different cables, even GPUs, it aint working.
     
  8. Mda400

    Mda400 Maha Guru

    Messages:
    1,016
    Likes Received:
    142
    GPU:
    3080Ti 1950/21.3g
    Some things to try:

    1. Update TV firmware to latest version available. Some regions may have newer firmware that may have already solved this issue.
    2. Make sure graphics driver is up-to-date.
    3. Make sure game mode is set to Auto under External Device Manager.
    4. Make sure PC is connected to HDMI port 4 and make sure Input Signal Plus is enable for port 4 under External Device Manager
    5. If using HDMI ARC/eARC, disable/discontinue using the feature temporarily.
    6. Try labeling HDMI port 4 to "PC" and use a refresh rate higher than 50hz.
    7. Change color bit depth to a different value in the Nvidia control panel (e.g. if on 8 bit, select 10 bit and vice-versa)
    8. Toggle the G-Sync feature off/on in the Nvidia control panel after computer startup, then see if it causes the image to stabilize.
    9. Change display scaling modes in the nvidia control panel to see if it resolves the issue.
    10. Temporarily disable sound for the display in the Nvidia control panel or windows sound control panel to see if it resolves the issue.
     
    Last edited: Feb 1, 2021
  9. PPC

    PPC Master Guru

    Messages:
    257
    Likes Received:
    126
    GPU:
    3070
    Ha, yeah, tried everything but 10. and then some (3 cables, different manufacturers, different length, basically all do the same), tried 2 nvidia GPUs, 3 drivers so far, all the resolutions and refresh rates, fresh windows, etc. Next on my list is a test with AMD GPU or if i get someone with new Xbox.

    Basically, VRR engages in Gsync compatible mode but it flickers like mad. When fps falls down from 120 Gsync counter and "Info" on tv both say the same. Display tries to lower refresh rate to match frame rate but something brings it back instantly so when fps is on lets say 90 what i will see on the counters is very fast switching like 90...120...90...120...90...120...90...120... It tries to go back up in refresh (not in fps, obviously) and that confusion is causing the flicker. It is unusable. Once, i cant even remember under which conditions, when Gsync engaged the whole screen started distorting in a precise horizontal wave pattern, should have video it but didnt. :/
     
  10. Cave Waverider

    Cave Waverider Maha Guru

    Messages:
    1,405
    Likes Received:
    263
    GPU:
    RTX 3090 ROG Strix
    What's the lower VRR boundary of your TV? My guess it's somewhere near 90Hz (You could use CRU to see the upper and lower VRR bounds), as soon as it goes below that, it'll jump to 120 (either due to LFC if it's supported or it'll just go to the default refresh rate if not).
    Then as you said, it's brightness flicker, as the TV probably can't sustain the same brightness levels at various Hz ranges and you'll notice the big jump. Try keeping your framerate above 93 FPS and see if it still occurs.
    Also, you could try to use Custom Resolution Utility (CRU) to set the lower boundary of your VRR Range to something lower like 48Hz (but perhaps try different Hz with your screen resolution first to see how low the display will go and try that).
     

  11. PPC

    PPC Master Guru

    Messages:
    257
    Likes Received:
    126
    GPU:
    3070
    Actually, the RTINGS test measured it as low as 20Hz, also 90 was just an arbitrary number that i get in horizon dawn, it happens on every fps/hz. As the fps goes lower the flicker gets worse. Im starting to think there might be an issue with my unit tbh. When i open CRU there is like 7 samsung devices listed (for one tv) and none of them has any info about freesync, none. Nvcpl does detect the tv as Gsync compatible (but not certified), the tv does display VRR in "Info" tab when it engages but absolutely nothing in CRU.

    Only thing i have left is trying it with AMD gpu since the tv is freesync certified, gsync is just a compatibility. If that fails ill take it for RMA, 2020 models in the "high end" basically only differentiated by hdmi 2.1 features, thats basically what i paid for, if it doesnt work...
     
  12. Richintx

    Richintx New Member

    Messages:
    5
    Likes Received:
    1
    GPU:
    3090
    I have the same problem with a:

    LG NanoCell 85 Series 2020 49 inch and a zotac 3090.

    Interestingly it worked fine with a 1080ti albeit at only 60 Hz.

    I suspect it is in fact a defect in gsync over hdmi 2.1, but I don’t think Nvidia and LG/Samsung know who is responsible for the fix.

    I have not gone to the lengths of the OP to Attempt to resolve, I’m just glad I found this post because I was suspecting a defective TV as well.

    Hdmi 2.1 is a bleeding edge tech so that’s the core of the problem.

    Why couldn’t they just have added 1 DisplayPort input for goodness sake!?!?

    You are not Alone... I’ve suffered in silence since Christmas, but consoled myself with the fact that I was at least able to score a 30 series GPU.

    This is the only post I’ve seen accurately describing the exhibited problem.

     
  13. Richintx

    Richintx New Member

    Messages:
    5
    Likes Received:
    1
    GPU:
    3090
    Well thanks to this post I figured it out.

    GSYNC won’t work over hdmi 2.1 even though it allows you to enable it.

    I found a year old post on the nvidia forum that says hdmi 2.1 supports vrr irrespective of whether you have Gsync or Freesync video card.

    Which basically means having an hdmi 2.1 chip on their cards forces Nvidia to actually support Freesync by default.

    So I did a test...and it works!

    here’s the fix:

    1. Turn on advanced gpu queueing in windows 10 graphics adapter setting
    2. set gysync to off in nvcpl— change to fixed refresh
    3. Turn on freesync to wide on the tv
    4. Set vsync setting to “fast” in nvcpl Global
    5. Set low latency to “on” in nvcpl global
    6. Set FPS limiter to ‘117” in nvcpl — I use 100
    7. Set vsync on in in games
    And there you have it 100-120hz hdmivariable refresh rate with “No Brightness Flickering” on an rtx3090.

    If you didn’t post, I would have assumed I had a defective tv as well, so no thanks required.

    What a horrible waste of time figuring this all out.

    Happy 4K gaming!
     
    bigcid1 likes this.
  14. Terepin

    Terepin Master Guru

    Messages:
    819
    Likes Received:
    96
    GPU:
    ASUS RTX 3070 Ti
    Not true. First off, it's FreeSync, not GSync. Secondly, FreeSync was designed to be used with VSync, as it's using it only as a frame limiter.
     
  15. Mda400

    Mda400 Maha Guru

    Messages:
    1,016
    Likes Received:
    142
    GPU:
    3080Ti 1950/21.3g
    If we want to get technical, it's called HDMI forum VRR as that is what Nvidia is using to provide G-Sync Compatible over HDMI on Turing and Ampere gpu's.

    When VRR is enabled, V-Sync causes the VRR functionality in the display to adhere to the scanout period when frame rate is inside the VRR range. Otherwise you will get a small tearing line at the bottom of the screen with v-sync off, but framerate inside the VRR range.
    https://blurbusters.com/gsync/gsync101-input-lag-tests-and-settings/2#spikes-101
     
    Last edited: Feb 4, 2021

  16. Terepin

    Terepin Master Guru

    Messages:
    819
    Likes Received:
    96
    GPU:
    ASUS RTX 3070 Ti
    I'm not exactly sure what you just wrote, but with VSync the frame rate never exceeds monitor's refresh rate. Frame rate is capped and extra frames are discarded.
     
    Mda400 likes this.
  17. Richintx

    Richintx New Member

    Messages:
    5
    Likes Received:
    1
    GPU:
    3090
    Well regardless of the technicals behind it... the near epilepsy brightness flickering the OP and I experienced is Finally resolved for me.

    I suppose nobody that has personally experienced it can relate until you actually see it.

    The weird thing, is that in addition to resolving the flicker, I gained near 10 Constant FPS vs compared to when I had gsync Enabled and NO tearing. I can’t believe it myself!

    Hope this helps someone else who Maddeningly thought they had a defective hardware issue. Almost 2 months of troubleshooting this nonsense.
     
  18. PPC

    PPC Master Guru

    Messages:
    257
    Likes Received:
    126
    GPU:
    3070
    Hmmm theres only one problem here man, on Samsung as soon as you disable Gsync in nvcpl the VRR options get grayed out on the TV. It seems like it uses separate (or separate section) EDID when gsync is enabled since enabling it the first time reset my display settings completely, like the tv was a new, unset, display device.
     
    Last edited: Feb 5, 2021
  19. Richintx

    Richintx New Member

    Messages:
    5
    Likes Received:
    1
    GPU:
    3090
    Yeah... the OP and I are using LG... his is the OLED version... mine is the nanocell version.

    From what I understand as long as your Samsung has hdmi 2.1 120hz and supports Freesync, and you have an nvidia 30 series you probably have the capability.

    I’ve read and watched you tube that says many of the Samsung features are hidden in deep menus that are non obvious.

    The only thing I can recommend is to familiarize yourself with all of the Samsung menu options via the manual or online to see if you’ve overlooked something.

    Also search for your TV model and Freesync and follow the trail.
     
  20. PPC

    PPC Master Guru

    Messages:
    257
    Likes Received:
    126
    GPU:
    3070
    Yeah, i got that much but my point was that when you disable gsync in nvcpl i doubt it will somehow be active because you switched it on on tv. Tv is a reproduction device, gpu is the source, if its cut at the source how does it activate on the display? At 120hz my tv really has so little tearing even when playing doom eternal (very fast fps, i have motion blur turned off) i only see tearing in very special circumstances that are close to test patterns. Like when there are a lot of same textured vertical objects next to each other, if you move the mouse really fast (and i do mean frantic) you can see that some edges wont line up but again the discrepancy is very minor. In the heat of the game i really cannot notice it. You can turn gsync indicator in nvcpl, try that and see if it displays, im genuinely interested.

    EDIT: Blah, just checked, if you disable Gsync in nvcpl the Gsync indicator option becomes grayed out. Im really not sure you are actually getting Gsync with your method. :/ Tear free, mostly, but Gsync, no.

    EDIT: Seems like last drivers broke Gsync for CX and now its fixed
    [461.40] LG CX OLED TVs (2020) are not recognized as G-SYNC Compatible displays [3244055]
     
    Last edited: Feb 5, 2021

Share This Page