Strange SSD behavior!

Discussion in 'SSD and HDD storage' started by bathrobehero, Jan 25, 2013.

  1. bathrobehero

    bathrobehero Member

    Messages:
    10
    Likes Received:
    0
    GPU:
    GTX 780 Ti
    Hi, I'm just going to start with a picture:

    http://screenshotuploader.com/i/01/6uu0lcv1h.png

    Explanation:
    The benchmarks on the left side are made while the CPU was not stressed, as in idle environment, but here's come the fun part because the benchmarks on the right side are made while the CPU was kept at 100% - by Everest's stress test (CPU only) but it's not exclusive to Everest, any CPU hogging application seem to make the SSD faster.


    This happens both on my new Samsung 840 (non-Pro) and on my older SiliconPower V20 40GB SSD's.
    Also, it's the same with both the amd_sata (1.2.1.331) and the Standard AHCI drivers.
    I have an Athlon II X2 3.4 @ 4.0 CPU and a fresh Win7 x64 HP and the minimum processor state is set to 100% in the power options so it's not even about it being downclocked to around 800mhz when being idle.
    My MB (M4A88T-M) only supports Sata2.


    So why is my SSD is faster in every test I tried when my CPU is stressed to 100%?
     
    Last edited: Jan 25, 2013
  2. Chillin

    Chillin Ancient Guru

    Messages:
    6,813
    Likes Received:
    1
    GPU:
    -
    That is strange.

    I'm going to run a similar test in a few minutes and we'll see if the same behavior occurs on my 840 Pro.
     
  3. Chillin

    Chillin Ancient Guru

    Messages:
    6,813
    Likes Received:
    1
    GPU:
    -
    Holy crap, it's confirmed.

    Idle:
    [​IMG]


    Load:
    [​IMG]

    I'm going to message Hilbert and Anand to see if they can take a look at this.
     
  4. Scerate

    Scerate Maha Guru

    Messages:
    1,039
    Likes Received:
    0
    GPU:
    980Ti@1.5/1070N@2Ghz
    Try disabling or enabling C-States in Bios, cause i remember that this thing can do something like this.
     

  5. Mufflore

    Mufflore Ancient Guru

    Messages:
    10,340
    Likes Received:
    67
    GPU:
    1080ti @2GHz air
    ^ was about to say the same.
    It will be down to the CPU taking time to wake from power saving.

    edit:
    To confirm, I have all idle states disabled on my CPU and performance remains the same, if not a tiny bit lower when running Prime95 while using HDTune to test my OCz Vector 256GB.
     
    Last edited: Jan 25, 2013
  6. Agent-A01

    Agent-A01 Ancient Guru

    Messages:
    9,833
    Likes Received:
    72
    GPU:
    1080Ti H20
    Yep. Its always been like this ever since ive had a ssd. basically those tests dont put enough load on the cpu to get them out of idle clocks. normal behavior
     
  7. clawhamer

    clawhamer Ancient Guru

    Messages:
    2,579
    Likes Received:
    0
    GPU:
    EVGA 780 Classified
    Not sure if it's directly related or not, but I get the same results on my laptop with no way making adjustments in the bios.
     
  8. Mufflore

    Mufflore Ancient Guru

    Messages:
    10,340
    Likes Received:
    67
    GPU:
    1080ti @2GHz air
    Same results as what?
     
  9. clawhamer

    clawhamer Ancient Guru

    Messages:
    2,579
    Likes Received:
    0
    GPU:
    EVGA 780 Classified
    Higher BM numbers while the CPU is under load, it's a known issue for some laptops.
     
  10. Mufflore

    Mufflore Ancient Guru

    Messages:
    10,340
    Likes Received:
    67
    GPU:
    1080ti @2GHz air
    Ah ok.
    I thought you meant you also get the same loaded vs unloaded which would be unusual if you cant change the settings in the BIOS.
     

  11. bathrobehero

    bathrobehero Member

    Messages:
    10
    Likes Received:
    0
    GPU:
    GTX 780 Ti
    The only BIOS feature I found and tried disabling was C1E, but that had no effect.
    Also, my CPU is set not to downclock itself when idle, so it look like this always:
    http://valid.canardpc.com/2667419
     
  12. Arctucas

    Arctucas Ancient Guru

    Messages:
    2,028
    Likes Received:
    1
    GPU:
    eVGA GTX970SSC
    Using AS SSD rather than HD Tune, I see little overall score difference.

    Load

    [​IMG]

    Idle

    [​IMG]
     
  13. bathrobehero

    bathrobehero Member

    Messages:
    10
    Likes Received:
    0
    GPU:
    GTX 780 Ti
    AS SSD:

    [​IMG]
    (lower is idle)

    Yes, the difference is much smaller, but it's still there, especially for 4k read/write.

    Tried disabling windows write cahce or turning off write cache buffer flushing but it has no effect.

    If it was the other way around - slower speeds under heavy CPU load - that would be logical and even make sense but this is just beyond me.
     
    Last edited: Jan 26, 2013
  14. Arctucas

    Arctucas Ancient Guru

    Messages:
    2,028
    Likes Received:
    1
    GPU:
    eVGA GTX970SSC
    Other benchmarks:


    atto

    idle

    [​IMG]

    load

    [​IMG]

    anvil

    idle

    [​IMG]

    load

    [​IMG]

    crystal

    idle

    [​IMG]

    load

    [​IMG]

    HD tune

    idle

    [​IMG]

    load

    [​IMG]
     
  15. bathrobehero

    bathrobehero Member

    Messages:
    10
    Likes Received:
    0
    GPU:
    GTX 780 Ti
    Ok, I found the problem and the solution.

    So apparently the CPU has more idle modes than I thought. In other words, the CPU can be idle even if it's not downclocking itself. Which is great, but some chipsets - like mine (AMD 880G/SB710) - is not "waking up" the CPU in case of heavy I/O operations.

    So there's a registry key with which we can disable the cpu ever being idle by chaning the Attributes key from 1 to 0 under:
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power\PowerSettings\54533251-82be-4824-96c1-47b60b740d00\5d76a2ca-e8c0-402f-a133-2158492d58ad]

    which unlocks an option in the Power Options which looks like this:

    [​IMG]

    So with this option I have awesome speeds - for sata2 that is - but this option has some disadvantages as well. One of which is higher CPU temperatures, more power consumption because it appears disabling this idle state is acting like the CPU is at 100% but it is not, as you can see marked on the picture with red (cpu usage).
    So if you have a dumb chipset and a CPU which gets hot under heavy load than it's not for you.
    My CPU's idle temperature is around 30°C with stock cooler at 10% (ten) fan speed @4.0 (from 3.4) but with this "tweak" it's around 38°C.


    Source: http://www.storagereview.com/how_to...rmance_in_intel_series_5_chipset_environments
     

  16. bathrobehero

    bathrobehero Member

    Messages:
    10
    Likes Received:
    0
    GPU:
    GTX 780 Ti
    My final thoughts on this is that this phenomen must be chipset-related.

    Notice that the main difference in the benchmarks is about 4k R/W which has the highest IOPS action, meaning that something has to manage those high IOPS actions which would be our missing element (CPU/FPU/cache/whatever) which was not required for HDD's due to low IOPS so it's understandable why some chipsets are not "waking up" this missing component for heavy I/O actions - even if they should for SSD's.
     
  17. tweakpower

    tweakpower Banned

    Messages:
    932
    Likes Received:
    0
    GPU:
    MSI HD 6770
    For me it is same, even worse on load.

    IDLE:
    [​IMG]

    LOAD:
    [​IMG]

    One note, I'm using "UnparkCPU" program at first install of Win 7+ OS. Try that instead, temps are same as without Unparked cores.
     
  18. bathrobehero

    bathrobehero Member

    Messages:
    10
    Likes Received:
    0
    GPU:
    GTX 780 Ti
    Thanks for the feedback and I tried UnparkCPU but it's not about parked cores since I only have 2 cores anyway.

    You have nice results either way so you're chipset is great.
     
  19. tweakpower

    tweakpower Banned

    Messages:
    932
    Likes Received:
    0
    GPU:
    MSI HD 6770
    And after you tried is the same? I know that you have only two cores, but on my Athlon II x2 (same as yours but slower, 870 chipset), for some reason, core parking have influence, games for example, works smoother than without unparking, go figure, i also noticed same behavior on 960T (890 chipset).

    That's why i thought you should give it a try. Other things i did, optimized all drives same as SSD (not allowing them to use system RAM for caching), disabled HPET (in both BIOS and device manager).

    Maybe worth a try.
     
  20. bathrobehero

    bathrobehero Member

    Messages:
    10
    Likes Received:
    0
    GPU:
    GTX 780 Ti
    I tried it and it had no noticable effect.
    I left it unparked though.
     

Share This Page