Stop reinstalling the wddm drivers!

Discussion in 'Videocards - NVIDIA GeForce Drivers Section' started by PirateNeilsouth, Mar 17, 2010.

  1. PirateNeilsouth

    PirateNeilsouth Ancient Guru

    Messages:
    1,773
    Likes Received:
    0
    GPU:
    980 OC
    I'm not sure why but with some nvidia drivers even if you tell windows not to install it's own drivers via device manager it does anyway. I don't want it to install the nvidia gtx 260 wddm drivers but it keeps doing it , even in safemode.

    This doesn't happen with every driver :3eyes:

    I'm trying to do a complete clean up , to do some driver benchmarking
     
  2. SuperBill

    SuperBill Master Guru

    Messages:
    243
    Likes Received:
    0
    GPU:
    Dual eVGA GTX 580's - SLI
    After you uninstall the existing drivers reboot into safe mode. It will still attempt to install the drivers but just run Driver Sweeper or Driver Cleaner.net (whichever you prefer). Then reboot into normal Windows mode and it will not reinstall the wddm drivers. Install your drivers of choice and reboot.
     
  3. PirateNeilsouth

    PirateNeilsouth Ancient Guru

    Messages:
    1,773
    Likes Received:
    0
    GPU:
    980 OC
  4. Scalarscience

    Scalarscience Member Guru

    Messages:
    154
    Likes Received:
    1
    GPU:
    Gigabyte GTX580 Classifie
    Just change the behavior of windows update to not autoinstall always without user intervention. That's the setting for a mom/pop PC so that they can't mess things up (windows will override drivers with its own.)
     

  5. PirateNeilsouth

    PirateNeilsouth Ancient Guru

    Messages:
    1,773
    Likes Received:
    0
    GPU:
    980 OC
    I know that's already been done

     
  6. SuperBill

    SuperBill Master Guru

    Messages:
    243
    Likes Received:
    0
    GPU:
    Dual eVGA GTX 580's - SLI
    Windows is installing default drivers contained within it's .cab files. The only thing an end user can control is whether or not Windows checks Windows Update for updated drivers to auto-install. Regardless of this setting it will want to install the latest drivers it can find contained within the setup .cab's. There are ways to modify the .cab's but it's just not worth it really when you can just boot to safe mode and run a clean.
     
  7. kitch9

    kitch9 Ancient Guru

    Messages:
    1,891
    Likes Received:
    0
    GPU:
    XFX 7990 3GB
  8. PirateNeilsouth

    PirateNeilsouth Ancient Guru

    Messages:
    1,773
    Likes Received:
    0
    GPU:
    980 OC
    Well i uninstalled the 196.86 benchmarked , uninstalled e.t.c ( Windows didn't install it's own driver )

    Installed the 186.18 , uninstalled ( windows didn't install it's own driver )

    But why did it do it with the 197.x and sometimes other drivers. Just wondering!
     
  9. Infanticide

    Infanticide Member Guru

    Messages:
    190
    Likes Received:
    0
    GPU:
    AMD Radeon R7 260X 2GB
    The same happens to me (Win7 x64), even though I have all necessary things unchecked. Heres how I am doing this:
    1)uninstall drivers from add\remove progs
    2)restart into safe mode
    3)windows will install its own drivers and you cant cancel it, just go into device manager and manually uninstall your gpu driver, then leave it for now
    4)clean with driver sweeper and ccleaner (to be sure:);
    5)return to device manager and tell it to check for hardware changes, it will redetect your GPU and attempt to install driver for it but will fail
    6)run driver sweeper one last time (it always finds new nvidia entries at this point) and restart
    7)install new drivers
    8)restart :p

    It works every time on my PC.

    Windows is doing it to me with every driver, not just last one.
     
  10. PirateNeilsouth

    PirateNeilsouth Ancient Guru

    Messages:
    1,773
    Likes Received:
    0
    GPU:
    980 OC
    :beer: Nice one Cheers
     

  11. gladi8r

    gladi8r New Member

    Messages:
    5
    Likes Received:
    0
    GPU:
    MSI 3080ti
    Go to C:\Windows\System32\DriverStore\FileRepository (in Win7)
    Search for nv_disp.inf_amd64_neutral*
    If you take ownership and delete this dir, windows shouldn't reinstall the drivers on reboot.
     
  12. triskele10

    triskele10 Active Member

    Messages:
    65
    Likes Received:
    0
    GPU:
    MSI GTX660TI PE
    It didn't work but after deleting this line it works fine now C:\Windows\System32\DriverStore\FileRepository\nv_lh.inf_amd64_neutral

    It was from driver 185.93 and now it's not comming back.
     
  13. gladi8r

    gladi8r New Member

    Messages:
    5
    Likes Received:
    0
    GPU:
    MSI 3080ti
    I meant to include that dir as well, sorry.
     
  14. ferdy

    ferdy Active Member

    Messages:
    92
    Likes Received:
    0
    GPU:
    gtx980 TI hybrid
    if y want you can set this to off ..so w7 does not install anything in the beginning and after that..i try to tell y were y find it so try it an have fun....

    How To Disable Automatic Driver Installation In Windows 7 / Vista

    Suppose you have connected a device with your computer, Windows 7 / Vista will now automatically search for the driver and install it. If you want to select every driver manually(because you have a manual driver that is better), then you should disable automatic driver installation. To do this you don’t need to install any software at all, you can do this using Windows Driver Settings.

    Update: Some people complained that the original method doesn’t work at all. Reader mufuti0815 points out a method to properly disable automatic driver installation. I have tested it and it seems to be working. Here is what you need to do:

    * Go to Start–>Search type in gpedit.msc
    * Click the file to open the Local Group Policy Editor and show Windows who is in control!!
    * You want to go here: Computer Configuration->Administrative Templates->System->Device Installation. Click on the subfolder Device Installation on the left and on the right side you will see the possible restrictions.
    * Right Click on Prevent Installation of Devices not described by other policy settings and edit this option, set it on ENABLED.
    Reboot Windows and enjoy its inability to pollute your system with its standard driver, open gpedit.msc again and revert the change so you will be able to install your driver.

    Go to Start menu, right-click on Computers and click Properties. On the left sidebar of the System dialog box, select Advanced System Settings. Now navigate to Hardware tab and click Windows Update Driver Settings as shown in the screenshot below.

    You will see a box as shown below, now simply select Ask me each time I connect a new device before checking for driversNever check for drivers when I connect a device, depending on how you want Windows Update to find a matching driver ? or

    Once you have selected the options, click OK and you are done.

    Update: If this doesn’t work, also try the solution here.

    what google can do for you so have fun
     
    Last edited: Mar 18, 2010

Share This Page