1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Starcraft II x64 crashes with RTSS 7.0

Discussion in 'Rivatuner Statistics Server (RTSS) Forum' started by Pinstripe, Dec 4, 2017.

Thread Status:
Not open for further replies.
  1. Pinstripe

    Pinstripe Member Guru

    Messages:
    136
    Likes Received:
    1
    GPU:
    GTX 1060 6G
    I'm not sure whether this is a RTSS or Starcraft 2 issue, but I'm gonna post it here anyway since Blizzard hasn't acknowledged the issue (yet).

    Using MSI Afterburner 4.4 + RTSS 7.0 (final), when launching Starcraft 2 (v 4.0.2) it immediately crashes with "An unexpected fatal error occurred". Mind you the 32-bit client launches normally. Took me quite a while to figure out what's the issue. In RTSS Setup under Compatibility poperties, I had to disable "Enable 64 bit applications support service" to make it launch. Alas, with that I can't use the OSD overlay anymore.

    Will this require a RTSS fix, or is the onus on Blizzard? Thanks in advance.
     
  2. Unwinder

    Unwinder Moderator Staff Member

    Messages:
    13,439
    Likes Received:
    462
    Cannot confirm that, launches fine here. Try to perform full uninistall and clean install of RTSS to ensure that you didn't cause the issue with unwanted RTSS tweaks and ensure that you don't have other 64-bit OSD software running in background.
     
  3. Fukki

    Fukki New Member

    Messages:
    6
    Likes Received:
    0
    GPU:
    MSI R9 390
    happens with me too, sc2 doesnt launch with rtss (game crash), it looks like started happening with novembers Windows 10 update.

    without rtss game works normal.
     
  4. Unwinder

    Unwinder Moderator Staff Member

    Messages:
    13,439
    Likes Received:
    462
    And the same advice for you. Read the previous post please and follow the suggestions.
     

  5. Unwinder

    Unwinder Moderator Staff Member

    Messages:
    13,439
    Likes Received:
    462
    Update:

    I've managed to reproduce the problem, as suspected it is a conflict with other 64-bit overlay. Blizzard's own overlay/streaming service broken compatibility in their recent patch. To address that open "Streaming" settings in Blizzard launcher and uncheck "Enable streaming". Alternately power users may also add Blizzard's overlay library (bzrclient64.dll) to delayed injection engine settings.
     
    Gendrol75 likes this.
  6. Fukki

    Fukki New Member

    Messages:
    6
    Likes Received:
    0
    GPU:
    MSI R9 390
    a clean reinstall solved for me, sorry for the trouble.

    blizzard streaming was already disabled too.
     
  7. Gendrol75

    Gendrol75 New Member

    Messages:
    1
    Likes Received:
    0
    GPU:
    GTX1080
    I've been having exactly the same problem, and this fixed it for me without having to reinstall/disable/modify RTSS in any way.

    Thanks!
     
  8. Andrea_23

    Andrea_23 Member

    Messages:
    16
    Likes Received:
    0
    GPU:
    5870@950|1250|1.2v
    Hi, just an update: i have to put on rtss's black list this executable
    ...\StarCraft II\Versions\Base62347\SC2_x64.exe

    Without this action, the game instantly crash on startup. It is not related to the streaming issue previously mentioned, because i'm able to launch the game with the "Enable streaming" option activated on the Blizzard launcher.
    All my others Blizzard games (D3, WoW, OW) launches without any hassle.
     
  9. Unwinder

    Unwinder Moderator Staff Member

    Messages:
    13,439
    Likes Received:
    462
    Cannot confirm that, configure your system properly and disable other hooks/overlays. That's the only reason that can cause it. Closed.
     
Thread Status:
Not open for further replies.

Share This Page