Starcraft 2 legacy of the void and crossfire with a HD7990

Discussion in 'Videocards - AMD Radeon Drivers Section' started by veca, Nov 16, 2015.

  1. veca

    veca New Member

    Messages:
    4
    Likes Received:
    0
    GPU:
    6 GB DDR3
    Hi,

    I have a little (big) problem with Starcraft 2 legacy of the void and my AMD Radeon HD 7990...

    The game have many many problems with crossfire, textures flickering for exemple, its totaly unplayable.

    The problem is there are apparently a profil for this game with crossfire enabled in the driver, and, beceause I have a Bi-GPU Card (AMD Radeon HD7990) I canot disable this in CCC, I can only add a profil for the game and disable crossfire for it... but... we dont have a direct acces to the .exe file for this game (thanks to blizzard) and, if I try this, the crossfire stay enabled... And I cannot play (I really hate this video card for that...)

    Can anyone have a solution for that ? or did I have to whait for the next driver ?


    PS : Sorry for my English but I'm french
     
  2. Turanis

    Turanis Ancient Guru

    Messages:
    1,779
    Likes Received:
    475
    GPU:
    Gigabyte RX500
    Only solution: no CFX/SLI for this DX9 old game.
     
  3. Bloodred217

    Bloodred217 Master Guru

    Messages:
    356
    Likes Received:
    1
    GPU:
    2x GTX 1080 G1 Gaming 8GB
    I had some terrible issues with LotV as well, though not graphical glitches. Instead performance is terrible and it appears to crash the driver and Windows along with it.

    Solution is pretty easy for SC2 specifically though, simply set the game to run in borderless fullscreen windowed mode from the settings, that will disable CF since it only works in fullscreen.
     
  4. veca

    veca New Member

    Messages:
    4
    Likes Received:
    0
    GPU:
    6 GB DDR3
    And now I feel really stupid not to have thought of that... Thank you :D
     

  5. yasamoka

    yasamoka Ancient Guru

    Messages:
    4,856
    Likes Received:
    246
    GPU:
    EVGA GTX 1080Ti SC
    You don't need borderless Windowed mode to disable CF, since borderless comes with its own share of issues sometimes such as always-enabled VSync, or performance slowdown for a few games. Instead, add the Starcraft 2 executable to the list of 3D applications in CCC and set CrossFire to disabled in there. That way, you will have no CrossFire even if in fullscreen. Then you can run the game however you like without worrying about CrossFire issues.
     
  6. OnnA

    OnnA Ancient Guru

    Messages:
    13,464
    Likes Received:
    3,423
    GPU:
    3080Ti VISION OC
    Or maby just try RadeonPro or i'll qoute Tweak from my thread ;-)

    "EnableCrossfireForNonProfileApps_DEF"="0" (Try enabling This for better CF)

    "EnableCrossfireForNonProfileApps"="0" (this and upper must be set to 1)
     
  7. Bloodred217

    Bloodred217 Master Guru

    Messages:
    356
    Likes Received:
    1
    GPU:
    2x GTX 1080 G1 Gaming 8GB
    You're welcome. If it doesn't work out well for you make sure to try the other ways of disabling CF that were mentioned here.

    Sure, but OP mentioned he tried that already and it didn't work for him. I have not personally tried that with LotV, so I didn't contradict him since I don't have personal experience with this particular game (or dual-GPU cards, if CF is handled differently for those).
     
  8. PrMinisterGR

    PrMinisterGR Ancient Guru

    Messages:
    7,867
    Likes Received:
    735
    GPU:
    Inno3D RTX 3090
    The actual .exe is SC2.exe and it's buried inside the "bade" folder somewhere. I don't have the game installed, but it has always been there.
     
  9. The Mac

    The Mac Ancient Guru

    Messages:
    4,404
    Likes Received:
    0
    GPU:
    Sapphire R9-290 Vapor-X
    unless they changed it, it moves around.

    Each patch creates a new folder, with a new .exe.
     
  10. veca

    veca New Member

    Messages:
    4
    Likes Received:
    0
    GPU:
    6 GB DDR3
    Tried... dont work too... I have tried with all exe files inside the game folder (and sub-folders), crossfire still stay enabled...
    The only way that work for me is the borderless Windowed mode.
     

  11. Moofachuka

    Moofachuka Member

    Messages:
    17
    Likes Received:
    10
    GPU:
    12GB
    this link might give you the answer you're looking for btw...

    TerrainTextureSize=768

    into

    TerrainTextureSize=1080

    AMD crossfire screen flickering workaround !

    Hi,

    In case you are suffering texture flashes while playing certains maps, (flashing white squares on the ground):



    while AMD crossfire is enabled, I found a workaround.

    My setup:
    ---------
    GPU's: 3 time Sapphire Radeon R9 290 Tri-X 4G GDDR5 OC running @ 1000(core)/1300(mem) MHz
    running on pci express 2.0 @ 8x 8x 4x

    CPU: Intel i5 2500K running @ 5000 MHz
    Motherboard: Asrock P67 Fatal1ty pro
    Power supply: Akasa Venom Power 1000 W
    Screen: Full HD 1920x1080, on display port @ 60 Hz
    Memory: 8 GB
    OS: Windows 7 SP1 (latest updates).
    GPU drivers: AMD catalyst WHQL 14-4-win7-win8-win8.1-64-dd-ccc-whql
    stacraft 2 version 2.1.1.29261

    So to fix the flickering on some maps,
    set stacraft 2 in full screen mode to enable crossfire,
    set you favorites options, exit the game.

    Now browse into C:\Users\xixou\Documents\StarCraft II\
    Where C is your windows drive letter and xixou is your windows login/user name,
    replace those two.

    open the Variables.txt
    it contains starctaft 2 settings.
    search for the word TerrainTextureSize
    replace the current number that is next to it with the value 1080

    example:
    TerrainTextureSize=768
    becomes
    TerrainTextureSize=1080

    Enjoy stacraft 2 in crossfire mode !!


    PS: I tried to post a link to battle.net thread but I couldn't... I need 5 posts to do this.

    I registered to help you lolll
     

Share This Page