Star Wars Battlefront Beta Performance Discussion

Discussion in 'Videocards - AMD Radeon Drivers Section' started by SlackerITGuy, Oct 9, 2015.

  1. PrMinisterGR

    PrMinisterGR Ancient Guru

    Messages:
    8,074
    Likes Received:
    908
    GPU:
    Inno3D RTX 3090
    That happens only in the caves level as far as I understand. To fix it you can temporarily drop the Lighting Quality to medium. It applies instantly. I hope they fix it soon.
     
  2. Biebo

    Biebo Active Member

    Messages:
    52
    Likes Received:
    2
    GPU:
    GPU
    Yup, same here.
     
  3. Skinner

    Skinner Master Guru

    Messages:
    544
    Likes Received:
    44
    GPU:
    Sapphire RX6900XT
    Same here.
    Putting 15.11 dlls in the game dir didn't work either. It's unbelievable I still cann't play an AMD sponsored game :bang:
     
  4. PrMinisterGR

    PrMinisterGR Ancient Guru

    Messages:
    8,074
    Likes Received:
    908
    GPU:
    Inno3D RTX 3090
    That's a real shame. CFX not working on a sponsored game is bad, but light rendering not working properly is plainly stupid.
     

  5. Skinner

    Skinner Master Guru

    Messages:
    544
    Likes Received:
    44
    GPU:
    Sapphire RX6900XT
    It makes you think how gamedevs and AMD are working against each other instead of together. Well I have no doubt it will work great eventually. COD BLOPS3 is working great after a rough start, so its the waiting game again, but I have accepted that more or less when using AMD GPU's. Crimson IS promising on certain aspects. The shadercache is doing great things allready on some games and Fury CF is really smooth and fast in most of my games and the IQ is asthonising.
     
  6. PieEyedPiper

    PieEyedPiper Master Guru

    Messages:
    624
    Likes Received:
    10
    GPU:
    RX 580
    Performs much better than the beta for me, overall. Not encountered any black snow yet.

    I just wish TAA wasn't so blurry.
     
  7. PrMinisterGR

    PrMinisterGR Ancient Guru

    Messages:
    8,074
    Likes Received:
    908
    GPU:
    Inno3D RTX 3090
    I'm using ReShade and the SweetFX sharpener for that and it looks fine. You mean that with Lighting at Ultra, you don't have blackness in the caves map?
     
  8. Cave Waverider

    Cave Waverider Maha Guru

    Messages:
    1,411
    Likes Received:
    267
    GPU:
    RTX 3090 ROG Strix
    While setting lighting quality to medium gets rid of the black parts, the ice cave graphics don't look quite right either (compared to an Nvidia video card where there is no such issue). It's really odd.

    Also, using the 15.11 DLLs gets rid of the problem completely even on Ultra lighting, but the gameplay becomes really choppy with them and for some reason my audio crackles weirdly.

    On the other hand, the Crimson drivers perform really well, but the ice caves level is full of black patches.
    By the way, CrossfireX works on my two 7970Ms and appears to scale performance up well, too, if I have "Enable AMD Crossfire for directX 9/10/11 and OpenGL applications that hav eno application profile" ticked and I don't get the constant menu flickering and missing fonts that I get when forcing any of the Frostbite 3 Crossfire profiles (BFH, etc.).
     
    Last edited: Nov 30, 2015
  9. PieEyedPiper

    PieEyedPiper Master Guru

    Messages:
    624
    Likes Received:
    10
    GPU:
    RX 580
    Not that I've noticed but I need to play more tbh. I will update for sure if I see it. I don't want to give a false impression.

    EDIT: Nothing special going on here. I found the black snow like everyone else just had to play the right game mode.
     
    Last edited: Nov 29, 2015
  10. PrMinisterGR

    PrMinisterGR Ancient Guru

    Messages:
    8,074
    Likes Received:
    908
    GPU:
    Inno3D RTX 3090
    Because if you don't, we need to study your system :D
     

  11. Progeny

    Progeny Active Member

    Messages:
    54
    Likes Received:
    0
    GPU:
    GTX 670 DC2T @ 1300 MHz
    Crimson and 15.1.1 provides black snow for me altho crimson gives very high and smooth performence. 15.1 lil choppy and indeed a crackling sound. I'm switching to 15.10

    Is that the best drivers for this game for now?
     
  12. Cave Waverider

    Cave Waverider Maha Guru

    Messages:
    1,411
    Likes Received:
    267
    GPU:
    RTX 3090 ROG Strix
    I've tried 15.10 and while the crackling sound isn't as bad as 15.11, it's still there and performance is very choppy. Plus, with 15.10 the game seems to crash with TDRs at times.
    I'm back with the Crimsons for now and medium lightning in ice caves for now. Hopefully the next driver and/or game update will fix this annoying bug.
     
  13. Progeny

    Progeny Active Member

    Messages:
    54
    Likes Received:
    0
    GPU:
    GTX 670 DC2T @ 1300 MHz
    btw with 15.1.1 i used to crash alot of times too. I will have to test with 15.10 for now. I have noticed tho that the audio is laggy but i guess i can live with that.
     
  14. nevernamed

    nevernamed Master Guru

    Messages:
    234
    Likes Received:
    4
    GPU:
    EVGA 1080 TI FTW3
    thats strange people are saying the 15.11 dll's aren't working.. they are for me..
     
  15. Cave Waverider

    Cave Waverider Maha Guru

    Messages:
    1,411
    Likes Received:
    267
    GPU:
    RTX 3090 ROG Strix
    The new Crimson 15.11.1 Beta drivers have fixed all issues with Battlefront for me, except some minor flickering with the top performers screen being layed over the score at the end of a match. I can now play the game without any texture issues on Ultra quality on my two 7970Ms in CrossfireX and with solid 60 FPS at my laptop's native resolution of 1920x1080. Very cool. :)
     

  16. TonyTurbo

    TonyTurbo Master Guru

    Messages:
    233
    Likes Received:
    16
    GPU:
    Vega 64 @ 1750/1180
    Star Wars still screwed up on my 390 crossfire setup for me. Clocks fluctuating quite alot and it doesn't matter what setting I change lighting quality to, I get missing textures 100 feet in front of my on all the maps.

    [​IMG]
     
  17. putino

    putino Active Member

    Messages:
    68
    Likes Received:
    0
    GPU:
    2x AMD Radeon 8970M / 4gb
    Good to know, I will try whenever I get home.
     
  18. Progeny

    Progeny Active Member

    Messages:
    54
    Likes Received:
    0
    GPU:
    GTX 670 DC2T @ 1300 MHz
    It was about time. Thanks for this. Going to try them now.
     
  19. dox_aus

    dox_aus Master Guru

    Messages:
    301
    Likes Received:
    0
    GPU:
    MSi 290 Gaming CF
    Try turning off overlays such as afterburner/radeonpro, that fixed black terrain for me in CF
     
  20. Dygaza

    Dygaza Master Guru

    Messages:
    536
    Likes Received:
    0
    GPU:
    Vega 64 Liquid
    I don't really see why people think clocks jumping up and down is the problem, as it should be part of new power saving feature. You still have plenty or room there on gpu usage so higher clocks ain't needed. Though I don't know how flawless that feature is on 390 series, where it's working very well on Fury X. It shouldn't cause stuttering either, but who knows.

    Those missing textures must be annoying :(
     

Share This Page