Spec Ops The Line Vsync

Discussion in 'Games, Gaming & Game-demos' started by brutlern, Jun 28, 2012.

  1. brutlern

    brutlern Master Guru

    Messages:
    290
    Likes Received:
    0
    GPU:
    Gigabyte 1070 X Gaming
    Just tested Spec Ops the Line, and it ran great, maxed out, 60 fps all round with vsync enabled. But there's no AA, so I tried to force it using RadeonPro. Still no AA, but now the Vsync has gone all wonky, keeps dropping my frames to 30. I disabled RadeonPro thinking there was some compatibility issue, but still drops to 30 all the time. Fiddled with vsync from drivers, radeonpro, in game, restarted windows, but vsync still messed up. Had to do a system restore to before when the game was installed, reinstalled, did not mess with anything, and now game runs fine again, perfect 60 fps with in-game vsync enabled.

    What was the cause to making vsync unstable and how to undo it if I try to mess around with settings again (i still want to try and get AA to work) without having to resort to a system restore?

    P.S: I know about triple buffering, it is enabled by default from radeonpro as a global setting, and it works fine, it's just when I start messing around with settings that things get weird.
     
    Last edited: Jun 28, 2012
  2. teleguy

    teleguy Maha Guru

    Messages:
    1,359
    Likes Received:
    213
    GPU:
    GTX 1070/Vega 56
    You probably enabled something that increased the workload on the gpu so it could no longer maintain 60 fps.
     
  3. lume

    lume New Member

    Messages:
    1
    Likes Received:
    0
    GPU:
    Radeon HD 6870 1Gb
    Or instead you could just delete the spec ops folder from my games folder located in your documents. Resets the settings to the default.
     
  4. brutlern

    brutlern Master Guru

    Messages:
    290
    Likes Received:
    0
    GPU:
    Gigabyte 1070 X Gaming
    The problem is I did not change anything in the game, all the settings were the same as when it runs perfectly, and even after removing the custom profile from radeonpro, aka putting back everything as it was before, the problem would not go away. Right now the game runs perfect @ 60, all maxed out, with radeonpro's triple buffering enabled globally in the background, i'm just afraid to make a custom profile, and mess the whole thing up again.
     

  5. Darren Hodgson

    Darren Hodgson Ancient Guru

    Messages:
    16,070
    Likes Received:
    583
    GPU:
    EVGA GTX 1080 Ti SC2
    For AA, you can use an FXAA or, better still, SMAA Injector to give the game a far less jaggy look. I used the latter in the demo and it seemed to work very well. Didn't like the demo though so never bothered buying the game.

    It is very poor though that a 2012 PC games release doesn't at least have native FXAA support. It should be mandatory IMO. LEGO Batman 2 is an example of another game with extremely weak AA support. The edge-detect FSAA the game supports is barely effective and at least half a decade out of date!!!
     
  6. brutlern

    brutlern Master Guru

    Messages:
    290
    Likes Received:
    0
    GPU:
    Gigabyte 1070 X Gaming
    So, some more testing, and more weird things. Played the game again and the vsync thing came back, though I did not touch any settings. Quit the game, deleted the setting files like lume suggested, and now the game runs perfectly again. So whatever is going on, it has something to do with the game. Unfortunately, all the .ini files are encoded, so I can't mess around in them to figure out what's going on.

    I forgot about SMAA, have it stashed away somewhere in my misc stuff, used it on NFS Hot Pursuit before, going to try it as soon as I can figure out what keeps messing up the vsync.
     
  7. teleguy

    teleguy Maha Guru

    Messages:
    1,359
    Likes Received:
    213
    GPU:
    GTX 1070/Vega 56
  8. brutlern

    brutlern Master Guru

    Messages:
    290
    Likes Received:
    0
    GPU:
    Gigabyte 1070 X Gaming
    Right now, I dont care about AA, I just want to fix the vsync issue.
     
  9. Anarion

    Anarion Ancient Guru

    Messages:
    13,605
    Likes Received:
    383
    GPU:
    GeForce RTX 3060 Ti
    Use D3DOverrider and force triple buffering and v-sync, disable in game v-sync.
     
  10. brutlern

    brutlern Master Guru

    Messages:
    290
    Likes Received:
    0
    GPU:
    Gigabyte 1070 X Gaming
    Triple buffering is already on with radeonpro and it works fine if i start the game without the SREngine.ini. There is something messed up about that ini file. When the game creates it fresh, the game works, however after the file is created some settings are messed up, and next time I start the game with the SREngine.ini already there I get the wonky vsync. My guess is some settings get set at beyond default values causing massive fps hit. But I cant check the contents of the file, as it is encoded (the demo .ini's were fine oddly enough). Right now the only solution is to delete the SREngine.ini every time before I start the game. Does anyone know how to decode these files?

    P.S: just found the same temporary solution on the steam forums http://forums.steampowered.com/forums/showthread.php?p=31383439
    Guess I'm not the only one with this bug.
     
    Last edited: Jun 28, 2012

  11. teleguy

    teleguy Maha Guru

    Messages:
    1,359
    Likes Received:
    213
    GPU:
    GTX 1070/Vega 56
  12. brutlern

    brutlern Master Guru

    Messages:
    290
    Likes Received:
    0
    GPU:
    Gigabyte 1070 X Gaming
  13. teleguy

    teleguy Maha Guru

    Messages:
    1,359
    Likes Received:
    213
    GPU:
    GTX 1070/Vega 56
    He said Rick Gibbed decrypted the files.
     
  14. JonasBeckman

    JonasBeckman Ancient Guru

    Messages:
    17,523
    Likes Received:
    2,921
    GPU:
    MSI 6800 "Vanilla"
  15. hirmak

    hirmak Master Guru

    Messages:
    321
    Likes Received:
    0
    GPU:
    GTX285
    This game has one of the best endings in a game.I'm really impressed:backfire:
     

  16. brutlern

    brutlern Master Guru

    Messages:
    290
    Likes Received:
    0
    GPU:
    Gigabyte 1070 X Gaming
  17. brutlern

    brutlern Master Guru

    Messages:
    290
    Likes Received:
    0
    GPU:
    Gigabyte 1070 X Gaming
    I was disappointed that the "choices" you made dont change anything. And in most places there is only the illusion of choice (eg: you cannot not use the white phosphorus, I tried, I died :p)
     
  18. Year

    Year Ancient Guru

    Messages:
    11,594
    Likes Received:
    1
    GPU:
    EVGA GTX 690
    had the same 30fps problem, fixed it by setting the nvidia power option from Adaptive to Maximum Performance, it never happened again.

    unfortunately you got an ATI card, not sure if you got a similar option in your ati control panel.
     

Share This Page