Source Games main menus too bright - GTX 480 + 280.26 drivers

Discussion in 'Videocards - NVIDIA GeForce Drivers Section' started by Pedroshin, Sep 7, 2011.

  1. Pedroshin

    Pedroshin Active Member

    Messages:
    94
    Likes Received:
    0
    GPU:
    EVGA GTX 680 SC
    TF2, DoD & CSS main menus too bright - GTX 480 + 280.26 drivers

    So I just recently got a GTX 480 to replace my GTX 295 and installed the latest drivers, 280.26, along with it (after cleaning previous drivers the proper way of course).

    I have a slight problem though, Source game menus are too bright. Curiously though when I get in a server to play or anything 3D is running it goes back to normal, but as soon as I exit the server the blinding brightness is back...

    Is this a bug with the 400 series or has it started with these drivers?

    Because I remember using the 260.xx or 267.xx drivers with my GTX 295 and not having this problem.

    Examples from other users that complained of the same some months ago:
    Ok: http://i.imgur.com/q2uqW.jpg (this is how my game looked on my GTX 295 + older drivers)
    Too bright: http://i.imgur.com/YpBZd.jpg (this is how it looks now with GTX 480 + 280.26)

    Source Game main menus are too bright.

    Adjusting gamma doesn't help.
     
    Last edited: Sep 10, 2011
  2. dr_rus

    dr_rus Ancient Guru

    Messages:
    3,191
    Likes Received:
    509
    GPU:
    RTX 3080
    See if you have CSAA "enchanced" via NV control panel or chosen in the game settings. There was a bug with gamma levels with CSAA and NV tried to fix it by forcing higher than normal gamma levels by driver.
     
  3. Pedroshin

    Pedroshin Active Member

    Messages:
    94
    Likes Received:
    0
    GPU:
    EVGA GTX 680 SC
    Thanks, but I have AA set to "Controlled by application" and in-game it's 4x MSAA.

    Also tried setting "Color definitions" to be "controlled by Nvidia", but it made no difference.

    Does a previous or newer driver not have this problem?

    EDIT: Noticed this doesn't happen if I run in DirectX 8 mode. Thoughts? dxwebsetup says I already have latest DirectX.

    Also Half-Life 2 menus that have 3D backgrounds don't suffer from this.
     
    Last edited: Sep 7, 2011
  4. ESlik

    ESlik Ancient Guru

    Messages:
    2,415
    Likes Received:
    24
    GPU:
    EVGA x2 1080 Ti SC Black
    It's a driver issue. I can't set and keep color settings from the Nvidia control with ANY of the newer drivers. Nvidia is aware of this, and from what I have read, it will be fixed in the next driver release. Any day now.
     

  5. ESlik

    ESlik Ancient Guru

    Messages:
    2,415
    Likes Received:
    24
    GPU:
    EVGA x2 1080 Ti SC Black
    It's a driver issue. I can't set and keep color settings from the Nvidia control with ANY of the newer drivers. Nvidia is aware of this, and from what I have read, it will be fixed in the next driver release. Any day now.
     
  6. Pedroshin

    Pedroshin Active Member

    Messages:
    94
    Likes Received:
    0
    GPU:
    EVGA GTX 680 SC
    Sure you're talking about the same thing? Because I never really set/changed color settings from Nvidia control panel before. I just tested to see if it helped with this problem that only happens on Valve/Source Engine games.

    If it's the same thing, or at least related, I really hope they do fix it soon.

    Might be interesting to note it doesn't happen if I run with DirectX 8 by using -dxlevel 80 in launch options.
     
  7. nikavelli

    nikavelli Master Guru

    Messages:
    426
    Likes Received:
    0
    GPU:
    GTX 780 Ti
    Source engine games have always had screwy issues with video settings, especially gamma.

    I've had gamma issues in the past. Usually when I update drivers or get a new video card. This is the procedure I use to fix it, it involves completely resetting your config and graphics settings:

    Go into your source engine game's folder, make a copy of your config.cfg and autoexec.cfg files. Move those copies to another folder, than delete your original config.cfg and autoexec.cfg files.

    Go into your source engine game's launch options and type: -autoconfig

    Launch your game.

    Close your game.

    Remove -autoconfig from your source engine game's launch options.

    Launch your game.

    That should fix it. If it doesn't, just move the copies of your configs you made earlier back into your source engine game's folder so you don't have to re-do your binds and stuff.

    Don't ask me why this works, it just does (for me).
     
  8. PurSpyk!!

    PurSpyk!! Master Guru

    Messages:
    700
    Likes Received:
    21
    GPU:
    GTX 1080Ti X Sli
    Hi, its got nothing to do with any configuration files. The light screens appear when the game is loading and it only affects the loading screens, the game menu, and game are fine. The odd thing is I only have this in the HL2 games, none of the other source games. There is also an ambient occlusion bug as well in HL2, which might be related, the screen will flicker when moving the mouse, changes between bright and normal. This seems to only affect 4xx and higher cards. I never had this issue with my GTX 260 with same drivers.
     
    Last edited: Sep 8, 2011
  9. Pedroshin

    Pedroshin Active Member

    Messages:
    94
    Likes Received:
    0
    GPU:
    EVGA GTX 680 SC
    Thanks, but unfortunately that didn't work for me...

    It only affects the loading screens for you or the game menu as well?

    Because for me it doesn't happen in the first loading screen when you open the game, but it happens when it finishes loading. Doesn't happen if the menu has a 3D background like HL2 or Portal.

    So TF2, DoD and CSS menu all have the same problem in menu, except when I get into or start a server, as long as there's some 3D in the background there are no problems.
     
    Last edited: Sep 8, 2011
  10. PurSpyk!!

    PurSpyk!! Master Guru

    Messages:
    700
    Likes Received:
    21
    GPU:
    GTX 1080Ti X Sli
    Hi, I only have it on the loading screens, in all the HL2 games, and Portal. No issues in any of the other source games, and this has only started since I got the GTX 470.
     

  11. nikavelli

    nikavelli Master Guru

    Messages:
    426
    Likes Received:
    0
    GPU:
    GTX 780 Ti
    I apologize, I forgot one critical step. If you have Steam cloud sync enabled for your game, and you delete your config, it will simply copy your config and graphics settings over that you previously had, rendering the whole procedure I listed pointless.

    I'd recommend giving it another shot, but disabling Steam Cloud syncronization first. Launch your game, go into your multiplayer tab, and uncheck "sync with Steam cloud". Alternatively, you can navigate to your library, right-click your game > properties > and disable Steam cloud syncronization from there. I'd recommend doing both. As an extra step, you can also completely disable Steam Cloud syncronization all-together by going to your Steam properties. You can always re-enable Steam Cloud syncing later on.

    Then, repeat the steps I listed from step one.
     
  12. Pedroshin

    Pedroshin Active Member

    Messages:
    94
    Likes Received:
    0
    GPU:
    EVGA GTX 680 SC
    Thanks again, but doing that didn't help either :/
     
  13. Pedroshin

    Pedroshin Active Member

    Messages:
    94
    Likes Received:
    0
    GPU:
    EVGA GTX 680 SC
    By the way that almost seems like the inverse of what's happening with me on Source games that aren't HL2 or Portal (such as DoD, CSS and TF2):

    When game is loading the brightness is fine (like in Darmvlinder's case here)

    After loading finishes it goes up.

    In HL2 and Portal it does affect the loading screens, but not when it finishes loading, as something 3D being drawn stops the brightness from bugging out.
     

Share This Page