Sound BlasterX AE-5

Discussion in 'Soundcards, Speakers HiFI & File formats' started by angelgraves13, Jun 12, 2017.

  1. Astyanax

    Astyanax Ancient Guru

    Messages:
    9,171
    Likes Received:
    3,140
    GPU:
    GTX 1080ti
    did you install the asus provided realtek driver?

    if you have 8746, get rid of it, install either the latest from the microsoft catalog or the previous driver.
     
  2. Kol12

    Kol12 Active Member

    Messages:
    59
    Likes Received:
    0
    GPU:
    EVGA 2080 Ti FTW3
    No, I clean installed Win 10 1909 just a couple of weekends ago and have not installed any Realtek drivers. I have the on board audio disabled in the BIOS and that appears to have prevented Windows update from installing any Realtek sound drivers. So it's really just the Sound Blaster X-AE5 drivers and the Nvidia HD audio as audio sources... Windows update will always try to install a Creative driver as soon as it detects the X-AE5. I've had trouble installing the official Creative ones due to the MS ones force-ably reinstalling themselves...
     
  3. Astyanax

    Astyanax Ancient Guru

    Messages:
    9,171
    Likes Received:
    3,140
    GPU:
    GTX 1080ti
  4. Kol12

    Kol12 Active Member

    Messages:
    59
    Likes Received:
    0
    GPU:
    EVGA 2080 Ti FTW3

  5. Matroxxest

    Matroxxest New Member

    Messages:
    1
    Likes Received:
    0
    GPU:
    GTX1080
    Having the exact same problem(s) with Asus z390F and Sound Blaster AE5. I havent tried personally but switching sound card to first two pci-e slots (cpu controller) might be worth a try.
     
  6. Tweedilderp

    Tweedilderp New Member

    Messages:
    2
    Likes Received:
    0
    GPU:
    MSI RTX 2080 Ti
    So I was having issues in movies as well as youtube music playlists. The audio would suddenly switch between center and sub so I effectively got no vocals. This I believe, is due to a windows 10 update but the updates are required for my 3900X to function properly with the new chipset driver.

    I tried many things including signing in to the creative connect 2 app which produced no fix. I did see a fix on another forum where if you set windows to just stereo and let the AE-5 do all the processing which seemed to work, but games like battlefield 5 etc... the surround was non-existent if I wanted to turn off acoustic engine for a pure sound. This was not acceptable (although my music/movie playback was fixed with that method) so I decided to dive into the user/appdata/local/temp folder to the creative connect 2 log file.

    I think I found my problem as I found this error in the log which coincided with every boot when the software would start:

    2019-12-03 09:56:36,324 [1] WARN (Creative.SBConnect.AE5.ViewModels.Setup.SpeakerConfigViewModel:0) - Exception occurred when loading headphone eq files, exception is System.IO.DirectoryNotFoundException: Could not find a part of the path 'C:\Program Files (x86)\Creative\Sound Blaster Connect 2\Product\AE5\SpeakerEqConfigs'.

    I decided to track down the folder, it didn't exist so I ended up creating a new one with the exact name and have now set windows to 5.1 with full range on all my speakers (they're decent yamaha bookshelf speakers I use for front and surrounds). So far no issues and am leaving my 10-hour long playlist going to see if it reverts back to it's on troublesome ways. Usually it kicks in after an hour or 2 or sometimes several hours. So far on the 1 hour mark no channel switching so that's good.

    Also for the crackling and popping after the windows update I decided to right-click sound>open sound settings>scroll down to sound control panel>set speakers as default>properties>advanced>switched the bit and sample a few times then switch to my receivers setting of 24-bit 96Khz. That resolved my snap-crackle-'n pop. Hope this troubleshooting helps anyone who has been having the same issues with a 5.1 analog output issue like I have had.
     
  7. Tweedilderp

    Tweedilderp New Member

    Messages:
    2
    Likes Received:
    0
    GPU:
    MSI RTX 2080 Ti
    Granted its a headphone eq file and my system is a receiver + passive bookshelves and dedicated 200W sub but I am rounding it to a combination of creative software and windows updates and doing the fix is working so far. I will post if it was fruitless in the end.

    Also note that I have the LTE bass reduction slider on with the custom and 5.1 settings in the connect 2 software. I have the crossover set to 80hz.

    Update:

    Seems the channel flipping has not been fixed, will have to revert to leaving the windows setting at stereo as windows is doing some kind of polling when in 5.1. I will have to leave it at stereo and let creative do all the surround processing for the channels with the acoustic engine. This is quite frustrating!. I have not tried commander yet because people were saying it had less customization, is this channel flipping an issue for anyone on 5.1 analog on commander?
     
    Last edited: Mar 10, 2020
  8. Eastcoasthandle

    Eastcoasthandle Ancient Guru

    Messages:
    2,757
    Likes Received:
    441
    GPU:
    Nitro 5700 XT
    If I recall correctly you can mitigate this by enabling spectrum services found within the bios. For example PCIe Spectrum, etc.
     
  9. kosta20071

    kosta20071 Member Guru

    Messages:
    115
    Likes Received:
    82
    GPU:
    Gigabyte RTX 3080
    New Software\Driver released on Creative's website! (can't paste text cause of Edge bug so here is a pic). Aurora Lighting support is finally added

    [​IMG]
     
    OnnA and Apparatus like this.
  10. lukiboss

    lukiboss Member

    Messages:
    14
    Likes Received:
    0
    GPU:
    3650 mobility
    They showed the ae-5 PLUS version with dts connect/encoders/etc Is it possible to install PLUS version drivers to normal AE-5? I really want to try 5.1 optical sound
     

  11. kosta20071

    kosta20071 Member Guru

    Messages:
    115
    Likes Received:
    82
    GPU:
    Gigabyte RTX 3080
    Its the same driver but you won't get Plus features because the driver will recognize your regular AE-5 and install the regular version features.

    I am not sure that even with a driver hack\tweak it is possible to activate 5.1 optical sound because it depends also on the hardware and not only the software
     
  12. moab600

    moab600 Ancient Guru

    Messages:
    6,263
    Likes Received:
    187
    GPU:
    1080TI Gaming editi
  13. lukiboss

    lukiboss Member

    Messages:
    14
    Likes Received:
    0
    GPU:
    3650 mobility
    :( Thats sad...
    I remember old times when you could activate 5.1 optical sound on X-fi 5.1 pro surround which doesnt support it at stock maybe some day someone will do that to ae-5 too
     
  14. kosta20071

    kosta20071 Member Guru

    Messages:
    115
    Likes Received:
    82
    GPU:
    Gigabyte RTX 3080
    New Update via SBC update : 3.4.72.01

    What's New:

    • Fix App crash when sign in Super X-Fi
     
    Last edited: Apr 25, 2020
    eGGroLLiO likes this.
  15. lenix

    lenix Master Guru

    Messages:
    309
    Likes Received:
    0
    GPU:
    EVGA 1080 Ti FTW3
    On latest driver, after updating to Windows 10 2004 I experience lag when changing the volume and it's very irritating. If anyone knows a solution please let us know.
     

  16. lenix

    lenix Master Guru

    Messages:
    309
    Likes Received:
    0
    GPU:
    EVGA 1080 Ti FTW3
    What do you mean by a 450 driver? Please explain because this problem really sucks.
     
  17. lenix

    lenix Master Guru

    Messages:
    309
    Likes Received:
    0
    GPU:
    EVGA 1080 Ti FTW3
    I'm already using the latest driver and many people on Windows 10 2004 are facing the problem of volume lag with latest driver.
     
  18. Sorry lenix I honestly don't know off the top of my head any of the usual things work so far?
    • cleaning out all traces of driver software/reinstalling from scratch
    • trying some of the older copies of the drivers/possibly the original one?
    • personally I don't know what @Astyanax is referring to although I'm sure it will help
    • https://www.reddit.com/r/SoundBlast...why_is_windows_volume_control_lagging_on_ae5/ from u/Geahad "Try downloading ISLC, running it, setting a timer to a 1 ms resolution, and then starting the programs service. There's actually no downside to having the timer at a higher resolution all the time, except for potentially a couple percent higher power bill."


     
    Last edited by a moderator: Jun 8, 2020
  19. Astyanax

    Astyanax Ancient Guru

    Messages:
    9,171
    Likes Received:
    3,140
    GPU:
    GTX 1080ti

Share This Page