Sound Blaster Z / Zx / ZxR Modded Driver for Windows 10

Discussion in 'Soundcards, Speakers HiFI & File formats' started by REGENERATI0N, Jun 29, 2020.

  1. REGENERATI0N

    REGENERATI0N Master Guru

    Messages:
    511
    Likes Received:
    9
    GPU:
    N/A
    In Windows 10 build 1803, Microsoft made some kernel changes related to hardware timers that broke a lot of device drivers and caused high latency on many systems. Ever since then, Sound Blaster Z / Zx / ZxR series are plagued with issues such as audio stuttering, crackling, popping, and sudden channel swapping.

    It's been 2 years and Creative Labs hasn't done enough to fix these issues. And therefore, the old house of ngohq.com is proud to introduce a modified driver based on the official software release from September 2019 and unofficial driver release from May 2020. This release is intended to solve issues and will not bring any new features.

    Instructions:
    Temporarily disable driver signature enforcement (hold down the SHIFT key while you click on the Restart button in the start menu, select Troubleshoot, Advanced options, Startup Settings, press on the Restart button, wait for the Startup Settings screen to appear and then press on 7), extract the SFX anywhere you want, and then run setup.exe as administrator.

    Changes (v0.2):
    * Updated driver to version 6.0.102.62.

    Downloads:
    Sound Blaster Z / Zx Modded Driver for Windows 10 | Mirror #1 | Mirror #2
    Sound Blaster ZxR Modded Driver for Windows 10 | Mirror #1 | Mirror #2
     
    Last edited: Jul 24, 2020
    Blackfyre, x-speed69, K.S. and 2 others like this.
  2. 0blivious

    0blivious Ancient Guru

    Messages:
    2,920
    Likes Received:
    439
    GPU:
    5700XT/ 1070/ RX580
    Channel swapping! That's what I came here to complain about on my SBZ (and it sounds like crap). It was fine until I put the card in a new build this week. Old/new drivers, doesn't matter. Thank you for posting this.


    [edit] ..... THIS DRIVER WORKS.

    No more channel swapping, no more tinny sound. SBZ Control Panel and everything else seems to be working fine again. I almost had to go with the onboard sound for awhile. (shudders)

    I owe you a drink, sir.
     
    Last edited: Jun 30, 2020
    cryohellinc likes this.
  3. Only Intruder

    Only Intruder Maha Guru

    Messages:
    1,281
    Likes Received:
    220
    GPU:
    Sapphire Fury Nitro
    cryohellinc likes this.
  4. cryohellinc

    cryohellinc Ancient Guru

    Messages:
    3,290
    Likes Received:
    2,563
    GPU:
    RX 5700 XT/GTX 1060
    Giving this a go ASAP. Even thou I have managed to fix my issue (temporarily), I will give this a go ASAP.

    Thank you for giving me a heads-up buddy. Much appreciated!
     
    Only Intruder likes this.

  5. cryohellinc

    cryohellinc Ancient Guru

    Messages:
    3,290
    Likes Received:
    2,563
    GPU:
    RX 5700 XT/GTX 1060
    Well, the installer says it can't detect supported product on my system. Running ZxR here, any clues?

    + fully followed the install process.
     
    Last edited: Jun 30, 2020
  6. REGENERATI0N

    REGENERATI0N Master Guru

    Messages:
    511
    Likes Received:
    9
    GPU:
    N/A
    Updated the 1st post with links for ZxR.
     
    Keitosha and cryohellinc like this.
  7. 0blivious

    0blivious Ancient Guru

    Messages:
    2,920
    Likes Received:
    439
    GPU:
    5700XT/ 1070/ RX580
    Spoke a little too soon. I still have some channel switching, just less often. But the sound clarity is fixed using this driver.

    Maybe I'll try using 2.1 and see how that goes.
     
  8. cryohellinc

    cryohellinc Ancient Guru

    Messages:
    3,290
    Likes Received:
    2,563
    GPU:
    RX 5700 XT/GTX 1060
    Cheers, will give it a go and provide feedback as soon as possible.
     
  9. fernake

    fernake Master Guru

    Messages:
    211
    Likes Received:
    13
    GPU:
    Asus strix GTX 1080 OC
    Hello, do you have to install the modified drivers on top of the official ones or do you have to uninstall the official drivers first? Thanks for your help.
     
  10. 0blivious

    0blivious Ancient Guru

    Messages:
    2,920
    Likes Received:
    439
    GPU:
    5700XT/ 1070/ RX580
    I uninstalled mine 1st. Not sure if it's required to uninstall, but this driver is a complete package.
     
    fernake likes this.

  11. REGENERATI0N

    REGENERATI0N Master Guru

    Messages:
    511
    Likes Received:
    9
    GPU:
    N/A
    Windows has a problem changing active protected device drivers. It is always recommended to uninstall the current drivers first.
     
    fernake likes this.
  12. REGENERATI0N

    REGENERATI0N Master Guru

    Messages:
    511
    Likes Received:
    9
    GPU:
    N/A
    What speaker config do you have and which channel is switching?
     
  13. cryohellinc

    cryohellinc Ancient Guru

    Messages:
    3,290
    Likes Received:
    2,563
    GPU:
    RX 5700 XT/GTX 1060
    @REGENERATI0N
    First of all - thank you for your effort.

    I have successfully installed the ZxR driver and extensively tested it: Audio works great on max quality - there are no channel swaps. Extensively tested this with music/movies.

    However, Warhammer 2 - once I load into the game, it crashed through a black screen. haven't noticed that anywhere else. Reinstalled the standard driver, everything works fine. Any ideas?
     
  14. REGENERATI0N

    REGENERATI0N Master Guru

    Messages:
    511
    Likes Received:
    9
    GPU:
    N/A
    Try to reset the game's user config files. Make sure automatic driver update in Windows 10 is disabled.
     
  15. cryohellinc

    cryohellinc Ancient Guru

    Messages:
    3,290
    Likes Received:
    2,563
    GPU:
    RX 5700 XT/GTX 1060
    Already tried that, the issue persists. Other games work just fine, really odd.
     

  16. REGENERATI0N

    REGENERATI0N Master Guru

    Messages:
    511
    Likes Received:
    9
    GPU:
    N/A
    Some anti-cheat software don't like unsigned drivers.
     
  17. 0blivious

    0blivious Ancient Guru

    Messages:
    2,920
    Likes Received:
    439
    GPU:
    5700XT/ 1070/ RX580
    I'm running 5.1 config through the orange/black/green 3.5mm wires into a Logitech z906 surround set.

    I'm not even sure if it's channel switching or channel "deletion" It's usually a problem while gaming, the front channel switches to the rears (it seems). (Ghost Recon Wildlands, Battlefield, etc) Other times, all spoken dialogue just goes silent but other game sound remains. (even spinning 360 degrees, voices are silent.). (Assassin's Creed Origins, etc) Sometimes, during movies/videos, I notice the center channel (or more) is missing.

    And once in awhile, it seems that left and right get swapped. It's hard to even describe because I can't even tell what's going on other than something is wrong with my sound. No crackling or hissing. The overall "tinny" sound that the Creative drivers were giving me, that is fixed with this modified driver.

    I haven't tried using the optical connection yet but I figured it should make no difference. I'm about to start using onboard as these sound issues are making things unplayable and unwatchable. I don't know what my onboard sounds like (and I don't want to know).
     
    Last edited: Jul 4, 2020
  18. REGENERATI0N

    REGENERATI0N Master Guru

    Messages:
    511
    Likes Received:
    9
    GPU:
    N/A
    Run regedit.exe, search for "CalibDelay", and change all entries (CSubLR, RearLR) to 0.
     
  19. 0blivious

    0blivious Ancient Guru

    Messages:
    2,920
    Likes Received:
    439
    GPU:
    5700XT/ 1070/ RX580
    I found 4 instances of those items in the registry. All set to 0 now.

    Appreciate the insight and the driver. Crossing fingers.
     
  20. 0blivious

    0blivious Ancient Guru

    Messages:
    2,920
    Likes Received:
    439
    GPU:
    5700XT/ 1070/ RX580
    Still having channel swapping. Considering my old PC is on the exact same windows build and the card works fine in that, I started questioning my new build. I can put it back in my old PC to confirm, but I also found this:

    MSI Forum post: Sound Blaster Z has weird behaviour after updating BIOS X570 Gaming Edge Wifi

    There is a fair amount of discussion regarding X570 motherboards being the culprit with the Soundblaster Z series, channel swapping, some say specifically after certain bios updates. I have an Asus STRIX x570 wifi board.

    I'm not interested in rolling back my bios. At this point, I'm closer to just buying a new brand sound card. But only after making sure the same issues don't exist.
     

Share This Page