1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Sound Blaster Z and 1809 upgrade

Discussion in 'Operating Systems' started by Morpheous416, Oct 4, 2018.

  1. zimzoid

    zimzoid Maha Guru

    Messages:
    1,433
    Likes Received:
    23
    GPU:
    2xEVGA980TiSC+(H20) Swift
    My X-Fi titanium works fine too, the best of the creative cards in my opinion, had a Z but had issues, went back to the titanium and all good.
     
    Last edited: Oct 7, 2018
  2. Dj_ALeX

    Dj_ALeX Master Guru

    Messages:
    207
    Likes Received:
    76
    GPU:
    G1 GTX 980 OC
    It is not the best. The new AE-5 has a Sabre DAC which is miles away from anything that creative has produced in the past.
     
    Last edited: Oct 7, 2018
    Blackfyre likes this.
  3. dr_rus

    dr_rus Ancient Guru

    Messages:
    2,980
    Likes Received:
    322
    GPU:
    RTX 2080 OC
    Eh, well, I guess you can say that it works but between weird driver installation and 1809 resetting sound output to stereo all the time it's not "fine".
     
  4. bobmitch

    bobmitch Master Guru

    Messages:
    410
    Likes Received:
    20
    GPU:
    EVGA RTX 2080 TI XC
    After reading this thread....I checked mine. Still on 5.1 and drivers are still Creative's last. Only issue I found was that it reset all my speaker settings and defaulted to no EQ. However, I did save a profile and reactivated it and all the settings came back immediately.
     

  5. Astyanax

    Astyanax Ancient Guru

    Messages:
    3,279
    Likes Received:
    850
    GPU:
    GTX 1080ti
    in the future, this is usually resolved by cleaning off the downgrade files since it mucks up file linkage.
     
  6. AnimeDan

    AnimeDan New Member

    Messages:
    1
    Likes Received:
    1
    GPU:
    ATI Radeon HD 6970 / 2GB
    i have the AE-5 and it seems to have broke that as well i got that update a week ago not having read about it cause it just installed the update by it self, i tried uninstalling both voicemeeter and the drivers for creative and installing just the drivers i still get the issue

    thoue i also get the issue where soundblast connect 2 dosent detect my card but that is usually fixed by restarting the windows audio endpoint builder service
     
    warlord likes this.
  7. warlord

    warlord Ancient Guru

    Messages:
    2,367
    Likes Received:
    777
    GPU:
    Null
    Thank God I was ready to break my card with a hammer and put the stripe leds of pure edition to my Christmas tree.

    I have the same problem and I use Realtek audio and gpu hdmi for my needs until is fixed. Either Microsoft broke something or creative should update drivers. Please report to both Microsoft and creative that problem I will do the same tomorrow morning.
     
  8. Dr_McNinja

    Dr_McNinja New Member

    Messages:
    1
    Likes Received:
    0
    GPU:
    GTX 1080
    Just got auto updated to 1809 and now the mic/line-in port for my Sound Blaster Z doesn't work anymore.

    Omni Surround 5.1 (USB sound card) still works though
     
  9. yosef019

    yosef019 Ancient Guru

    Messages:
    2,113
    Likes Received:
    3
    GPU:
    EVGA 1080 ti
    i have same problem with asus new orrange card if i use optical out i can use only stereo since then i use analog...
    my old recon 3d fatality was finewith spdif
     
  10. Morpheous416

    Morpheous416 Ancient Guru

    Messages:
    3,581
    Likes Received:
    2
    GPU:
    Geforce GT 750 Ti
    Try my previous work around. Remove all drivers. Restart system. Let Windows install the default driver, then install the SB drivers on top. Use the Windows sound settings to set it to 5.1, just don't use the SB software to switch to 5.1 for now. Leave it as is.
     

  11. Glidefan

    Glidefan Don Booze Staff Member

    Messages:
    12,491
    Likes Received:
    41
    GPU:
    GTX 1070 | 8600M GS
    Seriously, this happens every time there is a big Win10 upgrade.
    I simply have the latest SBZ driver package from Creative stored on my hard drive, and just install it over.
    Because MS keeps installing a newer driver from windows update, but that driver simply doesn't work.
    Speakers are borged otherwise.

    I just stopped caring or trying to investigate further and just install them over.
     
  12. GREGIX

    GREGIX Master Guru

    Messages:
    538
    Likes Received:
    46
    GPU:
    MSI 1080 /AMD v7
    Disable automatic driver update trough gpedit.msc or regedit. There are tutorials on yt, or just google it...
     
  13. zimzoid

    zimzoid Maha Guru

    Messages:
    1,433
    Likes Received:
    23
    GPU:
    2xEVGA980TiSC+(H20) Swift
    Yep my X-Fi titanium still not working but working fine in an earlier version
     
  14. Glidefan

    Glidefan Don Booze Staff Member

    Messages:
    12,491
    Likes Received:
    41
    GPU:
    GTX 1070 | 8600M GS
    I did, but it seems that it restores that when i'm updating.
     
  15. GREGIX

    GREGIX Master Guru

    Messages:
    538
    Likes Received:
    46
    GPU:
    MSI 1080 /AMD v7
    ah, yea, there are ppl that updates os no matter what updates brings/brokes.
    If there is not something crucial, I leave WU completely disabled, and if need arises, I do only manual update using WUMT.
    AND then DISABLE IT again.
    w10 is like malware, if u let it install updates itself, then it is your fault that something went wrong as u do not know what it "fixes" or brakes in many cases...
    Anyway, do not see reason to update w10 unless for RTX gimmix now.
    In fact, just returned to w7 as is far more stable and, surprise surprise, games runs faster and more stable on it.
    I just use common sense and Comodo Firewall as threat barrier and it works well.
    DX12 is crap(crap implementation in 8/10 cases) and brings FPS down almost all time. Esp on GTX 1080. Hell, there are some games that have dx12 but it crashes or other problems arise...
    Wish to have more games on Vulkan...
     

  16. Glidefan

    Glidefan Don Booze Staff Member

    Messages:
    12,491
    Likes Received:
    41
    GPU:
    GTX 1070 | 8600M GS
    I know what you mean. I'm like "wait to see if there are any reports of stuff broken."
    And after 5 mins of waiting there's a little voice in my head "The version number is hiiiigher.... doooo it... you know how to fix iiiiit."
     
  17. Watcher

    Watcher Ancient Guru

    Messages:
    2,529
    Likes Received:
    173
    GPU:
    Gigabyte Windforce R9 380
    Not sure exactly which Creative Sound Card you have but Creative updated the drivers for the following Cards on March 11 / 2019

    Creative Sound Blaster Drivers X-Fi Titanium is the latest drivers for all Creative Sound Blaster X-Fi Titanium cards from Creative for Windows 10.

    Sound Blaster X-Fi Titanium (SB0880)
    Sound Blaster X-Fi Titanium OEM (SB0881)
    Sound Blaster X-Fi Titanium OEM (SB0883)
    Sound Blaster X-Fi Titanium OEM (SB0887)
    Sound Blaster X-Fi Titanium OEM (SB0889)
    Sound Blaster X-Fi Titanium Fatal1ty Champion Series (SB0886)
    Sound Blaster X-Fi Titanium Professional Fatal1ty Series (SB0886)
    Sound Blaster X-Fi Professional Audio Titanium (SB0888)

    You may download the drivers from Majorgeeks:
    https://www.majorgeeks.com/files/details/creative_sound_blaster_x_fi_titanium_drivers.html

    Just looked at the Thread Subject line, it indicates your model as the Sound Blaster Z

    It's odd that the drivers would not be updated since they are still selling the card in a speaker bundle.

    https://us.creative.com/p/bundled-offers/sound-blaster-z-t6300-gaming-pack

    Other special by Creative can be found here:
    https://us.creative.com/sale/
     
    Last edited: Mar 12, 2019
  18. Athlonite

    Athlonite Maha Guru

    Messages:
    1,276
    Likes Received:
    27
    GPU:
    Nitro+RX580 8GB OC
    For those of you having problems with your X-Fi under win10 1809 I suggest you use the Daniel Kawakami 4.0 pack

    for those on SB Z cards give creative some time they've just done an update for X-Fi owners so probably shouldn't be to far away for Z owners either
     
  19. zimzoid

    zimzoid Maha Guru

    Messages:
    1,433
    Likes Received:
    23
    GPU:
    2xEVGA980TiSC+(H20) Swift
    I got the new driver for my titanium a few weeks back and all is well again on the latest insider build
     
  20. zimzoid

    zimzoid Maha Guru

    Messages:
    1,433
    Likes Received:
    23
    GPU:
    2xEVGA980TiSC+(H20) Swift
    Weird just looked at creative site and the new driver is gone?
     

Share This Page