1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Something i want to share for gtx maxwell-old games

Discussion in 'Videocards - NVIDIA GeForce Drivers Section' started by boombastik, May 12, 2016.

  1. MrBonk

    MrBonk Ancient Guru

    Messages:
    2,908
    Likes Received:
    51
    GPU:
    MSI RTX 2080
    I haven't had this problem with CSGO with my bios modded 980.
    I can hit 180FPS with 4xMSAA at 900p without issue. I do become CPU limited if I try very very high framerates however.
     
  2. adrock311

    adrock311 Master Guru

    Messages:
    793
    Likes Received:
    0
    GPU:
    EVGA GTX 1070 SC 8gb
    Boombastik: Thank you so much for this, I had my gigabyte GA-Z68X-UD3H-B3 with i5 2500k and GTX 670 SLI setup set at 64 bit HPET in bios, and I couldn't figure out why random read/writes on my SSD were slower than ever. Thanks to your thread, I set it to 32bit HPET in bios and games feel much smoother too. thanks!
     
  3. DummyPLUG

    DummyPLUG Member Guru

    Messages:
    131
    Likes Received:
    0
    GPU:
    Titan X
    HPET is quite outdated and new cpu come with Invariant TSC (intel) which is way better, AMD have something similar.
    In shot, windows/driver/program select anything they think it is the best for you, except some HPET implement is really bad, that's why it always had different result for different motherboard+cpu.

    If it had bad implement in your motherboard then disable HPET in BIOS is no brainer.
     
  4. nav-jack

    nav-jack Master Guru

    Messages:
    254
    Likes Received:
    0
    GPU:
    980 ti 1520/2000
    i'll never understand why that whenever i reinstall the asus ai suite software, my hpet becomes reenabled. everything is better with it off. with it on, whenever my cpu is under load or there is tons of disk io, the computer becomes choppy. its nonsense.
     

Share This Page