1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

[Solved] RX480/RX580 AMD drivers causing cursor/mouse lag

Discussion in 'Videocards - AMD Radeon Drivers Section' started by FookDat, Jul 20, 2018.

  1. Only Intruder

    Only Intruder Maha Guru

    Messages:
    1,109
    Likes Received:
    141
    GPU:
    Sapphire Fury Nitro
    Actually, I've just recently installed 18.8.1 and I'm getting stutter now.... (I had been on 18.3.2) - disabled and re-enabled my secondary monitor and stutter disappeared (Primary monitor is displayport, secondary is HDMI).

    Doesn't seem to be a pattern as to how it occurs for me just that it occurs sometimes.
     
    Last edited: Aug 19, 2018
  2. Xzess

    Xzess Member

    Messages:
    24
    Likes Received:
    2
    GPU:
    R9 380 4gb
    Try this:
    - Use "latency monitor" software to see if something is having too much DCP and conflicts the mouse. (this is only to test)

    - Put the pc in Hhgh performance mode in windows, and desactivate freesync (if you have), and energy eficiency in radeon CP.
    - Disable "AMD external events" service in windows services.
    - Put your monitors in 100% scaling options in the windows settings, don't use 150% or 125%....

    Do that one by one, maybe one of them works.
     
  3. kingofmummy

    kingofmummy New Member

    Messages:
    1
    Likes Received:
    0
    GPU:
    GTX 980 Ti, RX 580
    I used to have a problem similar to this with AMD cards ( RX 570, RX 580)

    Tried many ways:
    - fully uninstall driver and install many different versions driver.
    - switch different ports on both card & monitor.
    - change hdmi & displayport cables (all are premium cables. fully support HDCP 2.2, HDR, displayport 1.4...)

    only have had this problem with AMD graphic cards (I have 2 AMD cards: 1 RX570, 1 RX580).

    with my GTX 980 Ti, my system have no issue.
     
  4. Awesome Donkey

    Awesome Donkey Member

    Messages:
    14
    Likes Received:
    6
    GPU:
    Radeon RX 580 8GB
    I've been seeing this issue at random with the latest drivers, a RX 580 and a single Nixeus EDG 27 monitor @ 144Hz after playing certain games after a period of time, e.g. Left 4 Dead 2.
     

  5. FookDat

    FookDat Master Guru

    Messages:
    407
    Likes Received:
    20
    GPU:
    RX580 KrakenG12+H75
    Update FIXED:
    Cursor or system lag may be observed on some system configurations when two or more displays are connected and one display is powered off.


    18.9.1 driver fixed the issue of the cursor lag.
    Windows 7 x64 at moment.
     
    AlleyViper likes this.
  6. EdInk

    EdInk Active Member

    Messages:
    98
    Likes Received:
    2
    GPU:
    GTX 1080 (H20)
    You are a life saver, was close to tossing this RX570 out the window
     
    LocoDiceGR likes this.
  7. LocoDiceGR

    LocoDiceGR Ancient Guru

    Messages:
    1,935
    Likes Received:
    522
    GPU:
    Gigabyte R9 380 4G
    Its fixed in the latest drivers btw.
     
  8. Awesome Donkey

    Awesome Donkey Member

    Messages:
    14
    Likes Received:
    6
    GPU:
    Radeon RX 580 8GB
    Even with 18.12.1.1 I still get mouse lag after playing Left 4 Dead 2 (with a 144hz FreeSync monitor) for about 30 mins with the game at highest settings.
     
  9. TieSKey

    TieSKey Member Guru

    Messages:
    113
    Likes Received:
    24
    GPU:
    Gtx870m 3Gb
    I have this problem too but it's not just "mouse lag", the entire system freezes for half a second (games, videos, etc., not sure about audio).
    I'll try some of the suggestions posted but it happens on both my screens (both on) 1 on dp or hdmi and the other on dvi.


    Ok, disabling the hdcp on the monitor connected to a Dp fixed it..... bizarre behavior for sure....
     
    Last edited: Dec 13, 2018
  10. Awesome Donkey

    Awesome Donkey Member

    Messages:
    14
    Likes Received:
    6
    GPU:
    Radeon RX 580 8GB
    Finally fixed this. I noticed in the known issues log this was mentioned...

    I just got my current monitor two months ago, yet the old monitor was still "installed" in Windows. So I went into both the device manager and the registry and manually removed all monitors and did a clean install of the Adrenalin 2019 driver and voila, no more mouse lag in Left 4 Dead 2. :D
     
    fantaskarsef likes this.

  11. SauronDark

    SauronDark New Member

    Messages:
    1
    Likes Received:
    0
    GPU:
    Radeon R5 310M
    i am having this issue since 2016 version AMD driver, and stuck on Driver version 15

    idk but anyone haven't noticed its, but "System" process's "atikmdag.sys" thread hopping to 100% for a micro second in every 1 second interval make the whole system freeze, i found that on a process explorer tool. also i asked this on Amd community but seems they doesn't care it at all.

    https://community.amd.com/thread/205647
     
  12. sfo

    sfo New Member

    Messages:
    1
    Likes Received:
    1
    GPU:
    Radeon RX 580 4GB
    ----------------------------


    Wow, after 2 days of pulling my hair out - thank you! Fixed mouse skipping 4 seconds 5 seconds making Windows 10 unusable with RX 580 after RX 580 drivers loaded from default Windows 10 display drivers
     
    LocoDiceGR likes this.
  13. robbo247

    robbo247 Active Member

    Messages:
    57
    Likes Received:
    5
    GPU:
    Palit gtx 1080 8gb
    no issues on nitro+ 580
     
  14. Dekaohtoura

    Dekaohtoura Master Guru

    Messages:
    281
    Likes Received:
    30
    GPU:
    Sapphire V56 Pulse
    I'm having exactly the same problem, but on a HP laptop with an A8 APU with R5 graphics.

    Until some older driver release I could fix it by turning cursor trail on, then using RadeonMod (UVD clock fix) but for the better part of 2018 driver releases nothing works. The only way to have a functioning system is to DDU drivers and use the generic windows one.

    When anything requires some h/w acceleration, this anything just won't work.

    The last driver release that won't trigger this behavior is 17.7.1 (fine by me...my gf is not playing any games or anything), but W10 have recently acquired a very bad habit (another one) of auto download and install the latest release, even if I've set it to "off".

    Any ideas?

    TY and Merry Christmas!
     
  15. Adam Stickley

    Adam Stickley New Member

    Messages:
    1
    Likes Received:
    0
    GPU:
    AMD Radeon 480X
    Disabling HDCP didn't work. No extra screens were connected, and it would still happen with just 1 screen connected.

    Last solution was just to downgrade - downgrading back to 18.9.1 worked perfectly.
     

  16. TieSKey

    TieSKey Member Guru

    Messages:
    113
    Likes Received:
    24
    GPU:
    Gtx870m 3Gb
    Try disabling HCDP on all screens, dp, hdmi, dvi. Yeah, that crappy drm should't even work on the older interfaces but still made a difference for me.
     

Share This Page