Solution for stuck VRAM mem at max clocks on AMD Navi10

Discussion in 'Videocards - AMD Radeon Drivers Section' started by HD64G, Jan 20, 2021.

  1. MaCk0y

    MaCk0y Master Guru

    Messages:
    951
    Likes Received:
    354
    GPU:
    GB 5700XT Gaming OC
    From the test I did some time ago, it's 2 monitors max 1080p @ 60Hz. Don't know about more monitors.
     
  2. Turbogear

    Turbogear Member Guru

    Messages:
    105
    Likes Received:
    68
    GPU:
    PowerColor 6900XTU
    I own ASUS ROG Strix XG27WQ and I have same problem with 6800XT.
    Memory runs at full speed all the time, but for me it only happens at 165Hz refresh rate.
    If I set refresh rate to 144Hz then the Memory speed drops at idle desktop.

    I will try to play around with CRU to see if it can help.
     
    HD64G likes this.
  3. morrk

    morrk Member

    Messages:
    36
    Likes Received:
    14
    GPU:
    Red Devil 6800XT
    I've only just noticed this on my 6800XT yesterday having reinstalled windows for the first time in ages. Could have sworn I had the issue with my Vega card a long time ago but did something to stop it.

    I have 3 high refresh displays connected and have needed to move one over onto Intel onboard GPU to cool things down a little. It's a workaround for a moment but not one I'll be satisfied with for long.

    I'm able to run the following fine with the memory clock working properly:

    1 - 1440p - 144Hz
    1 - 1080p - 60Hz

    I've not bothered fiddling with custom resolutions on the 1080p panel but if I move to the next default increment of 85Hz the clocks move to 2000.
    With 3 screens connected the clocks are maxed, with all screens at 60Hz.

    I may be mistaken but I think the HDMI connection was more problematic for me. I seemed to have issues getting anything over 60Hz while that was connected while DP seems a little more forgiving.

    Would love to know what's happening with this if any of the Vanguard guys might know? I've read elsewhere that this behaviour is by design, would anybody know if this is true? Seems madness that a 6800XT with so much power needs to draw an additional 25W from the wall, while idling almost 20 degrees hotter in order to drive a couple of screens.

    Sorry for my rant. I only seem to post here when I'm moaning. :)
     
    Last edited: Feb 16, 2021
  4. supergt99

    supergt99 New Member

    Messages:
    3
    Likes Received:
    1
    GPU:
    5700xt
    same problem with 6900xt. any solutions yet?
     

  5. Tiki Thorsen

    Tiki Thorsen New Member

    Messages:
    5
    Likes Received:
    0
    GPU:
    RX 5500XT 4GB
    Hello, I have the same issue with the monitor defaulting to 1920x1080 at 75Hz (no issue at 60Hz)
    I tried all settings under custom resolution in Radeon Settings and the ones that did not were "out of range" had no effect on the VRAM clock. After trying settings for around an hour with CRU, the result was the same as with Radeon custom resolutions. I copied a few of the configs shown here but they did not work.
    Can anyone point me in the right direction, please?

    LG 24MK430H / RX 5500XT 4GB / Driver 21.2.3 (same issue with 20.11.2)
     

    Attached Files:

    • CRU.jpg
      CRU.jpg
      File size:
      67.9 KB
      Views:
      3
  6. The Creator

    The Creator Master Guru

    Messages:
    238
    Likes Received:
    47
    GPU:
    Red Devil 6800XT
    My "magic":

    cru.jpg

    1. I open the default resolution (which leads to high vmem clocks)
    2. I choose "Exact reduced" from "Timing" dropdown menu
    3. I close the detailed Resolution window with OK
    4. I double click again on the resolution (from 1) to edit
    5. Detailed Resolution dialog is opened again and "Timing" is set to "Manual"
    6. I change "Back porch" from 2 to 62
    7. I close the detailed Resolution window with OK
    8. I close the program and run restart64.exe

    Without step 6 I still have a high vmem clock. Of course, this "magic number 62" is ok for my monitor. You can try different values to see which one works for your one. I tried different values until I found one which keeps "Pixel clock" around 304-308MHz (I have this Pixel Clock with default settings and after that "Exact reduced" lowers it down).
     
    Last edited: Mar 7, 2021
    Tiki Thorsen likes this.
  7. Tiki Thorsen

    Tiki Thorsen New Member

    Messages:
    5
    Likes Received:
    0
    GPU:
    RX 5500XT 4GB
    Thanks for the reply.
    I just tried around 15 different number after following your instructions without success.
    How did you manage to find your magic number? Just trial and error or there is a way to make an educated guess?
     
  8. aufkrawall2

    aufkrawall2 Master Guru

    Messages:
    772
    Likes Received:
    106
    GPU:
    6800 reference UV
    It should simply be the higher, the better in terms of allowing dynamic VRAM clocking. I don't think it's documented that other timings than vertical back porch/blanking have an impact.
     
  9. Tiki Thorsen

    Tiki Thorsen New Member

    Messages:
    5
    Likes Received:
    0
    GPU:
    RX 5500XT 4GB
    After several more tests I did not manage to fix it.
    What puzzle me that the 60hz works correctly on Native PC timings but 75hz does not, only with Automatic which causes de VRAM issue.
    I tried quite a few modifications to the native timings but still no could not fix it. Anything higher den 32 on vertical give mes out of range.

    AUTOmatic.png NATIVE.png
     
  10. MaCk0y

    MaCk0y Master Guru

    Messages:
    951
    Likes Received:
    354
    GPU:
    GB 5700XT Gaming OC
    Change vertical blanking.
     
    Tiki Thorsen likes this.

  11. Tiki Thorsen

    Tiki Thorsen New Member

    Messages:
    5
    Likes Received:
    0
    GPU:
    RX 5500XT 4GB
    I appreciated all the instructions and tips but after wasting many hours failing to solve the issue I gave up trying to fix the issue at 75hz and spent 1 minute making a Custom Resolution in Radeon Settings at 74hz with CVT and problem solved.
     
  12. joaoameixa88

    joaoameixa88 Member

    Messages:
    34
    Likes Received:
    1
    GPU:
    5700XT
    This fix works for me, 5700XT max memory clock with 100hz 3440x1440 monitor.

    But everytime i change something in CRU , my pc keep crashing and restarting (completely random).
     
  13. PJVol

    PJVol Member

    Messages:
    10
    Likes Received:
    1
    GPU:
    Sapphire RX 5700 XT
    For 75Mhz monitors the trick is to raise Vblank. Not always works with 144 or higher though. I need just +6 lines to force memclk idle.
     
    aufkrawall2 likes this.
  14. gugabf

    gugabf New Member

    Messages:
    4
    Likes Received:
    0
    GPU:
    MSI RX 5700 XT 8GB
    In my case, MSI RX 5700 XT Gaming X with just one monitor (Dell S2721DS - 2560x1440x75Hz max), it was staying at mem max in idle even at 60Hz.
    Both 60Hz and 75Hz with standard settings did not work to put mem to variable behaviour, but just stucked at max all the time, even on idle.
    Setting custom resolution on AMD Software didn't work.
    In CRU, changing settings for 75Hz, adding just 1 more line on VBlank have worked and this way memclk is forced down on idle at 75Hz, max refresh rate of my monitor.
    What a mess.
    Without this workaround, with memclk at max all the time, GPU temp on idle is 17-19°C higher than with variable memclk, even at 60Hz.
    A default configuration working this way is unacceptable.
     
    Last edited: Apr 16, 2021

Share This Page