Softmod doesn't stick?

Discussion in 'RivaTuner Advanced Discussion forum' started by IceMole, Nov 2, 2004.

  1. IceMole

    IceMole Member

    Messages:
    18
    Likes Received:
    0
    GPU:
    XFX 7800GT OC @ 513/1200 (stock cooler)
    About 2 weeks ago I bought an eVGA from CC, brought it home on 61.77 drivers, softmodded to 16x1,6 and it was nice and easy. I ended up returning the card a week later and getting in on a great dell deal.

    I got a 6800GTO with it, 12x1,5 350/900 256mb DDR3, now I loaded up rivatuner expecting to softmod like everyone has been doing on these (running 66.81) install NVStrap, allow hardware masked units, changed to customize, click click reboot. Comes back up shows 12x1,5vp but the customize drop menu shows 16x1,6vp. Bios picture and target adapter all show 12x1,5vp.

    Am I doing something wrong? I thought this was pretty simple and straight forward to do, I'm missing Pixel Unit 2 / vertex 3. I posted at anandtech and no one knows, searched this board top to bottom and found nothing. Anyway thanks if anyone can help show some light.
     
  2. striker17

    striker17 Member

    Messages:
    18
    Likes Received:
    0
    GPU:
    6800 GTO, 9800 PRO
    I have the exact same problem. I've posted in the "15.2 Success Posts" thread (page 9), and it appears there's at least one other member (yoshi2004) that has the same problem. There must be something a bit different with the latest crop of Dell 6800 GTO cards. I've read reports of RT working with the 6800 GTOs, so I'm assuming that this is a relatively recent change to the GTO card/bios/software.

    Any help greatly appreciated.

    --striker17

    Here's my adapter and BIOS info:

    $ffffffffff ---------------------------------------------------
    $ffffffffff NVIDIA specific display adapter information
    $ffffffffff ---------------------------------------------------
    $0100000000 Graphics core : NV40 revision A1 (12x1,5vp)
    $0100000001 Hardwired ID : 0044 (ROM strapped to 0044)
    $0100000002 Memory bus : 256-bit
    $0100000003 Memory type : DDR (RAM configuration 07)
    $0100000004 Memory amount : 262144KB
    $0100000005 Core clock : 401.625MHz
    $0100000006 Memory clock : 506.250MHz (1012.500MHz effecti...
    $0100000007 Reference clock : 27.000MHz
    $010000000b HW masked units : pixel 0010b, vertex 001000b
    $ffffffffff ---------------------------------------------------
    $ffffffffff NVIDIA VGA BIOS information
    $ffffffffff ---------------------------------------------------
    $1100000000 Title : nv45 p211 sku10 VGA BIOS
    $1100000002 Version : 5.40.02.17.15
    $1100000100 BIT version : 1.00
    $1100010000 Perf. level 0 : 350MHz/450MHz/1.30V
    $1100020000 VID bitmask : 00000011b
    $1100020100 Voltage level 0 : 1.10V, VID 00000000b
    $1100020101 Voltage level 1 : 1.30V, VID 00000010b
    $1100020102 Voltage level 2 : 1.40V, VID 00000001b
    $1100000003 SW masked units : none


     
  3. yoshi2004

    yoshi2004 Guest

    I just got my 6800 gto today and im seeing the same thing.

    I reloaded xp pro to no avail.
     
  4. striker17

    striker17 Member

    Messages:
    18
    Likes Received:
    0
    GPU:
    6800 GTO, 9800 PRO
    Yoshi, what's your BIOS version? I'm thinking of re-flashing my GTO bios with an nvidia 6800 GT bios. Any one have pointers, warnings? Can I revert if the flash goes bad?

    I've been playing with my GTO at 450/1100 and it seems pretty snappy. I only have a 3.0 Ghz P4. Here are a few numbers:

    3d 03 - 9607 stock / 9864 450/1100
    3d 05 - 3067 stock / 4013 450/1100

    --striker17

     

  5. yoshi2004

    yoshi2004 Guest

    same bios info as what you posted.


    Im just finishing the memory clocking, mines at 1100 as well. Gonna hold here.

    next im going to start working on the gpu clock.

    What temps are you seeing at your gpu clock?


    at 350/1100 im seeing 68c at load. Ive got a nv silencer 5 i just havent installed it yet.
     
  6. striker17

    striker17 Member

    Messages:
    18
    Likes Received:
    0
    GPU:
    6800 GTO, 9800 PRO
    70 C temps at idle with 2D at 400/1100. 77 C after 3d benchmarks at 450/1100.
     
  7. Unwinder

    Unwinder Moderator Staff Member

    Messages:
    14,439
    Likes Received:
    1,463
    First, I'd like to see _full_ disagnostic report from one of these cards (including GPU registers snapshot). Second, I'd like to have BIOS of such card to peek inside it.
    Finally, it would be nice to have such card in my testrig, I doubt that I'll be able to do anything without having it installed and seeing the problem with my eyes. But anyway it worth trying.
     
  8. striker17

    striker17 Member

    Messages:
    18
    Likes Received:
    0
    GPU:
    6800 GTO, 9800 PRO
    I can't get the BIOS dumped at the moment. Need to get a floppy drive hooked up to the PC (not even sure if there's a floppy option other than USB for these Dell 8400.) So, hopefully, Yoshi can provide the BIOS dump.

    I'd be willing to kick in a few bucks for an 9800 GTO fund :) But, can't provide one unfortunately since mine is going to be in serious use soon.

    I can't fit the full diagnostic report in the message, it's too big. Here's a portion. Please let me know what else you need and I'll post in follow up.l

    Thanks!

    $ffffffffff ---------------------------------------------------
    $ffffffffff Display adapter information
    $ffffffffff ---------------------------------------------------
    $0000000000 Description : NVIDIA GeForce 6800 Series GPU
    $0000000001 Vendor ID : 10de (NVIDIA)
    $0000000002 Device ID : 00f9
    $0000000003 Location : bus 1, device 0, function 0
    $0000000004 Bus type : PCI
    $0000000009 Base address 0 : dd000000 (memory range)
    $000000000a Base address 1 : c0000000 (memory range)
    $000000000b Base address 2 : de000000 (memory range)
    $000000000c Base address 3 : none
    $000000000d Base address 4 : none
    $000000000e Base address 5 : none
    $ffffffffff ---------------------------------------------------
    $ffffffffff Display adapter PCI configuration space
    $ffffffffff ---------------------------------------------------
    $ffffffffff +00+01+02+03+04+05+06+07+08+09+0a+0b+0c+0d+0e+0f
    $0300000000 +00 de 10 f9 00 07 00 10 00 a2 00 00 03 10 00 00 00
    $0300000001 +10 00 00 00 dd 08 00 00 c0 00 00 00 de 00 00 00 00
    $0300000002 +20 00 00 00 00 00 00 00 00 00 00 00 00 de 10 6d 02
    $0300000003 +30 00 00 00 00 60 00 00 00 00 00 00 00 10 01 00 00
    $0300000004 +40 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
    $0300000005 +50 00 00 00 00 01 00 00 00 ce d6 23 00 00 00 00 00
    $0300000006 +60 01 68 02 00 00 00 00 00 05 78 80 00 00 00 00 00
    $0300000007 +70 00 00 00 00 00 00 00 00 10 00 11 00 c0 04 58 02
    $0300000008 +80 16 28 00 00 01 55 02 00 48 00 01 11 00 00 00 00
    $0300000009 +90 00 00 00 00 00 00 00 00 0c 08 40 c1 01 04 40 c1
    $030000000a +a0 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
    $030000000b +b0 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
    $030000000c +c0 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
    $030000000d +d0 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
    $030000000e +e0 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
    $030000000f +f0 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
    $ffffffffff ---------------------------------------------------
    $ffffffffff NVIDIA graphics processor registers
    $ffffffffff ---------------------------------------------------
    $020100003c CR3C : 00000078
    $0200000000 NV_PMC_BOOT_0 : 440400a1
    $0200001080 NV_PBUS_DEBUG_0 : 00000000
    $0200001084 NV_PBUS_DEBUG_1 : 00205609
    $0200001088 NV_PBUS_DEBUG_2 : 000211f0
    $020000108c NV_PBUS_DEBUG_3 : 00000092
    $02000010b0 NV_PBUS_DEBUG_CTRIM_0 : 00000092
    $02000010b4 NV_PBUS_DEBUG_CTRIM_1 : 00000092
    $02000010b8 NV_PBUS_DEBUG_CTRIM_2 : 00000092
    $02000010bc NV_PBUS_DEBUG_CTRIM_3 : efffffff
    $02000010c4 NV_PBUS_DEBUG_CTRIM_4 : efffffff
    $02000010c8 NV_PBUS_DEBUG_CTRIM_5 : efffffff
    $02000010cc NV_PBUS_DEBUG_CTRIM_6 : efffffff
    $02000010e0 NV_PBUS_DEBUG_PRIV_ASRC : 00000000
    $0200100000 NV_PFB_BOOT_0 : 00000000
    $0200100080 NV_PFB_DEBUG_0 : f1000020
    $0200100200 NV_PFB_CFG : 43003023
    $020010020c NV_PFB_CSTATUS : 10000000
    $0200100220 NV_PFB_TIMING0 : 060f1b15
    $0200100224 NV_PFB_TIMING1 : 09010509
    $0200100228 NV_PFB_TIMING2 : 20250407
    $02001002c0 NV_PFB_MRS : 00000272
    $02001002c4 NV_PFB_EMRS : 0010008b
    $0200101000 NV_PEXTDEV_BOOT_0 : a15ec09f
    $0200101004 NV_PEXTDEV_BOOT_0_AND : 7e0f403f
    $0200101008 NV_PEXTDEV_BOOT_0_OR : 01508080
    $020010100c NV_PEXTDEV_BOOT_1 : 80000090
    $0200101010 NV_PEXTDEV_BOOT_1_AND : 7fffffef
    $0200101014 NV_PEXTDEV_BOOT_1_OR : 00000010
    $020060081c NV_PCRTC_GPIO_EXT : 06050370
    $0200680500 NV_PRAMDAC_NVPLL_COEFF : 00040701
    $0200680570 NV_PRAMDAC_NVPLL_COEFF_1 : 80001104
    $0200680504 NV_PRAMDAC_MPLL_COEFF : 00018684
    $0200680574 NV_PRAMDAC_MPLL_COEFF_1 : 00000401
    $020068050c NV_PRAMDAC_PLL_COEFF_SELECT : 10004704
    $0200001540 NV40_UNITS_CFG : 0001370d
    $0200004004 NV40_PRAMDAC_NVPLL_COEFF : 0d030601
    $0200004000 NV40_PRAMDAC_NVPLL_COEFF_1 : c001001c
    $0200004024 NV40_PRAMDAC_MPLL_COEFF : 19040601
    $0200004020 NV40_PRAMDAC_MPLL_COEFF_1 : e000001c
    $020000c010 NV40_UNITS_MASK_DEFAULT : 00880000
    $020000c020 NV40_UNITS_MASK : 00000000
     
  9. Unwinder

    Unwinder Moderator Staff Member

    Messages:
    14,439
    Likes Received:
    1,463
    You don't need a floppy to dump it. Just start RivaTuner.exe with "/BI" command line switch and it will read your flashrom create a dump of VGA BIOS image.
     
  10. striker17

    striker17 Member

    Messages:
    18
    Likes Received:
    0
    GPU:
    6800 GTO, 9800 PRO
    I have the 6800 GTO bios dumped. Where's the easiest place to upload it?

    I'm willing to flash over my 6800 GTO bios with a stock nvidia 6800 GT rev 2 bios. Would this help? If something goes wrong, is it easy to revert? I would imagine just plugging in another PCI graphics card and reflashing right?

    Thanks,

    --striker17

     

  11. Unwinder

    Unwinder Moderator Staff Member

    Messages:
    14,439
    Likes Received:
    1,463
    Please send it to [censored] (CC to [censored]).


    Yep, it may help if the preotection is at VGA BIOS level. But be careful, you can void your warranty.
     
    Last edited: Nov 2, 2004
  12. jiggaroy

    jiggaroy Guest

    *EDIT*
    There are alotta people with GTOs in the hardops forum that had success. Would it help if we get one to post their vga bios info?

    Me and my friend both just got dell systems with the 6800 gto and we are both having the same problems.

    heres my vga bios info if that helps

    $ffffffffff NVIDIA VGA BIOS information
    $ffffffffff ---------------------------------------------------
    $1100000000 Title : nv45 p211 sku10 VGA BIOS
    $1100000002 Version : 5.40.02.17.15
    $1100000100 BIT version : 1.00
    $1100010000 Perf. level 0 : 350MHz/450MHz/1.30V
    $1100020000 VID bitmask : 00000011b
    $1100020100 Voltage level 0 : 1.10V, VID 00000000b
    $1100020101 Voltage level 1 : 1.30V, VID 00000010b
    $1100020102 Voltage level 2 : 1.40V, VID 00000001b
    $1100000003 SW masked units : none
     
    Last edited by a moderator: Nov 2, 2004
  13. Pepperoni7

    Pepperoni7 Member Guru

    Messages:
    110
    Likes Received:
    0
    GPU:
    8800GT 512MB +Thermalright V2
    Hey Unwinder, would you mind telling me what VID stands for in the "core VID" monitoring graph? Is it the core voltage, and is 1.0 the normal value?

    Cheers
     
  14. Unwinder

    Unwinder Moderator Staff Member

    Messages:
    14,439
    Likes Received:
    1,463
    It is Voltage IDENTIFIER, and the graph clearly states that it is non-dimensional value. It is NOT a voltage.
     
  15. yoshi2004

    yoshi2004 Guest

    Id be willing to send you my gto if you could send me a pci express card to use in the mean while. I dont have another pci express card im sorry to say.


    EDIT - slight problem with this. It looks like the gto in the dells have a proprietary power connector. Its not a 4 pin molex its a 6 pin thats coming out of the dell powersupply. Damn the man!
     
    Last edited by a moderator: Nov 2, 2004

  16. Unwinder

    Unwinder Moderator Staff Member

    Messages:
    14,439
    Likes Received:
    1,463
    Examined striker17's registers dump and BIOS. Masked pipes are really not activated, even considering that current mask register is successfully reprogrammed.
    I see no major differences in BIOS initialization scripts, which can cause it. So either there are some hardware differences in new Dell GTOs, or there are some protections hidden deeper in the script. I can continue examining the BIOS, but I really don't want to make monkey job, so I'll do it only if I'll have one of those GTOs in my PC or some GTO ownder will be brave enough to flash old BIOS and confirm that the protection is BIOS related.
     
  17. Unwinder

    Unwinder Moderator Staff Member

    Messages:
    14,439
    Likes Received:
    1,463
    Damn. Is GTO a PCI-E board? Then I can forget about it, all my testbeds are AGP based and I won't have PCI-E platform in the nearest future.
     
  18. striker17

    striker17 Member

    Messages:
    18
    Likes Received:
    0
    GPU:
    6800 GTO, 9800 PRO
    I'd be willing to flash mine. I took a look at flashing one of the AGP BIOS versions and could force nvflash to flash it. Using a tool like nbitor, didn't look like I could modify the AGP 6800 BIOS image properly. Some German(?) error message when manipulating the settings.

    I think the best bet is to get another working 6800 GTO's BIOS and flash that. Hopefully, it'll be a different BIOS version.

    Can anyone post/send their working 6800 BIOS to me?

    Thanks,

    --striker17

     
  19. IceMole

    IceMole Member

    Messages:
    18
    Likes Received:
    0
    GPU:
    XFX 7800GT OC @ 513/1200 (stock cooler)
    Glad to see I'm not the only one with this problem. I thought it was going to be easy as reported over in Hard. Striker I'm getting 10,173 in 03 stock, you may want to look at your settings.

    I'd be willing to flash to another users 6800GTO bios that has already worked. Looks like mine is the same as yours:

    $1100000000 Title : nv45 p211 sku10 VGA BIOS
    $1100000002 Version : 5.40.02.17.15
    $1100000100 BIT version : 1.00
    $1100010000 Perf. level 0 : 350MHz/450MHz/1.30V
     
  20. striker17

    striker17 Member

    Messages:
    18
    Likes Received:
    0
    GPU:
    6800 GTO, 9800 PRO
    Got to run to work, so can't reflash mine now. I'm going to flash a 6800 Ultra rom image modified with nbitor to set the voltage back to 1.3 and 400/1100 clocks. I'll let you know how this turns out later tonight. Hopefully, someone will find a stock 6800 GTO bios that works before that time and I won't have to experiment :)

    I only got a 3.0 Ghz processor with mine, so that's probably where the difference is in scores.

    Also, after a bit more testing, my OC temps actually go up to 80 C after running nvidia's nalu demo. If you want to test your OC rig, give this demo a shot, it really exercises the gfx card.

    I'll let you know tonight if I have working pipes or a dead card.

    --striker17

     

Share This Page