So this 4:4:4 problem in a nutshell (HDMI)

Discussion in 'Videocards - NVIDIA GeForce Drivers Section' started by Mda400, Mar 13, 2013.

  1. maco07

    maco07 Active Member

    Messages:
    96
    Likes Received:
    0
    GPU:
    7970 3GB Boost
    My Sammy support 4:4:4 and sound. Also support 24hz, but when I switch to this refresh rate, 4:4:4 gone and 4:2:2 is back.

    In your case, you can create a custom resolution with 23.976Hz. Forget to achieve 4:4:4 in 24hz
     
  2. elMARIACHI

    elMARIACHI Member

    Messages:
    30
    Likes Received:
    0
    GPU:
    3x Sapphire R290x
    I would like to thank you all for your advice especially Mda400...you have been particularly helpful. I just finished attempting the EDID override you just posted on my HDTV & GTX580 but unfortunately it didn't work. I'm still stuck having to create a custom resolution which not only introduces fuzz but complicates things when I use SVP since it no longer interpolates @ 60 Hz. What to do0o0o0o0o0...:bang:

    Edit: After some more screwing around, I can't seem to set a resolution in between 60 and 61 hz which doesn't surpass my maximum pxiel clock (which must be what's creating a blurry/fuzzy picture & most probably damaging the display). If i set it below 50.560, no 4:4:4 and any higher then that it simply creates a resolution of 61 hz regardless of the value I input. After more time wasted...58 Hz has the same effect; 4:4:4 with fuzz and blur. I've got no clue what's going on anymore. I did also just notice HDCP is still ON in NV Ctrl Panel but my Display is in fact listed as EDID OVERRIDE in device manager...could that be a problem?
     
    Last edited: Apr 23, 2013
  3. Mda400

    Mda400 Master Guru

    Messages:
    971
    Likes Received:
    129
    GPU:
    3080Ti 1950/21.4G
    Use this method for overriding the EDID: LCD Televisions with 4:4:4
     
  4. elMARIACHI

    elMARIACHI Member

    Messages:
    30
    Likes Received:
    0
    GPU:
    3x Sapphire R290x
    I did use that very method and applied it on my display and video card and it didn't seem to have any effect...back to square 1.
     

  5. elMARIACHI

    elMARIACHI Member

    Messages:
    30
    Likes Received:
    0
    GPU:
    3x Sapphire R290x
    Mda400 or anyone else for that matter, would you have any suggestions as to what may be causing the problem?
     
  6. dsbig

    dsbig Ancient Guru

    Messages:
    4,059
    Likes Received:
    43
    GPU:
    EVGA RTX 2070
    for me vga looks better on my screen then hdmi.

    text look dark and crisper.

    hdmi text is brighter and blured a little


    at lest with vga I can have full screen for bios and none windows activities
     
  7. elMARIACHI

    elMARIACHI Member

    Messages:
    30
    Likes Received:
    0
    GPU:
    3x Sapphire R290x
    Help! I need somebody help! Not just anybody helpppppppp!!!!
     
  8. Mda400

    Mda400 Master Guru

    Messages:
    971
    Likes Received:
    129
    GPU:
    3080Ti 1950/21.4G
    That method of overriding the EDID has worked on every TV i have needed it for and that about 4 different HDTV's now. If its not working, you most likely aren't editing the correct registry object or not pasting the edid bits into your display driver .inf (nvdisp.inf) under the correct field.

    Make sure to do that device manager part first. Then:

    For the registry part, the last two bit fields it tells you to modify can be incorrect with the checksum that comes from the Phoenix EDID program. After I did numerous retries with the EDID override, Phoenix would calculate a different checksum than before because i kept editing the registry value.

    The general rule is this, follow the instructions to the registry object your suppose to modify for disabling HDMI extensions. Then, since the bits are displayed in hexadecimal, 01 means 1 HDMI extension (the audio extension on the EDID), 02 would mean 2 extension bits and so on and so forth.

    So changing that value to 00 disables the audio extension and forces a DVI display to be read. With that last field (mine was 3E) its suppose to be changed to the calculated checksum that Phoenix EDID manager calculated, but again its not always the correct calculated checksum as described above.

    What I'm saying is I caught on to the trend of how Phoenix calculates the checksum when changing extensions. If I have one extension (01 in hex) and the checksum is currently 3E, then disabling that extension adds 1 in value to the checksum (think of the checksum as the entire "pool" of bits). So 1+3E (this is in hex, again) equals 3F. After E comes F because Hex goes up to 16 values before starting over (Base 16 -1,2,3,4,5,6,7,8,9,10,A,B,C,D,E,F,) and Decimal (Dec. meaning 10) starts over after 10 values (Base 10-1,2,3,4,5,6,7,8,9,10).

    Ignore Phoenix EDID manager's checksum and do the calculation as i posted. So if you have a 01 and <your # EDID checksum> set in registry, it should be set to 00 and <original checksum plus one>.

    Hope this long explanation helps as i have just taught a little computer math as an ADDED BONUS! woo! :banana:
     
    Last edited: May 2, 2013
  9. elMARIACHI

    elMARIACHI Member

    Messages:
    30
    Likes Received:
    0
    GPU:
    3x Sapphire R290x
    Thanks again for the quick reply Mda. As I said in my previous post, I'm 99% sure I did all procedures correctly since my HDTV is now treated as if it's connected VIA DVI, I've lost my audio signal and my HDTV is now listed as EDID Override. I managed to achieve 4:4:4 only if i set a resolution other then 60 Hz in which case my display freaks out and seems fuzzy/blurry to the point where it strains your eyes . At this point, I'm guessing the question I should be asking is how to keep 4:4:4 without having to a refresh rate other then 60 Hz. Any thoughts?
     
  10. maco07

    maco07 Active Member

    Messages:
    96
    Likes Received:
    0
    GPU:
    7970 3GB Boost
    Did you tried 60.001hz?
     

  11. elMARIACHI

    elMARIACHI Member

    Messages:
    30
    Likes Received:
    0
    GPU:
    3x Sapphire R290x
    I tried all the way up to 60.560 where any value higher then that, it creates a 61 Hz refresh rate and any lower, it sticks to 60 Hz. My screen also confirms this.
     
  12. Mda400

    Mda400 Master Guru

    Messages:
    971
    Likes Received:
    129
    GPU:
    3080Ti 1950/21.4G
    My fault. I thought you were still trying to get the override to even show a DVI connection (but you're past that part). I didn't have to make a separate refresh rate for my TV after the override for it to work, but then again, my horizontal scan range was a max of 63hz so I have a little room for a higher refresh rate. Check to see if yours is maybe only up to 60hz in moninfo?
     
  13. elMARIACHI

    elMARIACHI Member

    Messages:
    30
    Likes Received:
    0
    GPU:
    3x Sapphire R290x
    MonInfo reported My Horizontal Scan Range is 15-85kHz. I'm pretty much clueless what I should do from here...thanks once again for any help in advance!
     

Share This Page