So confused please assist?

Discussion in 'General Hardware' started by Improv, Mar 23, 2013.

  1. Improv

    Improv Banned

    Messages:
    63
    Likes Received:
    0
    GPU:
    Patriot 8gb DDR3 ram
    Hey guys I am really confused about something.

    So I just bought a Maximus V Formula and i7 3770k with windows 8

    My question is it seems that my CPU is stuck at its turbo speed of 3900MHz.

    However, if I set my power options to balanced as opposed to max it starts to make use of the power saving features such as EIST.

    Now what I'm confused about is in my last build even if I had power settings set to max power it would still downclock when it wasn't being stressed.

    Is something wrong? Or is this normal.

    Thank you
     
  2. IcE

    IcE Don Snow Staff Member

    Messages:
    10,654
    Likes Received:
    11
    GPU:
    Gigabyte 970 G1
    If Windows can, it will keep the CPU from downclocking. By default the max performance profile has the "minimum CPU" setting set to 100%. What you're seeing is normal. Set it to high performance, customize, and set minimum CPU to 5% instead of 100%. Balanced has link state power management on by default which you don't want.
     
  3. Improv

    Improv Banned

    Messages:
    63
    Likes Received:
    0
    GPU:
    Patriot 8gb DDR3 ram
    Okay thank you very much. I just don't remember this happening with my Win 7 build with a i5 2500k.

    Max Performance still had it downclock.
     
  4. IcE

    IcE Don Snow Staff Member

    Messages:
    10,654
    Likes Received:
    11
    GPU:
    Gigabyte 970 G1
    It shouldn't have, is the thing. Not sure why it was doing that before, but who knows. You may have had some other software overriding Windows.
     

  5. Improv

    Improv Banned

    Messages:
    63
    Likes Received:
    0
    GPU:
    Patriot 8gb DDR3 ram
    Thanks mate =)
     
  6. SLI-756

    SLI-756 Banned

    Messages:
    7,604
    Likes Received:
    0
    GPU:
    760 SLI 4gb 1215/ 6800
    What IcE said, ASus mobos have always looked way too complicated to me, no doubt there'll be a setting in there somewhere if it's not windows causing it.
     

Share This Page