Smoke Demo problem

Discussion in 'Videocards - NVIDIA GeForce' started by BiZkiT, May 6, 2007.

  1. BiZkiT

    BiZkiT New Member

    Messages:
    9
    Likes Received:
    0
    GPU:
    EVGA 8600 GTS 256mb
    Hi everyone, I've just bought a GeForce 8600 GTS. All the demos look good, well, except the smoke one. It looks very ugly. The ugliness is mainly caused by the apperance of some kind of artifacts. You have to see it for yourself. Does anyone have an idea what could be the problem? I have the latest drivers (installed properly). I found it that the artifacts appear due to Anisotropic Filtering being turned on,when I turn it off,the smoke looks much better,altough the edges of the box still look very crispy (with AA set to 16xQ) Overheating could not be possible because the GPU is new. I have a second question, is there any way to watch this demo in fullscreen? Here's a link to an exact thread of mine on NVIDIA's site, there're screenshots of my problem there
    http://forums.nvidia.com/index.php?showtopic=34704

    Thanks in advance:)
     
  2. chispy

    chispy Ancient Guru

    Messages:
    8,981
    Likes Received:
    1,202
    GPU:
    RX 6900xt / RTX3090
    Welcome to Guru3D , Please update your profile under your name that way we gurus can help you.

    Good day.
     
  3. dB

    dB Ancient Guru

    Messages:
    2,448
    Likes Received:
    0
    GPU:
    88GTS 512M@830/2050/2.2g
    Try to update your drivers. If that doesn't help reinstall the program.
     
  4. BiZkiT

    BiZkiT New Member

    Messages:
    9
    Likes Received:
    0
    GPU:
    EVGA 8600 GTS 256mb
    That's not because of drivers,so far I've used about 3 or 4 different drivers,now I'm using the newest. The artifacts appear only in the smoke demo, I also tried to underclock my GPU with no effect. What could be the problem? Did some of you have the same problem?
     

  5. BiZkiT

    BiZkiT New Member

    Messages:
    9
    Likes Received:
    0
    GPU:
    EVGA 8600 GTS 256mb
    There's a little progress I've made so far. It's kinda interesting: the problem is suddenly gone when I turn the anisotropic filtering off (well,it also looks acceptable on 2x aniso), any ideas?
     
  6. VultureX

    VultureX Banned

    Messages:
    2,577
    Likes Received:
    0
    GPU:
    MSI GTX970 SLI
    We all have that problem.
    Physics rendering and Anisotropy don't match

    If you try forcing Anisotropy, it will apply AF also on every smoke particle which will cause a kind of artifacting problem. Just turn forced AF off and enjoy!
     
  7. BiZkiT

    BiZkiT New Member

    Messages:
    9
    Likes Received:
    0
    GPU:
    EVGA 8600 GTS 256mb
    BIG THX!!!!

    That helped me a lot,but that strange white dots still apear, it looks like if it were no AA turned on, maybe that's because I'm not running this demo on fullscreen, but, I guess there's no way to go fullscreen in this demo, Thanks again:)
     
  8. BiZkiT

    BiZkiT New Member

    Messages:
    9
    Likes Received:
    0
    GPU:
    EVGA 8600 GTS 256mb
    VultureX - Can You apply AA to this demo or go fullscreen in it? I can't neither go FS nor turn the AA on, it looks the same on 4x or 16xQ AA
     
  9. VultureX

    VultureX Banned

    Messages:
    2,577
    Likes Received:
    0
    GPU:
    MSI GTX970 SLI
    AA (forcing or enhancing) doesn't really improve image quality in this demo. I guess it's not supported or forced off or something.
    Also, you can't go full screen, but you can just maximize the window ;)
     
  10. BiZkiT

    BiZkiT New Member

    Messages:
    9
    Likes Received:
    0
    GPU:
    EVGA 8600 GTS 256mb
    alright,but tell me-do You have the same strange white dots and jagged edges when You run the demo? look,here are the screens from my demo http://forums.nvidia.com/index.php?showtopic=34704, don't look at the smoke artifacts because we already know how to avoid this:) just take a look at the jagged edges and these dots? Do You have them?
     

  11. VultureX

    VultureX Banned

    Messages:
    2,577
    Likes Received:
    0
    GPU:
    MSI GTX970 SLI
    jagged edges = more or less same as in your pic. It'll be less when you put it on higher res

    And those dots only occur (sometimes) in the water demo (just think of it as some water drops hanging on the ceiling:p), but the smoke is perfectly fine for me.
     
  12. BiZkiT

    BiZkiT New Member

    Messages:
    9
    Likes Received:
    0
    GPU:
    EVGA 8600 GTS 256mb
    but how to put it on higher res,I don't see any settings for this demo,I guess it's not about my desktop res. which is now 1440x900,thanks again:)
     
  13. VultureX

    VultureX Banned

    Messages:
    2,577
    Likes Received:
    0
    GPU:
    MSI GTX970 SLI
    Just drag the window to a bigger format (by moving your mouse to the lower right corner. It will change into an arrow and then you can drag to change size. Or just maximalize the window)
    You can't set numbers for this demo, but you can manually change the size of the window
     
  14. BiZkiT

    BiZkiT New Member

    Messages:
    9
    Likes Received:
    0
    GPU:
    EVGA 8600 GTS 256mb
    I did the same earlier,just thought it might have been some way to set the res,but thanks anyway, the jagged lines appear anyway,I'll keep trying to get rid of it :) THANKS!
     
  15. Murock

    Murock Active Member

    Messages:
    50
    Likes Received:
    0
    GPU:
    Extreme 8800GTS 320MB 661/1902mhz
    na man I dont see anything in 2142 or any game and i have everything maxxed out and also why is the shaders really bad not smooth and how do fix this?
     

  16. TheWheelman

    TheWheelman Master Guru

    Messages:
    819
    Likes Received:
    0
    GPU:
    Asus96GT512 700/1800/1100
    Isn't there a file you can edit to get it fullscreen?
     
  17. VultureX

    VultureX Banned

    Messages:
    2,577
    Likes Received:
    0
    GPU:
    MSI GTX970 SLI
    Sorry I should have mentioned physics rendering On GPU ... The physics in every other DX9 game are computed by the CPU.
    And for "why is the shaders really bad not smooth" --> That is called Shader Model 3.0, my friend ;) In future games with DX10 all of that will be history ;)


    Nope (at least not that I know of ;))
     
  18. TheWheelman

    TheWheelman Master Guru

    Messages:
    819
    Likes Received:
    0
    GPU:
    Asus96GT512 700/1800/1100
    Well I'd check on that.
    Just to be sure.
    Cause more do.

    And why is it that Physics + AF = ERROR?
     
  19. VultureX

    VultureX Banned

    Messages:
    2,577
    Likes Received:
    0
    GPU:
    MSI GTX970 SLI
    Probably because AF is used to be applied on textures. The card doesn't know how to apply AF on the physics renderings...

    (btw I really have no idea if this is true, I'm just trying to sound intelligent :p)

    About the full screen: I'm not going to check on it, it's just a demo :p I've seen enough of it after 2 minutes :p May you try to find a full screen tool, please post !!! ;)
     
    Last edited: May 7, 2007
  20. BiZkiT

    BiZkiT New Member

    Messages:
    9
    Likes Received:
    0
    GPU:
    EVGA 8600 GTS 256mb
    now I've noticed that there's some GL error appearing when I run the demo? As far as I know there's nothing like updating Open GL,but I may be wrong,any ideas?:)
     

Share This Page