Skyrim stutters in fullscreen

Discussion in 'Videocards - AMD Radeon Drivers Section' started by MrSean490, Feb 3, 2012.

  1. MrSean490

    MrSean490 Active Member

    Messages:
    59
    Likes Received:
    0
    GPU:
    ref. Sapphire 6950 2GB
    I just want to know if anyone else has this problem.

    1. The framerate is perfectly fine and stable at no less than 55 frames.
    2. The game stutters heavily indoors whilst maintaining the same frame rate.
    2a. The game stutters outdoors as well, perhaps not as noticeable, with about the same frame rate.
    3. Changing the settings doesn't change the situation.
    4. Changing drivers doesn't change the situation.
    5. Switching the game to windowed mode suddenly fixes the situation, the stuttering is gone and the game is almost butter smooth.

    I simply don't understand why this happens, and if anybody else has come across this situation and if there is a reason worked out as to why this happens and why windowed fixes it?

    My problem with windowed mode is that I can't change the in-game brightness because it relies on desktop brightness as it's treated as a normal desktop window object. And that the framerate is can be somewhat affected by this (however take note the stuttering and framerate in this scenario seem completely separate).


    EDIT: My specs are as follows:


    Win 7 64bit
    8GB RAM Corsair Vengeance
    Intel i5 750 @ ~3.4ghz
    ATI 6950 2GB
     
    Last edited: Feb 3, 2012
  2. Geralt

    Geralt Master Guru

    Messages:
    284
    Likes Received:
    0
    GPU:
    Radeon RX 580 8GB
    I'm not sure what causes it but capping the FPS to 59 with MSI Afterburner allows me to run it in fullscreen without the stuttering.
     
  3. MadelineX

    MadelineX Master Guru

    Messages:
    259
    Likes Received:
    0
    GPU:
    Sapphire 295x2
    It's the game itself. Go to the nexus and search out stutter fix and DL it.
     
  4. diddly

    diddly Active Member

    Messages:
    81
    Likes Received:
    0
    GPU:
    KFA2 GTX 970 Infin8
    wait for the "soon" to be released 1.4 patch. or try out the beta via steam.
     

  5. racofer

    racofer Master Guru

    Messages:
    273
    Likes Received:
    0
    GPU:
    HD6950 2GB Twin Frozr III
    Yes, I have the same issue. However, I've managed to fix it by switching to windowed mode and applying this mod: Simple Borderless Window

    My Skyrim now runs silky smooth without any stutter/jitters at all.
     
  6. Netherwind

    Netherwind Ancient Guru

    Messages:
    7,787
    Likes Received:
    1,622
    GPU:
    MSI 3080 Gaming X
    I also had massive stuttering indoors and some outdoors.
    Indoors stuttering fix : Use Dxtory framelimiter (I use 60 but Ill try 59 to see if it's better) or MSI Afterburner limiter, although that one hasn't worked for me.
    Outdoor stuttering fix : Remove Skyrim HD (I'm positive the stuttering comes from VRAM swapping due to large textures. I did use the Lite version but apparently my cards cant cope). I've beginning to reinstall Skyrim just to make sure that I have the pure vanilla version before I start modding.
     
  7. XTORO

    XTORO Member

    Messages:
    24
    Likes Received:
    0
    GPU:
    Radeon HD 7690M XT
    Turn on your vsync
     
  8. adrock311

    adrock311 Master Guru

    Messages:
    793
    Likes Received:
    0
    GPU:
    EVGA GTX 1070 SC 8gb


    you are not alone. I have the exact same problem, windowed performance is MUCH smoother than fullscreen. the way i learned to live with it is using a mod which makes windowed mode look exactly like full screen.

    http://skyrim.nexusmods.com/downloads/file.php?id=4


    try that.

    and its idiotic that we should have to do this.
     
  9. Del_Boy

    Del_Boy Banned

    Messages:
    457
    Likes Received:
    0
    GPU:
    MSI R9 290 (2560x1600)
    Yeah ive experienced this amongst a vast multitude of other problems, crossfire flickering for one (frown), anyways i think there's a mod that puts windowed mode to full screen, but i don't agree with this because you shouldn't have to do it.

    Me personally have uninstalled skyrim for the foreseeable future until everything is fixed, which is a shame because i waited so long for this game to come out and when it does its as broken as hell, even with the new 1.4 patch. But on the plus side heres some boobs:-:boob:
     
  10. Raiga

    Raiga Maha Guru

    Messages:
    1,099
    Likes Received:
    0
    GPU:
    GPU
    Strangely, the game runs fine with fullscreen on my system. Also its better than using the tool to play in Window Mode, as the window mode has a bit longer loading times on my system and I have the steam folder on an SSD.

    (AMD 6950 2GB)
     

  11. morbias

    morbias Don TazeMeBro Staff Member

    Messages:
    13,445
    Likes Received:
    37
    GPU:
    -
    I was having this problem, it happened for me in Deus Ex 3 also. vsync + framelimiter set to 60 in MSI Afterburner completely fixed it, even when the fps was lower than 60.
     
  12. adrock311

    adrock311 Master Guru

    Messages:
    793
    Likes Received:
    0
    GPU:
    EVGA GTX 1070 SC 8gb
    Yes, I believe the reason this problem happens more on indoor areas is that the framerate is actually TOO HIGH and turning around becomes jerky because of that for some reason.
     
  13. Dch48

    Dch48 Ancient Guru

    Messages:
    1,822
    Likes Received:
    1
    GPU:
    Sapphire Nitro+ RX 470 4g
    I never had any stuttering before the 1.4 patch but the first time I tried playing after it, I had much better framerates everywhere and no stuttering in cities. Outside, however the stuttering was very bad while traveling. I was considering the mod but went in game yesterday and everything is back to normal with no stutters anywhere. The only mod I use is one that puts an enchanting table in Breezehome. I won't use any mod that requires a script extender or that uses a different way of launching the game and I have never used anything like Afterburner or Radeon Pro since I don't believe in overclocking anything and have never had crossfire.

    Maybe the stuttering was caused by the program I use to see the framerate, Playclaw. I like it better than FRAPS but it still causes too much of a performance hit to capture video with it. Then I get massive stutterering. Tne second time I played after the patch, Playclaw was not running. If I'm satisfied with the way the game is performing, I really couldn't care less what my fps is. The game plays very well at anything over 25 and is even playable when it dips below that.
     
  14. Skinner

    Skinner Master Guru

    Messages:
    506
    Likes Received:
    40
    GPU:
    MSI SuprimX RTX3090
    Same here, alltough framerate is great, it stutter outdoors esp. just after a reload, it goes away after a few seconds.
    Indoors I get microstuttering, it looks almost like there is framerate skipping.

    Have this also in BF3, framrates are high, but it's not smooth, esp. indoors.
    Nothing helps, just disabling CF.
     
  15. Mufflore

    Mufflore Ancient Guru

    Messages:
    13,040
    Likes Received:
    1,462
    GPU:
    Aorus 3090 Xtreme
    I've had more stutters since using the 1.4 patch.
    (I wasnt using Skyboost before)

    The worst one I got was today during a big army battle outside Whiterun.
    There was a lot of fog during the fight.

    The whole screen would flicker fast (maybe 10 flickers/second) between the game and a black screen, very regularly (every 3 or 4 seconds), sometime ending with 1/2 a second of frame loss, very annoying.
    It continued after the fight until...
    I found a nearby Nirnroot and plucked it.
    Instantly the game returned to normal.

    At other times, since applying this patch, I get higher framerates where it used to be low (as expected), but a bit too often when there are particles in the air, it isnt as smooth.
     

  16. Catch22law

    Catch22law New Member

    Messages:
    1
    Likes Received:
    0
    GPU:
    Saphire 5870 1gb cfx
    Hi All,

    Ive been a regular here for a while, but finally registered as I owe a big thank you to Neverwind whos advise resolved this issue for me.

    I had the same issue, microstutter indoors (breezehome was my test location) but occured in most indoor locations.

    I had tried all suggestion dxtory, stutter fixs on nexus with no joy, although windowed mode resolved the issue, I wasnt willing to implement as it killed crossfire (which wasnt an option for me)

    Downloaded latest MSI afterburner beta and capped at 59, 60 still had a slight stutter.

    Thanks again Neverwind, I can now start to enjoy this great game without feeling like Im have a fit everytime I go home :thumbup::thumbup::thumbup:
     
  17. adrock311

    adrock311 Master Guru

    Messages:
    793
    Likes Received:
    0
    GPU:
    EVGA GTX 1070 SC 8gb

    does the borderless windowed mod also kill crossfire?
     
  18. dove

    dove Master Guru

    Messages:
    312
    Likes Received:
    0
    GPU:
    Powercolor 6950 2GB
    I had terrible jerkiness in fullscreen mode (felt like pushing against treacle) so was using windowed mode with SBW quite happily until I realised that Skyrim sets the Gamma to minimum in windowed mode (equivalent to the Brightness slider being at minimum in fullscreen) which made Realistic Lighting unusable.

    However, I've just tested again and to my surprise find it's fine in fullscreen now. It may be the latest Skyboost that's helped or it may be the following edits I made to skyrim.ini:

    [General]
    uGridsToLoad=9
    uExterior Cell Buffer=100
    uInterior Cell Buffer=50
    fMasterFilePreLoadMB=128.0000
    iPreloadSizeLimit=268435456

    [Papyrus]
    iMaxMemoryPageSize=4096
    iMinMemoryPageSize=1024
    iMaxAllocatedMemoryBytes=3000000000
     
  19. Del_Boy

    Del_Boy Banned

    Messages:
    457
    Likes Received:
    0
    GPU:
    MSI R9 290 (2560x1600)
    incase you didn't know AMD have swept skyrim aside because they think they don't need to support it anymore because they claimed to have nailed it already, ??? they released a crossfire profile in a driver (11.11b) which F.O.B.A.R'ed the game with flickering for most users, and are ignoring all pleas to increase performance and fix CFX flickering.

    Sad thing is Nvidia have just released another skyrim performance driver which boost skyrim by 45%. < This AMD/Nvidia/skyrim driver thing is the pinicle of standards today, makes ya sick dont it, you have to choose expencive card with heavenly drivers, or cheaper card with awfully slow support and drivers.
     
    Last edited: Feb 26, 2012
  20. Del_Boy

    Del_Boy Banned

    Messages:
    457
    Likes Received:
    0
    GPU:
    MSI R9 290 (2560x1600)
    AMD Radeon headaches now gone for me, ive just ordered a Zotac GTX580
     

Share This Page