Skyrim crossfire fix petition.

Discussion in 'Videocards - AMD Radeon Catalyst Drivers Section' started by Del_Boy, Apr 24, 2012.

  1. Del_Boy

    Del_Boy Banned

    Messages:
    457
    Likes Received:
    0
    GPU:
    MSI R9 290 (2560x1600)
    Is there anyone out there who still suffers from bad scaling and/or flickering textures with crossfire enabled, with AMD whatever drivers ?

    We need to start a petition and send it to AMD (in the nicest possible way) for them to acknowledge and address the situation.

    ps. If you don't get flickering textures and have good scaling please dont :spam3: here just to say that you do.
     
    Last edited: Apr 24, 2012
  2. ipredator

    ipredator Master Guru

    Messages:
    542
    Likes Received:
    0
    GPU:
    Quadro K5000M
    Yes me. Whatever I do, if I leave it at default the texture flicker (with and without CAP's). lf I set it to AFR friendly the whole screen flickers yellow in the menu aswell as the face of the character.
     
  3. spajdrik

    spajdrik Maha Guru

    Messages:
    1,272
    Likes Received:
    2
    GPU:
    MSI Geforce GTX 960 2GB
    From my experience, if problem wasnt fixed for older generation of gfx cards in like 6 months, its already too late to hope that they will fix it (i mean for any problematic game on ATI/AMD cards). By the way, i would post this on RAGE3D forum, rather then here, since RAGE3D is more oriented towards AMD/ATI cards.
     
  4. Bestofbritish96

    Bestofbritish96 Member

    Messages:
    12
    Likes Received:
    0
    GPU:
    x3 XFX 7970
    3 x 7970's here.

    Flickering water, flying horses, the lot :(

    Hard to say if this is all driver related, it could be the game too.

    Whatever the cause, its killing my love for the game.
     

  5. chr!s

    chr!s Member Guru

    Messages:
    112
    Likes Received:
    0
    GPU:
    GTX 1080
    Hi,

    I've been playing skryrim for a while now ...

    I don't get flickering with my crossfire setup.
    (I used to get the "yellow" flickering on the map - but that was fixed few drivers ago...?)
    Using the 12.4 driver atm.

    However I do have micro stuttering. (this has been since the game came out - it think)

    I've got the issue where in "3rd person mode" there is no stuttering. But in "1st person mode" there is huge stutter - only indoors.
    There's a lot of threads on the net with similar issues.

    The best solution that I've come across was to play in window mode
    and because window mode is not really a "nice" way of playing ...
    ..I used one of those borderless window fixes/mods found on the skyrim nexusmods site
    (At least it removes the border and centers the window - so you can't notice the difference between full screen and window mode)


    Regards,
    Chris
     
  6. Bestofbritish96

    Bestofbritish96 Member

    Messages:
    12
    Likes Received:
    0
    GPU:
    x3 XFX 7970
    To be fair, apart from the Witcher 2, its the only game where I have had problems. All other games are fine.
     
  7. djamorpheus

    djamorpheus Active Member

    Messages:
    64
    Likes Received:
    0
    GPU:
    Gigabyte WF 670 2GB
    I had a crossfire 6850 setup and I did have yellow flickering on the map a few drivers ago but it was all fixed around the 12.1 driver. I believe the problem still exists for people with 6870x2 cards.
     
  8. streakpt

    streakpt Master Guru

    Messages:
    277
    Likes Received:
    0
    GPU:
    Sapphire 290 Crossfire
    I bought skyrim and its the only game i have issues with... but also it depends on the drivers.
     
  9. ipredator

    ipredator Master Guru

    Messages:
    542
    Likes Received:
    0
    GPU:
    Quadro K5000M
    Playing in windowed mode disables Crossfire --> no option
     
  10. rflair

    rflair Don Commisso Staff Member

    Messages:
    3,771
    Likes Received:
    4
    GPU:
    GTX 980/290X
    I don't run a crossfire setup but one thing did happen to me with this game, when it was first released I tweaked the command file to allow for more vegetation and such things and set it to read-only, when the game was later patch I got the odd flickering texture, apparently there were changes made to how the command file was written and with the file set to read-only it wasn't updated properly, once I deleted it and let the game recreate it the game ran fine.

    I'm sure most of you guys with this problem have tried everything and wish your petition the best.
     
    Last edited: Apr 24, 2012

  11. Lowki

    Lowki Master Guru

    Messages:
    608
    Likes Received:
    0
    GPU:
    evga 980 classified
    I think this should be changed to amd fix for skyrim I had a cf setup 6850 upgraded to. 7970 and all the micro stutter I got indoors is still presant on my single gpu configuration. So my point being amd needs a fix in genral.
     
  12. WhiteLightning

    WhiteLightning Don Illuminati Staff Member

    Messages:
    26,666
    Likes Received:
    34
    GPU:
    Inno3d GTX 1070 iChill x4
    What command is that ?
     
  13. ipredator

    ipredator Master Guru

    Messages:
    542
    Likes Received:
    0
    GPU:
    Quadro K5000M
    rflair, I initially believed that was the issue for me too, but a fresh install of the game and later on a fresh windows 8 install & fresh skyrim install proved me wrong :( Its 100% related to the driver
    As I found on this site: "If you try to enter the quest menu the screen will flicker, because it's loading two separate frame buffers from each card. Nothing you can really do about it without having to modify the drivers :("
     
  14. chr!s

    chr!s Member Guru

    Messages:
    112
    Likes Received:
    0
    GPU:
    GTX 1080
    okay -
    1) how can i confirm that (MSI Afterburner OSD ?)
    2) the interesting thing is - I've disabled crossfire (using radeon pro) and there is still stutter using one card, - it however was an improvement - but still there.

    What baffles me is that 3rd person (full screen, therefore will assuming CFX is working) is 100% smooth?
     
  15. rflair

    rflair Don Commisso Staff Member

    Messages:
    3,771
    Likes Received:
    4
    GPU:
    GTX 980/290X
    I believe you guys.

    It was just something that happened to me and was easily fixed.
     

  16. rflair

    rflair Don Commisso Staff Member

    Messages:
    3,771
    Likes Received:
    4
    GPU:
    GTX 980/290X
    Was the skyrimprefs.ini I believe, you know where you could set the draw distance for things like grass and trees and their density.
     
  17. ipredator

    ipredator Master Guru

    Messages:
    542
    Likes Received:
    0
    GPU:
    Quadro K5000M
    1) Yeah just run Afterburner, go to Settings and in the OSD tab check both GPU's load and check the "Display in OSD" on each a few lines below.

    2) Its the notorious 64hz bug, google it for more information. It's an issue with Skyrim's engine, has been there in Fallout too.
     
  18. adrock311

    adrock311 Master Guru

    Messages:
    791
    Likes Received:
    0
    GPU:
    EVGA GTX 1070 SC 8gb
    signed.
     
  19. xoleras

    xoleras Active Member

    Messages:
    61
    Likes Received:
    0
    GPU:
    msi lightning gtx 580 sli
    Its been said a million times, flickering happens on all hardware IF YOU TURN VSYNC OFF in skyrim. DO NOT TURN VSYNC OFF IN SKYRIM.

    The vsync in skyrim is tied to the physics engine and you CANNOT turn it off for play, turn vsync on and the flickering will be gone. This happens on geforce cards as well. In fact, you can youtube it and find numerous videos of flickering on geforce cards with vsync off in skyrim. You can turn vsync off in other games but NOT SKYRIM.

    Happens on the geforce 680 here, also happened on my 680s: Here you can see skyrim flickering on the GTX 680 at the 9 minute mark. Just goes to show you guys are quick to blame drivers but the game engine is to blame.

    http://www.youtube.com/watch?v=IaPYEOUH7LE

    point is TURN VSYNC ON IN SKYRIM, problem solved.
     
    Last edited: Apr 24, 2012
  20. ipredator

    ipredator Master Guru

    Messages:
    542
    Likes Received:
    0
    GPU:
    Quadro K5000M
    Last edited: Apr 24, 2012

Share This Page