Skyim 7970 Stutter

Discussion in 'Videocards - AMD Radeon' started by NobleKing, Jan 12, 2012.

  1. NobleKing

    NobleKing Active Member

    Messages:
    57
    Likes Received:
    0
    GPU:
    EVGA GTX 780 SC ACX
    Even when Skyim is locked at 60 fps vsynced. I am getting stutter when turning this is only happening in Full Screen Mode. Window Mode its perfectly smooth. Anyone else having this issue?





    System Specs i7 2700k 4.7ghz
    8GB Ram
    Radeon 7970
    8.921.2.0 11.12 Catalyst
     
  2. LordJummy

    LordJummy Master Guru

    Messages:
    279
    Likes Received:
    0
    GPU:
    Crossfire "6970" 980/1400
    What kind of stuttering are you getting exactly?

    Is it similar to horizontal tearing? Or is it just stuttering frames similar to microstutter?
     
  3. [Drazio]

    [Drazio] Master Guru

    Messages:
    202
    Likes Received:
    0
    GPU:
    -
    Yeah, I hear it's a common issue on this game.

    Source
     
  4. zshulko

    zshulko Member

    Messages:
    18
    Likes Received:
    0
    GPU:
    Sapphire 5970 + 5850
    This fixed my issues with annoying microstuttering.

    With Vsync enabled in game...

    -download and install DXtory program.
    -Configure DXTORY so tesv.exe is limiting frame rates to 60.
    -If you have MSI Afterburner running... Shut it down..

    1. If i run withought afterburner and DXtory i get 60FPS with Microstuttering
    2. If i run with DXTORY and Afterburner i get 60FPS with Microstuttering
    3. If I run with DXTory alone i get 60FPS ... Nice and smooth

    This microstuttring is most noticable indoors where there is lots of light.. Where your machine is able to easily pump out, perhaps, 100's of FPS, but VSYNC limits to 60FPS so you get the Microstuttering... Almost looks like a vibration..
     

  5. NobleKing

    NobleKing Active Member

    Messages:
    57
    Likes Received:
    0
    GPU:
    EVGA GTX 780 SC ACX
    DXtory is not fixing the problem. My GTX 580 does not have any of this microstutter in skyrim. I also get the same microstutter in Witcher 2. Whenever I pan the camera it shakes a bit and lags. If I cant fix this problem I'm sticking with the gtx 580.
     
  6. Elder III

    Elder III Ancient Guru

    Messages:
    3,660
    Likes Received:
    253
    GPU:
    Both Red and Green
    Is Mouse Acceleration disabled?
     
  7. NobleKing

    NobleKing Active Member

    Messages:
    57
    Likes Received:
    0
    GPU:
    EVGA GTX 780 SC ACX
    Yes its disabled. I also tried it with a 360 controller and it still stutters just as bad. I went ahead and uninstalled my 7970 and drivers. I reinstalled the GTX 580 290.53 drivers. Everything is now smooth as butter. I may get more fps with the 7970 especially in games like crysis warhead, and crysis 2, however being that 2 games witcher 2 and skyrim stutter for me its not worth it for me to wait it out for better drivers. I'm returning this card back to amazon. Thanks everyone for trying to help.
     
  8. bryonhowley

    bryonhowley Member Guru

    Messages:
    109
    Likes Received:
    0
    GPU:
    Gigabyte GTX 670 SLI
    I just got my 7970 Monday but so far no problems with Skyrim or The Witcher 2. Vsyc on aswell as Mouse Acceleration every game plays great on my AMD rig.

    OS: Windows 7 x64
    CPU: AMD FX-8120 8-Core Black Edition : Motherboard: MSI 890FXA-GD70
    Case: In Win Dragon Rider : Video Card: 2x SAPPHIRE HD 6950 (flash to 6970) 2GB
    Monitors: 3x Asus VK278Q Black 27 : Memory: G.SKILL Ripjaws Series 8GB DDR3 1600
    SSD: OCZ Vertex 2 3.5" 90GB : HDD: 5x Western Digital Caviar Green 3TB 64MB Cache
    Optical Drive: LG WH10LS30K 10X Blu-ray Burner : Mouse: Logitech Performance Mouse MX
    Keyboard: Logitech G19 Gaming Keyboard
    Water Cooler: XSPC Rasa 750 RS240​
     
  9. Shebeski

    Shebeski New Member

    Messages:
    8
    Likes Received:
    0
    GPU:
    EVGA GTX 570 850MHz
    This is just a problem with AMD

    I switched over to an AMD 6950 for 2 weeks from a GTX 570 and got the exact same problems in both titles. Limiting the framerate to less than 60FPS fixes the issue. Use Dxtory. I'm pretty sure limiting to 60 doesn't fix it. Try 55.

    This is why I'll never buy an AMD card. My friend got his card back by the way.
     
  10. NobleKing

    NobleKing Active Member

    Messages:
    57
    Likes Received:
    0
    GPU:
    EVGA GTX 780 SC ACX
    Ok Dxtory pretty much fixes the stuttering, however I feel I shouldn't have to use a 3rd party program to fix a problem on AMD's side. My GTX 580 does not need any 3rd party program to function properly.
     

  11. Supertribble

    Supertribble Master Guru

    Messages:
    639
    Likes Received:
    40
    GPU:
    1080Ti/RadVII/2070S
    The so-called microstuttering is actually frame skipping caused by the usual 64Hz bug that is a flaw within Gamebryo. The curious thing with Skyrim is that it only affects AMD cards this time.
     
  12. Saad

    Saad Master Guru

    Messages:
    289
    Likes Received:
    0
    GPU:
    Amd Radeon 6970 crossfire
    Thats weird i get no stuttering..i play with v-sync on, 60hz 1080p...using just one 6970 @ default clocks...processor @ 5ghz..crossfire still doesnt work..well dont really need it anyway
     
  13. Pill Monster

    Pill Monster Banned

    Messages:
    25,216
    Likes Received:
    7
    GPU:
    7950 Vapor-X 1100/1500
    No stutter here...
     
  14. Netherwind

    Netherwind Ancient Guru

    Messages:
    7,202
    Likes Received:
    1,233
    GPU:
    MSI RTX 2080Ti
    Dxtory fixed such stuttering for me (caves, corners, looking down on the ground but no stuttering while outdoors). I know that MSI Afterburner also has an FPS limiter (which is what DXtory does) and I'll try MSI more after work.

    By the way, I'm getting flashing menu screen and 35fps at the intro exectution scene with dual 5850s, 11.12 / 11.12 CAP2. GPU1 activity ~80%, GPU2 activity ~50%. Bad! But I guess cities are still an FPS hog?
     
  15. Raiga

    Raiga Maha Guru

    Messages:
    1,099
    Likes Received:
    0
    GPU:
    GPU
    Yeah, I got the almost the same GPU, similar CPU as Pill..no shuttering.

    I also think the shuttering issue on AMD is tied to render ahead, increasing it will fix it. (but the option is non-existent on AMD drivers sadly, but present on Nvidia ones)
     

  16. Metz

    Metz Master Guru

    Messages:
    229
    Likes Received:
    0
    GPU:
    2x 5850 TOP CF
    I used to get TERRIBLE microstuttering when I used ASUS Smart Doctor, Especially in 3dmark benches where one card would always "look" smoother. Possible Afterburner is conflicting in CFX mode for whatever reason with some games.
     
  17. slckb0y

    slckb0y Banned

    Messages:
    758
    Likes Received:
    0
    GPU:
    GV-N470SO-13I@900/2000 x3
    got nvidia setup, got the exact same problem. perfectly smooth in donjon and when i'm running straight but when i turn i got hickup of sometime 1 second if not worst sometimes.

    i'm using a every hd texture i could put my hand on but not sure it's the problem, may try to defrag my disk in case the lag is caused by the texture streaming but i'd rather go with poor engine optimisation ...
     
  18. Maximus7724

    Maximus7724 Master Guru

    Messages:
    448
    Likes Received:
    0
    GPU:
    AMD 7950 PCS+ @ 1150/1500
    Got to say if im changing card brands i always do a windows reinstall.
     
  19. ScoobyDooby

    ScoobyDooby Ancient Guru

    Messages:
    7,103
    Likes Received:
    70
    GPU:
    1080Ti & Acer X34
    I had this problem and still would if I tried to play full screen.

    What's weird is that on my initial install of the game, I made a whole bunch of adjustments to the ini files and implemented other fixes like ENG Deepfreeze and at the time the 4gb hack. Somehow I got the game to run perfectly on full screen.. not sure how I did that, but then I was force to reinstall the game and in doing so lost all the settings.

    After that I struggled to get it working smoothly again. I have it running as good as it can right now, but I use SBW hack from Skyrimnexus. You have to set the options in the launcher so that Skyrim opens in windowed mode, then when you launch SBW it will launch skyrim in windowed mode, and then within about 10 seconds it maximizes it to full screen. Its still actually performing in windowed mode however, and performance is smooth. Also, I prefer forcing aa and af through CCC, not through the skyrim launcher..
     
    Last edited: Jan 16, 2012
  20. Floppington

    Floppington New Member

    Messages:
    1
    Likes Received:
    0
    GPU:
    HD7970 @ 1125/1575
    I had this problem as well, where it would stutter when I turn. I was able to fix this by disabling vsync. Did this by adding iPresentInterval=0 under the heading of [Display] in my SkyrimPrefs.ini
     

Share This Page